Bug 997630 - RFE: an option to format bug numbers compatible with Bugzilla autolinkification
RFE: an option to format bug numbers compatible with Bugzilla autolinkification
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: python-bugzilla (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 16:05 EDT by Steve Tyler
Modified: 2013-10-28 13:52 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-28 13:52:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Tyler 2013-08-15 16:05:02 EDT
Description of problem:
The current bug numbers returned by bugzilla have the format "#NNNNNN".

This format is incompatible with Bugzilla autolinkification, which automatically generates internal bug links from strings with the format "Bug NNNNNN". This Bugzilla feature is documented here:

Chapter 5. Using Bugzilla
5.8.1. Autolinkification
https://bugzilla.redhat.com/docs/en/html/hintsandtips.html

This RFE would add a command-line option to output bug numbers in a BZ compatible format.

See Bug 981120, Comment 16 for an actual use-case that required the use of a sed script to replace the "#" with the string "Bug " before pasting the query results into a bug comment.

Obviously, those six bug numbers could have been changed in a text editor by doing a search and replace, but that is a burden that even expert users might not want to take on. Here is an example of a bug number that is not linked, because it is not in a BZ compatible format:
Bug 986069 - AttributeError: 'F18_Url' object has no attribute 'partition' 

Additional info:

This RFE addresses the concerns about backward compatibility with parsers of bugzilla output expressed in Bug 995494, Comment 8:

Bug 995494 - "#NNNNNN" bug id format in query output not compatible with Bugzilla autolinkification

An alternative approach would be to enhance Bugzilla to autolinkify bug numbers of the form "#NNNNNN".

BTW, the format "#NNNNNN" is redundant, since "#" means "number" in this context.
Comment 1 Cole Robinson 2013-10-28 13:52:32 EDT
I think this would be a reasonable enhancement to add, but I'm not personally interested in implementing it. If you want to follow up, please take this to the upstream mailing list where more interested parties are watching.

Note You need to log in before you can comment on or make changes to this bug.