Bug 998080 - kernel panic with broadcom wifi hardware causes system freeze
kernel panic with broadcom wifi hardware causes system freeze
Status: CLOSED DUPLICATE of bug 989269
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 998234 998719 999137 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-17 01:25 EDT by Ankur Sinha (FranciscoD)
Modified: 2013-08-23 19:06 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-21 08:40:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
image of stack trace (2.76 MB, image/jpeg)
2013-08-17 01:25 EDT, Ankur Sinha (FranciscoD)
no flags Details

  None (edit)
Description Ankur Sinha (FranciscoD) 2013-08-17 01:25:36 EDT
Created attachment 787507 [details]
image of stack trace

Description of problem:
Updating to 3.10 kernels caused system freezes on boot as soon as i logged in to gnome. after some investigation, inreceived

Version-Release number of selected component (if applicable):
kernel-3.10.7-200.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1.update to problematic kernel
2.boot with wifi enabled
3.

Actual results:
system freezes. kernel crashes 

Expected results:
should work normally

Additional info:
screenshot of stacktrace attached
Comment 1 Ankur Sinha (FranciscoD) 2013-08-17 01:32:40 EDT
Apologies for the unclear image. My camera phone was all that I had handy during the crash.
Comment 2 Ankur Sinha (FranciscoD) 2013-08-17 22:03:46 EDT
Appears to be also be reported in other distributions. This link says it's a "divide by zero" error:

http://www.spinics.net/lists/linux-wireless/msg111165.html

https://bbs.archlinux.org/viewtopic.php?pid=1312140

I haven't been able to try a newer kernel than 3.10.x yet, since it crashes immediately on activating wifi.  A hard shutdown caused disk errors last time and I hade to reinstall Fedora from scratch :/

Thanks,
Ankur
Comment 3 Josh Boyer 2013-08-19 11:34:09 EDT
*** Bug 998234 has been marked as a duplicate of this bug. ***
Comment 4 Edgar Bertoti 2013-08-19 15:21:00 EDT
The same kernel panic occurs to me with wifi enabled. Previous kernels (kernel-3.10.5-201.fc19.x86_64 and kernel-3.10.4-300.fc19.x86_64) are working good, the 3.10.6 kernel was the first that produced the same kernel panic as this 3.10.7 kernel.
Comment 5 Josh Boyer 2013-08-20 08:30:38 EDT
*** Bug 998719 has been marked as a duplicate of this bug. ***
Comment 6 Marcos Martins da Silva 2013-08-20 09:04:53 EDT
Same here. kernel-3.10.5-201.fc19.x86_64 and kernel-3.10.4-300.fc19.x86_64 work good in my machine.
Comment 7 Cristián Rojas 2013-08-20 09:50:28 EDT
This affects me as well. I'm running Fedora 19 on a Dell Inspiron 14z. The issue appears when I try to authenticate to a wireless network. I currently use the 3.10.5, 3.10.6 and 3.10.7 kernels, and the issue occurs when I use the 3.10.6 and 3.10.7 kernels.
Comment 8 Stas Ashirov 2013-08-20 11:18:51 EDT
Confirm. Kernel panic on my MacBook Air, Broadcom BCM43224, kernel-3.10.7-200.fc19.x86_64. Previous kernels are working good.
Comment 9 Josh Boyer 2013-08-20 16:57:24 EDT
*** Bug 999137 has been marked as a duplicate of this bug. ***
Comment 10 Josh Boyer 2013-08-21 08:40:37 EDT

*** This bug has been marked as a duplicate of bug 989269 ***
Comment 11 Marcos Martins da Silva 2013-08-23 19:06:48 EDT
New update to kernel 3.10.9-200.fc19.x86_64 restored sanity. This version is working good for me. Thank you!

Note You need to log in before you can comment on or make changes to this bug.