This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 998542 - (SDDMDefault) SDDM as the default KDE display manager instead of KDM
SDDM as the default KDE display manager instead of KDM
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Bříza
Robert Krátký
ChangeAcceptedF21
: Tracking
Depends On: 1148659 997187 998978 1003619 1007065 1007067 1015048 1112841 1123506 1128463 1128465
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 09:44 EDT by Jaroslav Reznik
Modified: 2014-12-08 10:22 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1008223 1008224 (view as bug list)
Environment:
Last Closed: 2014-12-08 10:22:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
rkratky: fedora_requires_release_note+


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2013-08-19 09:44:34 EDT
This is a tracking bug for Change: SDDM as the default KDE display manager instead of KDM
For more details, see: http://fedoraproject.org//wiki/Changes/SDDMinsteadOfKDM

Retire KDM as the default display manager of the KDE Fedora Spin in favor of SDDM.
Comment 1 Martin Bříza 2013-08-20 08:28:40 EDT
So far only installable from the repositories, will set it as the default as soon as possible.
Test with the steps described in http://fedoraproject.org//wiki/Changes/SDDMinsteadOfKDM#How_To_Test .
Comment 2 Martin Bříza 2013-08-27 07:39:46 EDT
SDDM is now installed as a part of @kde-desktop.
There aren't any live images of the spin yet but it's testable by adding the group (with --skip-broken because of broken deps in hugin) and graphics adapter drivers to the minimal install.
Comment 3 Jaroslav Reznik 2013-10-11 04:46:03 EDT
This message is a reminder that Fedora 20 Accepted Changes 100%
Completed Deadline is on 2013-10-15 [1].

All Accepted Changes has to be code complete and ready to be
validated in the Beta release (optionally by Fedora QA). Required
bug state at this point is ON_QA.

As for several System Wide Changes, Beta Change Deadline is a
point of contingency plan, all incomplete Changes will be 
reported to FESCo for 2013-10-16 meeting. In case of any
questions, don't hesitate to ask Wrangler (jreznik).

[1] https://fedoraproject.org/wiki/Releases/20/Schedule
Comment 4 Kevin Kofler 2013-10-15 11:40:36 EDT
We agreed at today's KDE SIG meeting that this change can be considered code complete.
Comment 5 Orion Poplawski 2013-10-16 12:33:29 EDT
Really?  It's currently not possible to log into an LDAP/NFS home directory account with SDDM (see bug 1007067 that blocks this).  That's a show stopper for me.
Comment 6 Mike Chambers 2013-10-16 13:18:45 EDT
What about auto login? I guess this is a want and not need, but it exited in KDM but no way to see how to do it via ssdm?
Comment 7 Rex Dieter 2013-10-16 13:22:41 EDT
autologin is supported, else the kde live images wouldn't work. :)
Comment 8 Kevin Kofler 2013-10-16 17:00:12 EDT
Orion, "code complete" means "testable", not "bug-free".
Comment 9 Martin Bříza 2013-10-17 05:08:32 EDT
Hi Orion and Mike,
You can set auto login by using the AutoUser value in the /etc/sddm.conf configuration file. This will also be possible by using the SDDM KCM module (KDE System Settings) when the review for the module is done - Bug 1019453.
I'm starting with fixing the LDAP login today.
Comment 10 Jaroslav Reznik 2013-10-17 06:25:26 EDT
Btw. it's still possible to install and use KDM in cases where default SDDM is not enough powerful/bug free. This was of the requirements to accept SDDM as Change early for F20.
Comment 11 Mike Chambers 2013-10-17 11:42:26 EDT
I set AutoUser=mike but from the computer off to turning it on, it doesn't auto login and have to do it manually.

Also, with above set, and once already in kde desktop, when go to click on start button/leave/shutdown or restart, the workspace exits but it comes right back instead of doing either one.  In other words, it does NOT restart or shutdown, but automatically logs back into the kde desktop.
Comment 12 Mike Chambers 2013-10-17 11:43:37 EDT
Current version is sddm-0.2.0-0.13.20130914git50ca5b20.fc20.x86_64, forgot to add that as think it updated this morning.
Comment 13 Rex Dieter 2013-10-17 11:47:46 EDT
FYI, this is a bugzilla tracking bug only.

For particular bugs, please file those separately, and we can set it to block this one.

For support issues (like how to configure auto-login), please use something more appropriate, mailing list (devel or kde list), irc (#fedora-kde), whatever, see also:
https://fedoraproject.org/wiki/Communicating_and_getting_help
Comment 14 Jaroslav Reznik 2013-11-26 10:52:13 EST
#agreed sddm blocker bugs not safely resolvable, revert to kdm for f20, push sddm feature back to f21
Comment 15 Martin Bříza 2014-06-24 05:46:11 EDT
Bug 1112549 is not a blocker of this change. The change means SDDM will already be installed, no further actions are required from the user. If (s)he decides to switch back to KDM, the instructions how to do it are part of the release notes, including the necessary service enabling.
Comment 16 Greg` 2014-10-03 22:15:25 EDT
i think sddm 0.9.0 is out, any chance of an update to it?
Comment 17 Greg` 2014-10-03 22:17:18 EDT
(In reply to Greg` from comment #16)
> i think sddm 0.9.0 is out, any chance of an update to it?

https://github.com/sddm/sddm/blob/master/ChangeLog
Comment 18 Orion Poplawski 2014-10-04 21:07:54 EDT
Well, when I compiled and installed a 0.9.0 rpm locally, all I get is a blank white screen.  So things aren't looking better there.  Seems to be a commonly reported problem on the sddm github page.
Comment 19 Valerio De Angelis 2014-10-10 18:44:04 EDT
Tried right now the version sddm-0.9.0-2.20141007git6a28c29b.fc20, I have a two screen configuration (laptop + external monitor).
It works perfectly.
Comment 20 Petr Bokoc 2014-10-20 11:34:41 EDT
Hi Martin,

Is this change going to make it to Fedora 21? I'm asking because we need to finish writing the Release Notes and this bug's status is still on NEW. If SDDM is now indeed the default DM for KDE, we'll need to document it.
Comment 21 Martin Bříza 2014-10-21 10:32:20 EDT
Yes, sorry, forgot to change the status of the change. The code is complete.
Comment 22 Robert Krátký 2014-10-21 12:18:16 EDT
I wrote a short blurb about this for the RNs. Could you please have a look, Martin?

https://fedoraproject.org/wiki/Documentation_Desktop_Beat#KDE_4.14_and_SDDM
Comment 23 Martin Bříza 2014-10-22 06:49:04 EDT
Seems fine, thank you Robert

Note You need to log in before you can comment on or make changes to this bug.