This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 283631

Summary: kernel-2.6.23-0.169.rc5.git1.fc8 fails to boot: quickly cycles back to bios/grub
Product: [Fedora] Fedora Reporter: Tom London <selinux>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: amazarache, bloch, emcnabb, festchook, gnomeuser, greg, jones.peter, nicolas.mailhot, pdarga, quentin, sangu.fedora, scottt.tw, thethirddoorontheleft
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-09-10 14:48:16 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235703    

Description Tom London 2007-09-08 13:58:49 EDT
Description of problem:
kernel-2.6.23-0.169.rc5.git1.fc8 fails to boot for me (Thinkpad X60).

After the grub splash screen count down, I see a few text lines on the screen
for about half a second before it immediately reboots and I get the Thinkpad
startup screen.

Selecting kernel-2.6.23-0.164.rc5.fc8 from grub, the system boots fine.

Version-Release number of selected component (if applicable):
kernel-2.6.23-0.169.rc5.git1.fc8

How reproducible:
Every time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Will Woods 2007-09-08 17:36:29 EDT
*** Bug 283671 has been marked as a duplicate of this bug. ***
Comment 2 Will Woods 2007-09-08 17:38:18 EDT
On my Thinkpad, the kernel emits:

Booting: ABCDEFGHIJKLMNOPQ

waits a couple of seconds, and then reboots.
Comment 3 Tom London 2007-09-08 18:12:38 EDT
Probably not related, but removing this kernel package generates:

[root@localhost ~]# rpm -e kernel-2.6.23-0.169.rc5.git1.fc8
ls: cannot access /boot/initrd*kdump.img: No such file or directory
[root@localhost ~]# 
Comment 4 Roman 2007-09-09 03:08:29 EDT
Same problem on Acer TravelMate 2493NWLMi, selecting previous kernel
(kernel-2.6.23-0.43.rc0.git16.fc8) fix problem
Comment 5 Ronald Warsow 2007-09-09 09:10:05 EDT
reboots on a AMD X2 x86_64, also
Comment 6 Greg Dickie 2007-09-09 09:58:25 EDT
reboots on an ASUS P4P800 mobo as well. 
Comment 7 Will Woods 2007-09-09 10:48:09 EDT
*** Bug 283891 has been marked as a duplicate of this bug. ***
Comment 8 Nicolas Mailhot 2007-09-09 13:30:08 EDT
Reboots there too

 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
 Subsystem: Giga-byte Technology GA-K8N Ultra-9 Mainboard
Comment 9 Adrian Mazarache 2007-09-09 13:59:25 EDT
Here too

CPU: AMD 1607.311 MHz
Mobo: Asus K8N-VM
RAM memory: nVidia Corporation C51 Memory Controller (rev a2)
PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
VGA compatible controller: nVidia Corporation C51G [GeForce 6100] (rev a2)
Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport
Technology Configuration
Ethernet controller: Marvell Technology Group Ltd. 88w8335 [Libertas] 802.11b/g
Wireless (rev 03)
Comment 10 Quentin Armitage 2007-09-09 14:11:56 EDT
Same problem here too, on a Dell Latitude D800.

Have just downloaded from koji and installed
kernel-2.6.23-0.168.rc5.git1.fc8.i686, (only difference is patch
linux-2.6-x86-debug-boot.patch is not applied), and kernel boots without a problem.
Comment 11 Peter H. Jones 2007-09-10 00:48:06 EDT
*** Bug 284261 has been marked as a duplicate of this bug. ***
Comment 12 Peter H. Jones 2007-09-10 01:29:57 EDT
As suggested at
http://fedoraproject.org/wiki/KernelBugTriage , tried the following lines in
/boot/grub/grub.conf:

title Fedora (2.6.23-0.169.rc5.git1.fc8) debugging
        root (hd0,1)
        kernel /vmlinuz-2.6.23-0.169.rc5.git1.fc8 ro root=LABEL=/ rhgb
boot_delay=10000 vga=791 acpi=off nolapic noapic nohz=off earlyprintk=vga
nosoftlockup
        initrd /initrd-2.6.23-0.169.rc5.git1.fc8.img
t

I did not see any more information on the screen; computer cycles back to grub
screen.
Comment 13 Valent Turkovic 2007-09-10 01:49:38 EDT
here too on my HP Compaq NX7300 laptop...
just reboots...
Comment 14 Adam Huffman 2007-09-10 03:14:46 EDT
Same symptom on a Vaio SZ3
Comment 15 Peter H. Jones 2007-09-10 14:46:21 EDT
When trying the next version of the kernel, is it necessary to
rpm -e kernel-2.6.23-0.169.rc5.git1.fc8
before running the Software Updater, in order to continue to have
kernel-2.6.23-0.164.rc5.fc8 still available?

In other words, does the Software keep the currently-running kernel
(164) available in Grub, or does it keep the latest installed kernel
(169) as the "previous" one?
Comment 16 Chuck Ebbert 2007-09-10 14:48:16 EDT
Fixed in kernel-2.6.23-0.170.rc5.git1.fc8
Comment 17 Chuck Ebbert 2007-09-10 14:53:42 EDT
(In reply to comment #15)
> When trying the next version of the kernel, is it necessary to
> rpm -e kernel-2.6.23-0.169.rc5.git1.fc8
> before running the Software Updater, in order to continue to have
> kernel-2.6.23-0.164.rc5.fc8 still available?
> 
> In other words, does the Software keep the currently-running kernel
> (164) available in Grub, or does it keep the latest installed kernel
> (169) as the "previous" one?
> 

It keeps the latest one AFAIK.
Comment 18 Mark 2007-09-10 15:05:43 EDT
.170 fixed this issue for me.
can be downloaded here: http://koji.fedoraproject.org/koji/buildinfo?buildID=18240
Comment 19 Chuck Ebbert 2007-09-10 16:39:23 EDT
*** Bug 285081 has been marked as a duplicate of this bug. ***
Comment 20 Quentin Armitage 2007-09-10 19:52:57 EDT
(In reply to comment #15)
> When trying the next version of the kernel, is it necessary to
> rpm -e kernel-2.6.23-0.169.rc5.git1.fc8
> before running the Software Updater, in order to continue to have
> kernel-2.6.23-0.164.rc5.fc8 still available?
> 
> In other words, does the Software keep the currently-running kernel
> (164) available in Grub, or does it keep the latest installed kernel
> (169) as the "previous" one?
> 
To keep more versions of the kernel, and any other packages that are marked for
install only, as opposed to update, you can edit /etc/yum.conf and change
"installonly_limit=2" to "installonly_limit=n" where n is the number of kernel
versions you wish to keep installed. yum will always keep the newest n versions
of the package, regardless of the order in which they were installed, and
regardless of what version of the kernel is running.
Comment 21 Valent Turkovic 2007-09-19 13:53:23 EDT
after updating fedora with latest kernel for fedora devel I got finally a
working system.

My kernel is now:

]# uname -a
Linux rawhide 2.6.23-0.185.rc6.git7.fc8