Bug 429339

Summary: Thunderbird 2.0.0.9 fc8 binary incompatible with add-ons
Product: [Fedora] Fedora Reporter: Kai Engert (:kaie) (inactive account) <kengert>
Component: thunderbirdAssignee: Gecko Maintainer <gecko-bugs-nobody>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 8CC: gaveen.skyeye, holger.urbanek, mcepl
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-02-28 14:41:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Kai Engert (:kaie) (inactive account) 2008-01-18 19:54:33 UTC
I upgraded from fc7 to fc8, keeping /home
I installed thunderbird-2.0.0.9.fc8.i386
I installed the lightining 0.7 calendar addon

With that configuration, thunderbird looks "wrong".
There is an unexpected calendar pane on the left hand side.
The right hand side is "empty", you might call it even "distorted".
No information from my subscribed calendars is shown.

I suspect this is due to some binary INcompatibility.

I uninstalled the add-on from my profile.
I downloaded an official thunderbird 2.0.0.9 binary from ftp.mozilla.org
I started the mozilla.org thundebird and re-installed the add-on.

Now everything works as expected!

Comment 1 Kai Engert (:kaie) (inactive account) 2008-01-18 19:58:36 UTC
Interesting:

The compatibility might only be related to installation-time.

After I have used the official binary to install, I am able to run
thunderbird.fc8 and it works, too.


Comment 2 Kai Engert (:kaie) (inactive account) 2008-01-18 20:04:11 UTC
Ok, I understand now.

The lightning add-on comes with binaries.
Those binaries require old libstdc++.so.5

My system did not have that library when I first tried to run it.
So, I did not get any error messages on the console, all I got was the distorted UI.

When I tried to execute the thunderbird binary from mozilla.org, I noticed
libstdc++.so.5 is missing and installed compat-libstdc++

Once I had that library, the lightning plugin worked.


Comment 3 Matěj Cepl 2008-01-18 23:05:41 UTC
Don't know what to think about the idea to make thunderbird dependent on
compat-libstdc++. Caillon?

Comment 4 Kai Engert (:kaie) (inactive account) 2008-01-19 11:47:29 UTC
This bug should be extended to other Mozilla software as well.

For example, the Google toolbar extension for Firefox includes .so files, too,
and they require to the same old libstdc++.so.5

(While basic functionality of that extension seems to work with our firefox, I'm
sure there is some advanced functionality that won't work.)


Comment 5 Kai Engert (:kaie) (inactive account) 2008-01-19 11:56:21 UTC
I found another Linux extension, html-tidy, and it's indeed broken.
I even have a completely broken url-bar (always empty).

http://users.skynet.be/mgueury/mozilla/download.html
http://htmlvalidator.sourceforge.net/mozilla/tidy_firefox_linux_0843.xpi
http://users.skynet.be/mgueury/mozilla/faq.html#LINUX


Comment 6 Kai Engert (:kaie) (inactive account) 2008-01-20 23:35:36 UTC
If I understand correctly, it's considered unsafe to mix different versions of
c++ libraries in a process (risk of mixing alloc/free from different libs).


Comment 7 Matěj Cepl 2008-02-28 14:37:46 UTC
*** Bug 315111 has been marked as a duplicate of this bug. ***

Comment 8 Matěj Cepl 2008-02-28 14:37:58 UTC
*** Bug 245510 has been marked as a duplicate of this bug. ***

Comment 9 Matěj Cepl 2008-02-28 14:41:12 UTC

*** This bug has been marked as a duplicate of 237137 ***