Bug 459935

Summary: Stuck on Download boot images
Product: [Fedora] Fedora Reporter: Alexey Kuznetsov <axet>
Component: preupgradeAssignee: Seth Vidal <skvidal>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: b.peggs, cdahlin, chris.stone, dgoodwin, jeff, jesse.brandeburg, johannbg, kahrny+redhat, oded, os, razvan.sandu, sjoeboo, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: preupgrade-1.0.0-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-11-26 16:32:02 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Alexey Kuznetsov 2008-08-24 17:19:43 EDT
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 198, in on_assistant_apply
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 206, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 349, in main_preupgrade
    self.pu.retrieve_treeinfo()
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 395, in retrieve_treeinfo
    self.instimage = cp.get('stage2', 'instimage')
  File "/usr/lib/python2.5/ConfigParser.py", line 520, in get
    raise NoOptionError(option, section)
ConfigParser.NoOptionError: No option 'instimage' in section: 'stage2'
Comment 1 Matthew Nicholson 2008-09-10 15:57:34 EDT
I second this. Both with gui (preupgrade) and cli (preupgrade-cli)
Comment 2 Jeffrey C. Ollie 2008-09-14 08:35:26 EDT
I get the same traceback from the GUI (preupgrade-0.9.3-3.fc9.noarch)... retrying with the latest from the BZR repo...
Comment 3 Will Woods 2008-09-15 13:45:10 EDT
This will only happen if you're attempting to preupgrade to a tree that's got missing (or invalid) .treeinfo. So you're using a bad tree/mirror. You'll want to check on that.

I've added a check in the current bzr tree (rev 189) to make sure we handle this error properly. You should get a more useful error message if this happens in the future.
Comment 4 Will Woods 2008-09-17 12:37:47 EDT
*** Bug 462578 has been marked as a duplicate of this bug. ***
Comment 5 Jóhann B. Guðmundsson 2008-09-17 12:47:10 EDT
Is it possible to retry then against another mirror?

Perhaps fall back to the official one 
( http://download.fedoraproject.org/ )?
Comment 6 Zach Carter 2008-09-18 17:21:52 EDT
I have the same issue.   I tried pointing yum directly at download.fedoraproject.org, and got the same error again.  Is there a better workaround?
Comment 7 Jesse Brandeburg 2008-09-27 14:15:34 EDT
also occurs when using mirrors.kernel.org, upgrading from F9 to rawhide using rawhide version of preupgrade.  Probably just rawhide broken?

I don't see any obvious way to change the mirror that anaconda-preupgrade: uses.
Total size: 1.0 G
Download packages? 
Is this ok [y/N]: Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-cli.py", line 153, in <module>
    util = PreUpgradeCli()
  File "/usr/share/preupgrade/preupgrade-cli.py", line 40, in __init__
    self.main()
  File "/usr/share/preupgrade/preupgrade-cli.py", line 106, in main
    self.retrieve_treeinfo()
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 395, in retrieve_treeinfo
    self.instimage = cp.get('stage2', 'instimage')
  File "/usr/lib/python2.5/ConfigParser.py", line 520, in get
    raise NoOptionError(option, section)
ConfigParser.NoOptionError: No option 'instimage' in section: 'stage2'
Comment 8 Will Woods 2008-10-14 12:03:14 EDT
*** Bug 466878 has been marked as a duplicate of this bug. ***
Comment 9 Will Woods 2008-10-14 12:03:44 EDT
*** Bug 463433 has been marked as a duplicate of this bug. ***
Comment 10 Will Woods 2008-10-27 12:03:20 EDT
The metadata has changed somewhat since Fedora 9; this is handled in preupgrade-0.9.8 (which is available in updates-testing.)
Comment 11 Will Woods 2008-10-27 12:07:20 EDT
*** Bug 468710 has been marked as a duplicate of this bug. ***
Comment 12 Will Woods 2008-10-29 13:09:05 EDT
*** Bug 469006 has been marked as a duplicate of this bug. ***
Comment 13 Devan Goodwin 2008-11-09 15:36:03 EST
Using preupgrade 0.9.9 build obtained directly from Koji, I got past this issue.
Comment 14 Răzvan Sandu 2008-11-19 03:47:29 EST
On November 18, 2008, I've took a Fedora 9 system and tried to upgrade it to Fedora 10 (rawhide) via preupgrade.

All F9 online updates were applied prior of upgrading.

First phase (downloading) went OK, even it was very slow (there are no rawhide mirrors listed for Romania).

After reboot, I've got stuck in a (non-functional) grub prompt; I've used a F9 rescue disk to reinstall grub.

After that, upgrade completed OK.


(In the last months, I've frequently hit the situation in which a F9 system goes in a grub prompt after online updates, needing grub reinstall with a rescue disk. IMHO, this is not a preupgrade matter, since I was doing regular online updates, via yum, inside the *same version* of the distro - no preupgrade involved. Is this a grub matter ?)


Regards,
Răzvan
Comment 15 Will Woods 2008-11-26 16:31:08 EST
*** Bug 472905 has been marked as a duplicate of this bug. ***