Bug 517747

Summary: QtiPlot crashes when trying to plot any graph.
Product: [Fedora] Fedora Reporter: TNO-reg
Component: qtiplotAssignee: Frank Büttner <bugzilla>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: low    
Version: 11CC: bugzilla, ftbfs, ivg, lukasz.wojnilowicz, maslennikovdm, pavel.ondracka, supercyper1, yves.deblock
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: 0.9.7.11-5.fc12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-02-13 00:42:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 540838    
Bug Blocks:    
Attachments:
Description Flags
GNOME Bug-buddy crash report none

Description TNO-reg 2009-08-16 15:13:08 UTC
Created attachment 357580 [details]
GNOME Bug-buddy crash report

Description of problem: being installed from Fedora's repo, the program runs succesfully but crashes when trying to plot a graph.


Version-Release number of selected component (if applicable):
qtiplot-9.9-11.fc11 (i386)


How reproducible: always.


Steps to Reproduce:
1. Install the program: yum install qtiplot;
2. Fill the X and Y columns with whatever arbitrary numbers, they don't really matter; 
3. Select the columns and try to plot a graph, e.g., "Plot --> Line" (the exact type of graph doesn't matter).

  
Actual results: QtiPlot crashes.


Expected results: the program should work normally.


Additional info: looks like the package provided by Fedora's repository is obsolete and needs to be rebuild against the actual versions of it's dependencies. Also, the latest release version is 0.9.7.8, not 0.9-11, therefore an update would be desirable.

Comment 1 TNO-reg 2009-08-19 23:40:33 UTC
The version is 0.9-11.fc11, of course, 'tis a misprint above.

Comment 2 Dmitriy M Maslennikov 2009-08-20 12:31:23 UTC
Output from console:

$ qtiplot
qtiplot: Symbol `_ZTV9QwtSymbol' has different size in shared object, consider re-linking
qtiplot: Symbol `_ZTV13QwtPlotPicker' has different size in shared object, consider re-linking

Comment 3 Chen Lei 2010-01-25 03:59:57 UTC
*** Bug 538365 has been marked as a duplicate of this bug. ***

Comment 4 Chen Lei 2010-01-25 04:00:20 UTC
*** Bug 549805 has been marked as a duplicate of this bug. ***

Comment 5 Chen Lei 2010-01-25 04:00:33 UTC
*** Bug 548713 has been marked as a duplicate of this bug. ***

Comment 6 NSLW 2010-02-01 20:11:24 UTC
The same error on Fedora 12

Comment 7 Frank Büttner 2010-02-06 10:53:09 UTC
*** Bug 511688 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2010-02-06 18:02:51 UTC
qtiplot-0.9.7.11-5.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/qtiplot-0.9.7.11-5.fc12

Comment 9 Fedora Update System 2010-02-06 19:10:44 UTC
qtiplot-0.9.7.11-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qtiplot-0.9.7.11-5.fc11

Comment 10 Frank Büttner 2010-02-06 19:11:46 UTC
Please check if the new build will work.

Comment 11 Pavel Ondračka 2010-02-10 19:15:52 UTC
Great, it works now. Thank you.

Comment 12 Fedora Update System 2010-02-13 00:42:35 UTC
qtiplot-0.9.7.11-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2010-02-13 00:42:47 UTC
qtiplot-0.9.7.11-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.