Bug 569352

Summary: Broken dependencies for 1:openoffice.org-langpack-en-3.2.0-12.7.fc13.x86_64
Product: [Fedora] Fedora Reporter: Kamil Páral <kparal>
Component: yum-langpacksAssignee: Jens Petersen <petersen>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 13CC: braden, caolanm, cra, fabsh, feliciano.matias, fhimpe, i18n-bugs, idht4n, jlaska, kanelxake, manisandro, mattia.verga, petersen, pnemade, quentin, robatino, tagoh, tjkirch+redhat
Target Milestone: ---Keywords: CommonBugs
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: https://fedoraproject.org/wiki/Common_F13_bugs#PackageKit_silently_fails_to_update
Fixed In Version: yum-langpacks-0.1.5-1.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-04-16 19:51:16 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 507684    
Attachments:
Description Flags
yum update -v openoffice.org*
none
yum update openoffice.org*
none
yum update --disableplugin=langpacks openoffice.org*
none
yum update none

Description Kamil Páral 2010-03-01 07:06:25 EST
Created attachment 397046 [details]
yum update -v openoffice.org*

Description of problem:
Installed Fedora 13 Alpha RC4. After running yum update:

Error: Package: 1:openoffice.org-langpack-en-3.2.0-12.7.fc13.x86_64 (updates-testing)
           Requires: openoffice.org-core = 1:3.2.0-12.7.fc13
           Removing: 1:openoffice.org-core-3.2.0-12.6.fc13.x86_64 (installed)
           Available: 1:openoffice.org-core-3.2.0-12.7.fc13.x86_64 (updates-testing)
           Installing: 1:openoffice.org-core-3.2.0-12.8.fc13.x86_64 (fedora)

For full output see attached log.
Comment 1 Caolan McNamara 2010-03-01 07:29:17 EST
No problem here.

Checking deps for openoffice.org-langpack-en.x86_64 1:3.2.0-12.6.fc13 - None
---> Package openoffice.org-langpack-en.x86_64 1:3.2.0-12.8.fc13 set to be updated

All good, going from 3.2.0-12.6.fc13 to 3.2.0-12.8.fc13, but then later...

Dependency Process ending
Installing langpack for openoffice.org-core
Adding openoffice.org-langpack-en to transaction
Adding openoffice.org-langpack-en to transaction
--> Running transaction check
---> Package openoffice.org-langpack-en.x86_64 1:3.2.0-12.7.fc13 set to be updated

Doesn't seem to make a lot of sense to me, don't see why that would get selected when there's a later version already selected. I think there's some new langpack stuff in yum which might be the explanation for it.
Comment 2 Kamil Páral 2010-03-01 12:20:10 EST
You're right, it's the problem of yum-langpacks plugin. With the plugin enabled, I see the reported behaviour. With the plugin disabled, I can update openoffice* or install openoffice.org-langpack-en just fine.
Comment 3 Jens Petersen 2010-03-04 00:33:46 EST
I will try to investigate.

Adding to F13Blocker list as long as this is in @base.
Comment 4 Mattia Verga 2010-03-06 07:58:59 EST
As I suggested in [url=https://bugzilla.redhat.com/show_bug.cgi?id=568784]bug 568784[/url] I think this error is only related to openoffice 3.2.0-12.7. I had this problem trying to update from 3.2.0-12.6 to 3.2.0-12.7, but not to 3.2.0-12.8.

Today I also updated from 3.2.0-12.8 to 3.2.0-12.9 without any problem in dependencies check.

I suggest you to do a yum erase openoffice.org-langpack-en, then a yum update will update openoffice and install the needed langpack.
Comment 5 Féliciano Matias 2010-03-06 10:17:13 EST
(In reply to comment #4)
> As I suggested in [url=https://bugzilla.redhat.com/show_bug.cgi?id=568784]bug
> 568784[/url] I think this error is only related to openoffice 3.2.0-12.7. I had
> this problem trying to update from 3.2.0-12.6 to 3.2.0-12.7, but not to
> 3.2.0-12.8.
> 
> Today I also updated from 3.2.0-12.8 to 3.2.0-12.9 without any problem in
> dependencies check.
> 
> I suggest you to do a yum erase openoffice.org-langpack-en, then a yum update
> will update openoffice and install the needed langpack.    

I have this problem when updating from openoffice.org 3.2.0-12.9.fc13 to 3.2.0-12.10.fc13.

---------------------------------------------------
# cat /etc/yum/pluginconf.d/langpacks.conf 
[main]
enabled=1
langpack_locales = en, fr
# LANG=C yum update
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en, fr to language list
................
Installing langpack for openoffice.org-core
Adding openoffice.org-langpack-en to transaction
Adding openoffice.org-langpack-en to transaction
Adding openoffice.org-langpack-fr to transaction
Adding openoffice.org-langpack-fr to transaction
Installing langpack for hunspell
Adding hunspell-en to transaction
Adding hunspell-fr to transaction
--> Running transaction check
---> Package hunspell-en.noarch 0:0.20090216-7.fc12 set to be updated
---> Package hunspell-fr.noarch 0:3.5-1.fc13 set to be updated
---> Package openoffice.org-langpack-en.x86_64 1:3.2.0-12.9.fc13 set to be updated
--> Processing Dependency: openoffice.org-core = 1:3.2.0-12.9.fc13 for package: 1:openoffice.org-langpack-en-3.2.0-12.9.fc13.x86_64
---> Package openoffice.org-langpack-fr.x86_64 1:3.2.0-12.9.fc13 set to be updated
--> Processing Dependency: openoffice.org-core = 1:3.2.0-12.9.fc13 for package: 1:openoffice.org-langpack-fr-3.2.0-12.9.fc13.x86_64
--> Finished Dependency Resolution
Error: Package: 1:openoffice.org-langpack-fr-3.2.0-12.9.fc13.x86_64 (fedora)
           Requires: openoffice.org-core = 1:3.2.0-12.9.fc13
           Removing: 1:openoffice.org-core-3.2.0-12.9.fc13.x86_64 (@fedora)
           Installing: 1:openoffice.org-core-3.2.0-12.10.fc13.x86_64 (updates-testing)
Error: Package: 1:openoffice.org-langpack-en-3.2.0-12.9.fc13.x86_64 (fedora)
           Requires: openoffice.org-core = 1:3.2.0-12.9.fc13
           Removing: 1:openoffice.org-core-3.2.0-12.9.fc13.x86_64 (@fedora)
           Installing: 1:openoffice.org-core-3.2.0-12.10.fc13.x86_64 (updates-testing)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
---------------------------------------------------


It's OK if I disable yum-langpacks (openoffice.org-langpack-fr and openoffice.org-langpack-en are updated).
Comment 6 Mattia Verga 2010-03-06 12:14:18 EST
> I have this problem when updating from openoffice.org 3.2.0-12.9.fc13 to
> 3.2.0-12.10.fc13.
> 

You're right, I can reproduce the problem again by enabling the updates-testing repo. So maybe the error can be related to updating a package installed from a repo (fedora) with a package from another repo (updates-testing). When I did the updates that went fine in both case I updated from the fedora repo.

Moreover, enabling the updates-testing and doing an update give me another error related to langpack plugin:

18:06:50 : YUM: Installing langpack for hunspell

18:06:51 : YUM: Adding hunspell-it to transaction

18:06:51 : YUM: --> Esecuzione del controllo di transazione

18:06:51 : YUM: ---> Pacchetto hunspell-it.noarch 0:2.4-0.4.20070901.fc13 settato per essere aggiornato

18:06:51 : YUM: --> Risoluzione delle dipendenze terminata

18:06:53 : YUM: Esecuzione rpm_check_debug

18:06:55 : ERROR: Errore in yum Transaction: Errori nel test di transazione:   package hunspell-it-2.4-0.4.20070901.fc13.noarch is already installed

In this case the hunspell-it package already installed was from rawhide repo, but langpack seems to not recognize that is already there and tries to install the same version from updates-testing.
Comment 7 Féliciano Matias 2010-03-06 16:18:08 EST
(In reply to comment #6)
> In this case the hunspell-it package already installed was from rawhide repo,
> but langpack seems to not recognize that is already there and tries to install
> the same version from updates-testing.    

Strange, currently there is no hunspell-it in updates/testing (F13).
Can you check this ?
Comment 8 Féliciano Matias 2010-03-06 16:47:53 EST
Some tests.

* A fresh install with repo Rawhide (F13) and updates/testing (F13) enabled :
=> OK (openoffice.org-langpack-fr-3.2.0-12.10 & openoffice.org-langpack-en-3.2.0-12.10 are installed)


* A fresh install with repo Rawhide (F13) only enabled. After the installation repository Rawhide and updates/testing are enabled
------------------------------------
# cat /etc/yum/pluginconf.d/langpacks.conf 
[main]
enabled=1
langpack_locales = en, fr_FR
# yum repolist
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en, fr_FR to language list
repo id          repo name                          status
fedora           Fedora 13 - x86_64                 20265
updates-testing  Fedora 13 - x86_64 - Test Updates  1152
repolist: 21417
# repoquery --show-dupes openoffice.org-langpack-fr
openoffice.org-langpack-fr-1:3.2.0-12.9.fc13.x86_64   <== from repo fedora
openoffice.org-langpack-fr-1:3.2.0-12.10.fc13.x86_64  <== from repo updates-testing
# repoquery --show-dupes openoffice.org-langpack-en
openoffice.org-langpack-en-1:3.2.0-12.9.fc13.x86_64
openoffice.org-langpack-en-1:3.2.0-12.10.fc13.x86_64
# repoquery --disablerepo=fedora --show-dupes openoffice.org-langpack-fr
openoffice.org-langpack-fr-1:3.2.0-12.10.fc13.x86_64
# repoquery --disablerepo=fedora --show-dupes openoffice.org-langpack-en
openoffice.org-langpack-en-1:3.2.0-12.10.fc13.x86_64
# repoquery --show-dupes hunspell-fr
hunspell-fr-0:3.5-1.fc13.noarch
# repoquery --show-dupes hunspell-en
hunspell-en-0:0.20090216-7.fc12.noarch

# yum update
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en, fr_FR to language list
...
Installing langpack for openoffice.org-core
Adding openoffice.org-langpack-en to transaction  <== Added twice
Adding openoffice.org-langpack-en to transaction
Adding openoffice.org-langpack-fr to transaction  <== Added twice
Adding openoffice.org-langpack-fr to transaction
Installing langpack for hunspell
Adding hunspell-en to transaction                 <== Added once
Adding hunspell-fr to transaction                 <== Added once
--> Running transaction check
---> Package hunspell-en.noarch 0:0.20090216-7.fc12 set to be updated
---> Package hunspell-fr.noarch 0:3.5-1.fc13 set to be updated
---> Package openoffice.org-langpack-en.x86_64 1:3.2.0-12.9.fc13 set to be updated
--> Processing Dependency: openoffice.org-core = 1:3.2.0-12.9.fc13 for package: 1:openoffice.org-langpack-en-3.2.0-12.9.fc13.x86_64
---> Package openoffice.org-langpack-fr.x86_64 1:3.2.0-12.9.fc13 set to be updated
--> Processing Dependency: openoffice.org-core = 1:3.2.0-12.9.fc13 for package: 1:openoffice.org-langpack-fr-3.2.0-12.9.fc13.x86_64
--> Finished Dependency Resolution
Error: Package: 1:openoffice.org-langpack-fr-3.2.0-12.9.fc13.x86_64 (fedora)
           Requires: openoffice.org-core = 1:3.2.0-12.9.fc13
           Removing: 1:openoffice.org-core-3.2.0-12.9.fc13.x86_64 (installed)
           Installing: 1:openoffice.org-core-3.2.0-12.10.fc13.x86_64 (updates-testing)
Error: Package: 1:openoffice.org-langpack-en-3.2.0-12.9.fc13.x86_64 (fedora)
           Requires: openoffice.org-core = 1:3.2.0-12.9.fc13
           Removing: 1:openoffice.org-core-3.2.0-12.9.fc13.x86_64 (installed)
           Installing: 1:openoffice.org-core-3.2.0-12.10.fc13.x86_64 (updates-testing)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


# yum --disablerepo=fedora update
...
Error: Package: gegl-0.1.2-2.fc13.x86_64 (updates-testing)
           Requires: libSDL-1.2.so.0()(64bit)
Error: Package: gnome-dvb-daemon-0.1.14-4.fc13.x86_64 (updates-testing)
           Requires: dvb-apps
Error: Package: gnome-dvb-daemon-0.1.14-4.fc13.x86_64 (updates-testing)
           Requires: libgstrtspserver-0.10.so.0()(64bit)
# # ==> Expected missing dependencies
# # ==> trying openoffice.org* only
# yum --disablerepo=fedora update openoffice.org\*
...
Installing langpack for openoffice.org-core
Adding openoffice.org-langpack-en to transaction  <== Added once
Adding openoffice.org-langpack-fr to transaction  <== Added once

Dependencies Resolved     <== OK
...
Is this ok [y/N]: Exiting on user Command
...

# yum update openoffice.org\*
...
Installing langpack for openoffice.org-core
Adding openoffice.org-langpack-en to transaction  <== Added twice
Adding openoffice.org-langpack-en to transaction
Adding openoffice.org-langpack-fr to transaction  <== Added twice
Adding openoffice.org-langpack-fr to transaction
--> Running transaction check
---> Package openoffice.org-langpack-en.x86_64 1:3.2.0-12.9.fc13 set to be updated
--> Processing Dependency: openoffice.org-core = 1:3.2.0-12.9.fc13 for package: 1:openoffice.org-langpack-en-3.2.0-12.9.fc13.x86_64
---> Package openoffice.org-langpack-fr.x86_64 1:3.2.0-12.9.fc13 set to be updated
--> Processing Dependency: openoffice.org-core = 1:3.2.0-12.9.fc13 for package: 1:openoffice.org-langpack-fr-3.2.0-12.9.fc13.x86_64
--> Finished Dependency Resolution
Error: Package: 1:openoffice.org-langpack-fr-3.2.0-12.9.fc13.x86_64 (fedora)
           Requires: openoffice.org-core = 1:3.2.0-12.9.fc13
           Removing: 1:openoffice.org-core-3.2.0-12.9.fc13.x86_64 (installed)
           Installing: 1:openoffice.org-core-3.2.0-12.10.fc13.x86_64 (updates-testing)
Error: Package: 1:openoffice.org-langpack-en-3.2.0-12.9.fc13.x86_64 (fedora)
           Requires: openoffice.org-core = 1:3.2.0-12.9.fc13
           Removing: 1:openoffice.org-core-3.2.0-12.9.fc13.x86_64 (installed)
           Installing: 1:openoffice.org-core-3.2.0-12.10.fc13.x86_64 (updates-testing)

======================================

Create a new repository (fedora-all) with all packages from Rawhide (F13) and updates/testing (F13). Enable only the repository fedora-all.
# yum repolist
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en, fr_FR to language list
repo id     repo name         status
fedora-all  Fedora 13 (all) - x86_64   21417
repolist: 21417


Same issue with one repository (and --disablerepo is useless).
Comment 9 Mattia Verga 2010-03-07 04:10:13 EST
(In reply to comment #7)
> (In reply to comment #6)
> > In this case the hunspell-it package already installed was from rawhide repo,
> > but langpack seems to not recognize that is already there and tries to install
> > the same version from updates-testing.    
> 
> Strange, currently there is no hunspell-it in updates/testing (F13).
> Can you check this ?    

Yes, there's no hunspell-it update, but it tries to install that package because of hunspell update. In fact, the hunspell-it that it tries to install is the same version already installed in my system.
Comment 10 Féliciano Matias 2010-03-07 06:36:52 EST
(In reply to comment #9)
> (In reply to comment #7)
> > (In reply to comment #6)
> > > In this case the hunspell-it package already installed was from rawhide repo,
> > > but langpack seems to not recognize that is already there and tries to install
> > > the same version from updates-testing.    
> > 
> > Strange, currently there is no hunspell-it in updates/testing (F13).
> > Can you check this ?    
> 
> Yes, there's no hunspell-it update, but it tries to install that package
> because of hunspell update. In fact, the hunspell-it that it tries to install
> is the same version already installed in my system.    

OK.
Same problem here :
_____________________________________________________
# LANG=C yum -y update hunspell
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en, fr_FR to language list
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package hunspell.x86_64 0:1.2.8-17.fc13 set to be updated
--> Finished Dependency Resolution
Installing langpack for hunspell
Adding hunspell-en to transaction
Adding hunspell-fr to transaction
--> Running transaction check
---> Package hunspell-en.noarch 0:0.20090216-7.fc12 set to be updated
---> Package hunspell-fr.noarch 0:3.5-1.fc13 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package          Arch        Version                Repository            Size
================================================================================
Updating:
 hunspell         x86_64      1.2.8-17.fc13          updates-testing      177 k
Reinstalling:
 hunspell-en      noarch      0.20090216-7.fc12      fedora               353 k
 hunspell-fr      noarch      3.5-1.fc13             fedora               264 k

Transaction Summary
================================================================================
Install       0 Package(s)
Upgrade       1 Package(s)
Remove        0 Package(s)
Reinstall     2 Package(s)
Downgrade     0 Package(s)

Total download size: 794 k
Downloading Packages:
Setting up and reading Presto delta metadata
Processing delta metadata
Download delta size: 34 k
Presto reduced the update size by 81% (from 177 k to 34 k).
Package(s) data still to download: 617 k
--------------------------------------------------------------------------------
Total                                           132 kB/s | 617 kB     00:04
Running rpm_check_debug
Running Transaction Test


Transaction Check Error:
  package hunspell-en-0.20090216-7.fc12.noarch is already installed
  package hunspell-fr-3.5-1.fc13.noarch is already installed
_____________________________________________________

It seems the same issue as with openoffice.org, but an error is triggered later.
Comment 11 Peter Hjalmarsson 2010-03-07 12:01:27 EST
I hit his bug. I have no langpacks for openoffice installed more then en, and I have openoffice.org*-12.9 installed.

If I do a "yum install openoffice.org-langpack-sv" i builds a dep-chain with openoffice.org-langpack-sv-3.2.0-12.10 and wants to update the other packages as well from updates-testing. Then the langpacks plugin adds openoffice.org-langpack-sv-3.2.0-12.9 from "fedora", and the install fails.

For me the problem seem to be after adding a little print to /var/lib/yum-plugins/langpacks that the openoffice.org-langpack-sv packages gets added two times, one time with the installed version, and one time for the upgrade, and yums errors out because it has been told to remove one version of a package that it at the same time should upgrade to.

So (at least for me) the problem seem to be that langpacks acctually has no clue what it adds to the dep-list and/or yum does a bad job deciding if what langpacks adds is sane.
In a perfect world yum should only consider the newest of two deps if they fight for the same slot, and langpacks should only feed yum with one version per package.
Comment 12 Mattia Verga 2010-03-10 06:49:50 EST
Today both openoffice.org-core-3.2.0-12.10 and hunspell.x86_64 0:1.2.8-17 hit the fedora repo.
The openoffice update went fine without any langpack error, confirming my guess about the error to be related to updating from different repos. However I continue to get "package hunspell-it-2.4-0.4.20070901.fc13.noarch is already installed" like reported also by Feliciano Matias.
Comment 13 Jens Petersen 2010-03-11 00:03:21 EST
Seth, can you offer any clues - I stared at yum-langpacks-0.1.4/langpacks.py
for a bit (original code is by Bill as a PoC) but I confess I don't really
understand the low-level rpm transactions (with python) enough to fix this
quickly.  (It is lucky we turned on Bodhi for f13 and caught this in time...)
Is there a way to filter out current packages that are being replaced?
Comment 14 Jens Petersen 2010-03-11 00:28:28 EST
Just noting that I temporarily made yum-langpacks optional in comps
to avoid too many testers hitting this severe issue.
Comment 15 Jens Petersen 2010-03-11 00:48:42 EST
Doh I hadn't noticed patch from James Antill in bug 571845.
Comment 16 Frederik Himpe 2010-03-11 03:53:16 EST
The basic problem seems to be that langpack plugin tries to install langpack package from the release repository while yum is upgrading the main openoffice.org packages to the versions in updates-testing. The langpack plugin should grab the langpack from the same repository as the main packages.
Comment 17 Mamoru TASAKA 2010-03-12 04:46:56 EST
*** Bug 572897 has been marked as a duplicate of this bug. ***
Comment 18 David 2010-03-14 15:49:16 EDT
I think I'm having a related problem trying to install emacs.
I had previously removed a hunspell package to get an update to
complete after installing f13 alpha to disk from live USB.

yum install emacs
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package emacs.i686 1:23.1-23.fc13 set to be updated
--> Processing Dependency: emacs-common = 1:23.1-23.fc13 for package: 1:emacs-23.1-23.fc13.i686
--> Processing Dependency: libXpm.so.4 for package: 1:emacs-23.1-23.fc13.i686
--> Processing Dependency: libm17n-flt.so.0 for package: 1:emacs-23.1-23.fc13.i686
--> Processing Dependency: libotf.so.0 for package: 1:emacs-23.1-23.fc13.i686
--> Processing Dependency: aspell for package: 1:emacs-23.1-23.fc13.i686
--> Running transaction check
---> Package aspell.i686 12:0.60.6-11.fc13 set to be updated
---> Package emacs-common.i686 1:23.1-23.fc13 set to be updated
---> Package libXpm.i686 0:3.5.8-2.fc13 set to be updated
---> Package libotf.i686 0:0.9.9-3.fc13 set to be updated
--> Processing Dependency: libXaw.so.7 for package: libotf-0.9.9-3.fc13.i686
---> Package m17n-lib-flt.i686 0:1.5.5-2.fc13 set to be updated
--> Processing Dependency: m17n-db-flt for package: m17n-lib-flt-1.5.5-2.fc13.i686
--> Running transaction check
---> Package libXaw.i686 0:1.0.6-4.fc12 set to be updated
---> Package m17n-db-flt.noarch 0:1.5.5-3.fc13 set to be updated
--> Finished Dependency Resolution
Installing langpack for aspell
Adding aspell-en to transaction
Adding hunspell-en to transaction
--> Running transaction check
---> Package aspell-en.i686 50:6.0-11.fc12 set to be updated
---> Package hunspell-en.noarch 0:0.20090216-7.fc12 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package             Arch          Version                  Repository     Size
================================================================================
Installing:
 aspell-en           i686          50:6.0-11.fc12           fedora        1.1 M
 emacs               i686          1:23.1-23.fc13           fedora        2.0 M
Reinstalling:
 hunspell-en         noarch        0.20090216-7.fc12        fedora        353 k
Installing for dependencies:
 aspell              i686          12:0.60.6-11.fc13        fedora        629 k
 emacs-common        i686          1:23.1-23.fc13           fedora         18 M
 libXaw              i686          1.0.6-4.fc12             fedora        169 k
 libXpm              i686          3.5.8-2.fc13             fedora         58 k
 libotf              i686          0.9.9-3.fc13             fedora         78 k
 m17n-db-flt         noarch        1.5.5-3.fc13             fedora         48 k
 m17n-lib-flt        i686          1.5.5-2.fc13             fedora         23 k

<snip>

Transaction Check Error:
  package hunspell-en-0.20090216-7.fc12.noarch is already installed
Comment 19 David Tardon 2010-03-23 03:50:36 EDT
*** Bug 576051 has been marked as a duplicate of this bug. ***
Comment 20 David Tardon 2010-03-26 04:15:53 EDT
*** Bug 577107 has been marked as a duplicate of this bug. ***
Comment 21 Fabian A. Scherschel 2010-03-26 04:30:41 EDT
Sorry for the dupe. All my info is at Bug 577107.
Comment 22 Fabian A. Scherschel 2010-03-30 05:10:34 EDT
I fixed this on two systems by issuing

yum update -x hunspell-en

This will update all other packages which resolves the issue.
Comment 23 David 2010-03-31 11:00:23 EDT
(In reply to comment #22)
> I fixed this on two systems by issuing
> 
> yum update -x hunspell-en
> 
> This will update all other packages which resolves the issue.    

That didn't work for me for my similar problem installing emacs:
# yum update -x hunspell-en
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Update Process
No Packages marked for Update
# yum install emacs
<snip>
Transaction Check Error:
  package hunspell-en-0.20090216-7.fc12.noarch is already installed


Do I have a different problem that should get its own bug report?
Comment 24 Jens Petersen 2010-04-07 06:55:50 EDT
Could you please test yum-langpacks-0.1.5-1.fc13:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2099410
which should hopefully fix this blocker issue.
Comment 25 Fedora Update System 2010-04-07 07:02:06 EDT
yum-langpacks-0.1.5-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/yum-langpacks-0.1.5-1.fc13
Comment 26 Kamil Páral 2010-04-07 07:22:07 EDT
Jens, can you provide a use case how we can make sure the issue is fixed?
Comment 27 Kamil Páral 2010-04-07 07:32:06 EDT
Created attachment 404921 [details]
yum update openoffice.org*

Jens, please compare the output of current "yum update openoffice.org*" with and without langpacks plugin. Please notice that with langpacks plugin it states "Remove: openoffice.org-langpack-en" for its older version. There is no such line without langpacks. But the updates completes successfully. Is that a problem or not?
Comment 28 Kamil Páral 2010-04-07 07:32:45 EDT
Created attachment 404922 [details]
yum update --disableplugin=langpacks openoffice.org*
Comment 29 Mattia Verga 2010-04-07 11:41:55 EDT
Created attachment 405004 [details]
yum update

I confirm this fixes the openoffice only update, but that it errors out if I try a "yum update" (see attached output)
Comment 30 Fedora Update System 2010-04-07 16:54:16 EDT
yum-langpacks-0.1.5-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-langpacks'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/yum-langpacks-0.1.5-1.fc13
Comment 31 Jens Petersen 2010-04-08 06:00:38 EDT
(In reply to comment #27)
> Jens, please compare the output of current "yum update openoffice.org*" with
> and without langpacks plugin. Please notice that with langpacks plugin it
> states "Remove: openoffice.org-langpack-en" for its older version. There is no
> such line without langpacks. But the updates completes successfully. Is that a
> problem or not?    

Yeah I am aware of that and pointed it out to James Antill
who provided the patch... (In reply to comment #29)

> Created an attachment (id=405004) [details]
> I confirm this fixes the openoffice only update, but that it errors out if I
> try a "yum update" (see attached output)    

Hmmm I see.
Comment 32 Akira TAGOH 2010-04-08 07:46:06 EDT
That looks like needing further investigation and take more time to get this fixed. since the beta freeze is ongoing, it may be hard to make this stable in a timely manner. plus, yum-langpacks are now optional in comps. so changing to F13Target sounds reasonable.
Comment 33 Fedora Update System 2010-04-16 19:50:59 EDT
yum-langpacks-0.1.5-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.