Bug 679579

Summary: [R2XX] GNOME Shell graphics corruption
Product: [Fedora] Fedora Reporter: Nicholas Miell <nmiell>
Component: xorg-x11-drv-atiAssignee: Jérôme Glisse <jglisse>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 15CC: ahuhtal4, airlied, awilliam, covex, dusan, fabrice, hancockrwd, hdegoede, jreiser, keevom, maurizio.antillon, mclasen, michal, mwesten, nekohayo, pascal.schott, pebolle, theholyettlz, xgl-maint
Target Milestone: ---Keywords: Reopened, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: [cat:rendering] AcceptedBlocker
Fixed In Version: gnome-session-3.0.1-2.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-30 23:29:47 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 617261, 678116    
Attachments:
Description Flags
GNOME Shell misrendering
none
color corruption while Xv video is in use
none
Xorg.0.log
none
dmesg
none
/var/log/messages
none
GNOME Shell 2.91.92-3 text rendering
none
dmesg from affected system
none
xorg log from affected system
none
messages from boot on affected system
none
xorg.conf from affected system
none
gnome shell artifacts (now with HDG mesa version)
none
a test hack against upstream mesa. none

Description Nicholas Miell 2011-02-22 17:04:18 EST
Created attachment 480275 [details]
GNOME Shell misrendering

Description of problem:
GNOME Shell misrenders all text.

Version-Release number of selected component (if applicable):
Feburary 2011 graphics test day live CD.

01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200] (Secondary) (rev 01)

How reproducible:
Always

Steps to Reproduce:
1. Boot the system, log in to X.
  
Actual results:
See attached screenshot.

Additional info:
Smolt profile: http://www.smolts.org/client/show/pub_a5d07af1-0e5e-4bb1-b6cb-5d02feaf0891
Comment 1 Nicholas Miell 2011-02-22 17:08:48 EST
Created attachment 480276 [details]
color corruption while Xv video is in use
Comment 2 Robert Hancock 2011-02-23 21:13:36 EST
*** Bug 679981 has been marked as a duplicate of this bug. ***
Comment 3 Matěj Cepl 2011-02-24 18:31:49 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Nicholas Miell 2011-02-24 19:25:22 EST
Created attachment 480896 [details]
Xorg.0.log
Comment 5 Nicholas Miell 2011-02-24 19:25:48 EST
Created attachment 480897 [details]
dmesg
Comment 6 Nicholas Miell 2011-02-24 19:26:10 EST
Created attachment 480898 [details]
/var/log/messages
Comment 7 mwesten 2011-03-03 00:42:48 EST
I have the same issue.

F15-Alpha-RC2

ATI Radeon RV250 [Mobility FireGL 9000]
Comment 8 Robert Hancock 2011-03-09 20:46:49 EST
At least the GNOME Shell toolbar/menu text corruption (haven't tried video) is still present in the March 9th nightly desktop live image with xorg-x11-drv-ati-6.14.0-2.20110204gita27b5dbd9.fc15.i686.
Comment 9 James 2011-03-12 15:22:38 EST
*** Bug 684466 has been marked as a duplicate of this bug. ***
Comment 10 Adam Pribyl 2011-03-19 13:57:55 EDT
F15 Alpha: Same menu text corruption and lot of artifacts when menus etc. are redrawing - ATI Technologies Inc RV280 [Radeon 9200].
Comment 11 Dusan Obradovic 2011-03-30 18:11:46 EDT
I have the same issues as Adam Pribyl said, after updates today.

00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
Intel GMA 4500MHD
Comment 12 Adam Pribyl 2011-03-31 07:05:12 EDT
Even thou this bug is marked for RV280, it is possible that other cards suffer with it too. For me, this bug is still valid (using KMS now), I just found my way thru the garbage to use gnome-shell, but it is obviously not desired.
Comment 13 Adam Pribyl 2011-03-31 12:39:54 EDT
Created attachment 489168 [details]
GNOME Shell 2.91.92-3 text rendering
Comment 14 Matěj Cepl 2011-03-31 14:35:34 EDT
(In reply to comment #12)
> Even thou this bug is marked for RV280, it is possible that other cards suffer
> with it too. For me, this bug is still valid (using KMS now), I just found my
> way thru the garbage to use gnome-shell, but it is obviously not desired.

Add your logs requested in the comment 3, please
Comment 15 Adam Pribyl 2011-03-31 15:49:02 EDT
My logs were, last I checked them, same as those attached. The dmesg error messages point me to a bug 679579 where I filled the same thing. Not sure if this may be related to font corruption.
Comment 16 Adam Pribyl 2011-04-01 05:56:10 EDT
Created attachment 489339 [details]
dmesg from affected system
Comment 17 Adam Pribyl 2011-04-01 05:56:43 EDT
Created attachment 489340 [details]
xorg log from affected system
Comment 18 Adam Pribyl 2011-04-01 05:57:18 EDT
Created attachment 489341 [details]
messages from boot on affected system
Comment 19 Adam Pribyl 2011-04-01 05:57:52 EDT
Created attachment 489342 [details]
xorg.conf from affected system
Comment 20 Michal Jaegermann 2011-04-06 11:55:38 EDT
This looks like a bug 678803 even if there cards are, at least, R200 and RV250.
Comment 21 Hans de Goede 2011-04-10 18:00:08 EDT
(In reply to comment #20)
> This looks like a bug 678803 even if there cards are, at least, R200 and RV250.

Yes, I'm pretty sure this is one and the same, marking this as a duplicate of bug 678803. And I'll make 678803 block F15GNOMEfail.

*** This bug has been marked as a duplicate of bug 678803 ***
Comment 22 Hans de Goede 2011-04-10 18:53:01 EDT
Hi All,

For all those not in the CC of bug 678803, I've attached a patch there fixing this. I've also done a scratch build of mesa for F-15 which includes the fix, please give it a try:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2992201

Regards,

Hans
Comment 23 Adam Pribyl 2011-04-11 03:52:01 EDT
Created attachment 491168 [details]
gnome shell artifacts (now with HDG mesa version)

I'd consider this bug more general that #678803 that is just about text. This is however not the only corruption. Attached picture show a compilation of various artifact I see.
Comment 24 Hans de Goede 2011-04-11 04:10:59 EDT
(In reply to comment #23)
> Created attachment 491168 [details]
> gnome shell artifacts (now with HDG mesa version)
> 
> I'd consider this bug more general that #678803 that is just about text. This
> is however not the only corruption. Attached picture show a compilation of
> various artifact I see.

Agreed, lets re-open this one to track the other corruption issues, and keep
bug 678803 to track just the text corruption my patch fixes.
Comment 25 Paul Bolle 2011-04-11 04:28:00 EDT
It seems identical issues are triggered with other R200 grade cards (in my case an RV250). Could someone please remove (or update) the [RV280] from the summary?
Comment 26 Paul Bolle 2011-04-12 16:11:41 EDT
(In reply to comment #23)
> gnome shell artifacts (now with HDG mesa version)

It would be appreciated if someone took the time to explain how we might write (minimal) test cases. Those minimal test cases might make it easier to determine where in the complicated stack the issue might be caused. Very broadly speaking that stack seems to be:
- gnome shell
- gtk libraries
- xorg libraries
- xorg radeon driver
- kernel radeon driver
Comment 27 Paul Bolle 2011-04-12 16:18:23 EDT
(In reply to comment #23)
> gnome shell artifacts (now with HDG mesa version)

Regarding the mouse-over corruption in the top-right drop down menu: note that the corruption occurs only in the second or third item after a separator. So this could have something to do with the way those specific menus are generated dynamically (in the gnome shell, by gtk, by ...)?
Comment 28 Paul Bolle 2011-04-12 17:21:19 EDT
(In reply to comment #27)
> Regarding the mouse-over corruption in the top-right drop down menu: note that
> the corruption occurs only in the second or third item after a separator. 

0) So, playing with the alternative-status-menu extension from the gnome-shell-extensions repository shows that text mouse over corruption only occurs with the text of the second (and later) consecutive 
    PopupMenu.PopupMenuItem(...)

and not with a second PopupMenu.PopupImageMenuItem()

1) Any thoughts on this?
Comment 29 Dave Airlie 2011-04-13 03:55:58 EDT
Created attachment 491672 [details]
a test hack against upstream mesa.

anyone care to test a hack in the mesa upstream driver?
Comment 30 Paul Bolle 2011-04-13 04:08:54 EDT
(In reply to comment #29)
> anyone care to test a hack in the mesa upstream driver?

Yes, but what is this hack supposed to fix?
Comment 31 Dave Airlie 2011-04-13 05:21:31 EDT
I saw some errors in .xsession-errors about clutter fbos.

I think they can cause some of the glitches, this just hacks around things.
Comment 32 Paul Bolle 2011-04-13 08:19:45 EDT
0) Upgraded from Hans' mesa-*-7.11-0.5.20110401.0.fc15.hdg1.i686.rpm to mesa-*-7.11-0.6.20110412.0.fc16.i686 with the "test hack against upstream mesa" added.

1) The same corruption still occurs here. Main difference was that now sometimes the screen gets repainted slowly and strangely (with parts of the screen split diagonally). That looks like a regression.

2) Looking at the instances of graphic corruptions it seems they actually all are identical: parts of the screen (a single character, an icon, a rounded corner, etc.) get replaced (mostly temporarily) by a solid block (mostly white, but green in the gnome-shell's looking glass).

3) These few lines form .xsession-errors are gibberish to me but seem to be relevant:
[...]
radeonMapTexture(0x8741d30, tex 0x8b44658) No miptree in texture.
radeonMapTexture(0x8741d30, tex 0x8b44658) No miptree in texture.
radeonMapTexture(0x8741d30, tex 0x8b44658) No miptree in texture.
radeonMapTexture(0x8741d30, tex 0x8b44658) No miptree in texture.

(gnome-shell:1381): Cogl-glx-WARNING **: Skipping layers 1..n of your pipeline since the first layer is sliced. We don't currently support any multi-texturing with sliced textures but assume layer 0 is the most important to keep
[...]
Comment 33 Oveek 2011-04-13 10:18:57 EDT
I'm on ArchLinux, kernel 2.6.38.
Radeon RV250 [Mobility FireGL 9000] (rev 02)

I just compiled mesa from git with Dave's hack and it fixed a major gnome-shell / clutter issue I was experiencing where I couldn't open the Applications part of the Activities view. It would try to open for a few seconds and then exit to the desktop without showing anything. Performance is now much better as well--downright snappy.

I had been seeing the clutter fbo errors he mentioned. Previously logged a bunch of these errors from startx:

(gnome-shell:28180): Cogl-WARNING **: ./cogl-framebuffer.c:918: Failed to create an OpenGL framebuffer

Now all those errors are gone and the Application view renders nearly perfectly with app icons and text showing. 

One problem I still see is the scrollbar in the Application view just shows up as a white box instead of the grey bar that should be there, and the little gray arrow that points at the selected application category (Accessories, Graphics, Internet, etc.) also shows just a small white box.

Logging startx now just gives me a few warnings from clutter:

(gnome-shell:31151): Cogl-WARNING **: Skipping layers 1..n of your pipeline since the first layer is sliced. We don't currently support any multi-texturing with sliced textures but assume layer 0 is the most important to keep

(gnome-shell:31151): Cogl-WARNING **: Your hardware does not have enough texture unitsto handle this many texture layers
Comment 34 Adam Pribyl 2011-04-13 12:30:56 EDT
(In reply to comment #33)
> I just compiled mesa from git with Dave's hack and it fixed a major gnome-shell
> / clutter issue I was experiencing where I couldn't open the Applications part
> of the Activities view. It would try to open for a few seconds and then exit to
> the desktop without showing anything. Performance is now much better as
> well--downright snappy.

Acctually you probably have two new patches at least compared to "distribution". 1. from Hans that was pushed to git (see freedesktop bug), that fixes lot of problems, 2. this Dave's hack, which is probably forcing to return _dri_texformat_argb8888 on all radeon cards - not only R100, and is probably not changing much. Check the changelog.
Comment 35 Oveek 2011-04-13 14:06:20 EDT
(In reply to comment #34)

> Acctually you probably have two new patches at least compared to
> "distribution". 1. from Hans that was pushed to git (see freedesktop bug), that
> fixes lot of problems.

Hans also posted a link to that patch in a bug I filed in gnome. That sorted the text rendering and a few other issues, but I was still getting the clutter fbo errors and application view problems I described above. I'll go back and recompile without Dave's hack to see if there were any other commits after the one from Hans that caused the fix.
Comment 36 Adam Pribyl 2011-04-17 10:29:38 EDT
I also see those cogl errors. I have abrt crash report with this in a bug
https://bugzilla.redhat.com/show_bug.cgi?id=692423
Comment 37 John Reiser 2011-04-22 13:02:15 EDT
My $HOME/.xsession-errors grows by hundreds of lines per interaction with Activities.  Here are the top 5 frequencies after a few interactions:
-----
   1179 (gnome-shell:2711): Cogl-glx-WARNING **: ./cogl-framebuffer.c:912: Failed to create an OpenGL framebuffer
    367 (gnome-shell:2711): St-CRITICAL **: setup_framebuffers: assertion `priv->old_offscreen != COGL_INVALID_HANDLE' failed
    367 (gnome-shell:2711): Cogl-glx-CRITICAL **: cogl_set_source: assertion `cogl_is_pipeline (pipeline)' failed
    367 (gnome-shell:2711): Cogl-glx-CRITICAL **: cogl_pipeline_set_layer_combine_constant: assertion `cogl_is_pipeline (pipeline)' failed
    367 (gnome-shell:2711): Cogl-glx-CRITICAL **: cogl_pipeline_set_color: assertion `cogl_is_pipeline (pipeline)' failed
-----

The "app is starting" gadget in the top menu bar (8 radii which highlight in succession) has black+white "scrolling Morse code" in the top 4 rows.  Sometimes the Network icon has static inverse video on the top 4 rows.  It can disappear and re-appear according to mouse-over.

I still see the text corruption (white-out) on mouse-over of Comment #27.

Environment:
-----
kernel-PAE-2.6.38.2-9.fc15.i686     with 1GB system RAM
xorg-x11-drv-ati-6.14.0-7.20110316gitcdfc007ec.fc15.i686
mesa-dri-drivers-7.11-0.6.20110412.0.fc15.i686
mesa-dri-llvmcore-7.11-0.6.20110412.0.fc15.i686
mesa-libGL-7.11-0.6.20110412.0.fc15.i686
mesa-libGLU-7.11-0.6.20110412.0.fc15.i686
xorg-x11-server-Xephyr-1.10.1-11.fc15.i686
xorg-x11-server-Xorg-1.10.1-11.fc15.i686

[  1079.664] (--) PCI:*(0:1:0:0) 1002:5960:174b:0130 rev 1, Mem @ 0xf0000000/134217728, 0xdf000000/65536, I/O @ 0x0000d800/256, BIOS @ 0x????????/131072
[  1079.664] (--) PCI: (0:1:0:1) 1002:5940:174b:0131 rev 1, Mem @ 0xe0000000/134217728, 0xde800000/65536, BIOS @ 0x????????/65536
-----
Comment 38 Matěj Cepl 2011-04-26 12:44:04 EDT
The message I get from Xorg developers is that any R1xx and R2xx most likely just won't work with gnome-shell and we cannot do much about it in the time frame we have for F15 release.

It certainly doesn't mean that we would give up on this bug completely, but it is most likely not on the top of our todo list now.

Jerome, David, do you violently object to this assessment?
Comment 39 John Reiser 2011-04-26 13:07:09 EDT
If the card and drivers appear to work by non-visual tests, but actually fail to generate correct visual output, then Gnome shell was supposed to implement a "black list" of non-working environments.  The helper program which determines whether a card has good-enough hardware+drivers would exclude cards that appear on the black list even though the programmatic tests of functionality+performance [such as less than 5 seconds to accomplish a certain compositing operation] might otherwise "succeed".  Then Gnome desktop would fall back to [something like] the "classic", previous desktop, instead of generating bad output for the new desktop.  What is the status of such a black list for Fedora 15?
Comment 40 Matěj Cepl 2011-04-26 17:01:58 EDT
(In reply to comment #39)
> What is the status of such a black list for Fedora 15?

This is the reason why this bug blocks bug 678116
Comment 41 Adam Williamson 2011-04-29 14:21:56 EDT
Discussed at the 2011-04-29 blocker review meeting. Accepted as a blocker as the result with affected chips is bad: the test for Shell support passes so you get the corrupted Shell. We do not require working Shell on these adapters, an acceptable fix would be for the Shell support test (gnome-session-is-accelerated) to fail on these adapters so that fallback mode is used. Apparently otaylor has / is working on such a patch.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 42 Matthias Clasen 2011-04-29 14:22:23 EDT
The blacklist patch is being worked on here:
https://bugzilla.gnome.org/show_bug.cgi?id=644325
Comment 43 Fedora Update System 2011-04-29 14:29:28 EDT
gnome-session-3.0.1-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnome-session-3.0.1-2.fc15
Comment 44 Fedora Update System 2011-04-29 20:47:11 EDT
Package gnome-session-3.0.1-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-session-3.0.1-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gnome-session-3.0.1-2.fc15
then log in and leave karma (feedback).
Comment 45 Adam Pribyl 2011-04-30 15:10:27 EDT
OK for me. This udate forces gnome3 to fallback. Considering this sorted out, but would rather have gnome-shell working as it should....
Comment 46 Fedora Update System 2011-04-30 23:29:41 EDT
gnome-session-3.0.1-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.