This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 722859

Summary: smolt fails to parse ram_size
Product: [Fedora] Fedora Reporter: Mikko Tiihonen <mikko.tiihonen>
Component: smoltAssignee: Will Woods <wwoods>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: rawhideCC: awilliam, casep, hedayaty, hit_man2, hrafn, kparal, lkundrak, mads, marbolangos, nicolas.mailhot, ortizsantini, robatino, satellitgo, timosha, unix63, vonbrand, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: smolt-1.4.3-5.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-06 23:32:31 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Mikko Tiihonen 2011-07-18 05:23:29 EDT
Description of problem:
Smolt fails to create system profile and complains about NoneType while parsing ram_size.

Version-Release number of selected component (if applicable):
smolt-1.4.3-3.fc15.noarch

How reproducible:
Always

Steps to Reproduce:
1. smoltSendProfile -p
  
Actual results:
Traceback (most recent call last):
  File "/usr/bin/smoltSendProfile", line 152, in <module>
    profile = smolt.get_profile()
  File "/usr/share/smolt/client/smolt.py", line 1415, in get_profile
    return Hardware()
  File "/usr/share/smolt/client/smolt.py", line 1004, in Hardware
    _hardware_instance = _Hardware()
  File "/usr/share/smolt/client/smolt.py", line 591, in __init__
    self.host = Host()
  File "/usr/share/smolt/client/smolt.py", line 283, in __init__
    self.systemMemory = Gate().process('ram_size', memory['ram'], 0)
TypeError: 'NoneType' object is not subscriptable


Expected results:
Profile is created and printed to console
Comment 1 Mads Kiilerich 2011-07-26 09:05:57 EDT
That is with a 3.0 kernel, right?

I suggest /usr/share/smolt/client/smolt.py should have

def read_memory():
    un = os.uname()
    kernel = un[2]
    if kernel[:3] == "2.4":
        return read_memory_2_4()
    return read_memory_2_6()
Comment 2 Mikko Tiihonen 2011-07-27 03:35:31 EDT
Yes. 3.0 kernel.

I modified the smolt.py as suggested and now smolt works on rawhide.
Comment 3 Orion Poplawski 2011-08-25 16:25:09 EDT
*** Bug 726029 has been marked as a duplicate of this bug. ***
Comment 4 Orion Poplawski 2011-08-25 16:26:14 EDT
*** Bug 727797 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2011-08-25 16:45:44 EDT
smolt-1.4.3-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/smolt-1.4.3-5.fc16
Comment 6 Timon 2011-08-26 02:01:47 EDT
Package: smolt-1.4.3-4.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
tried to get smolt profile via abrt reporting tool
Comment 7 Boricua 2011-08-26 05:29:25 EDT
Package: smolt-1.4.3-4.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Just trying to provide profile for bug reporting.
Comment 8 Fabien Archambault 2011-08-26 06:06:55 EDT
Package: smolt-1.4.3-4.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
Trying to report ABRT bug with smolt send profile
Comment 9 Fedora Update System 2011-08-26 10:17:45 EDT
Package smolt-1.4.3-5.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing smolt-1.4.3-5.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/smolt-1.4.3-5.fc16
then log in and leave karma (feedback).
Comment 10 Amir Hedayaty 2011-08-26 13:04:27 EDT
Package: smolt-1.4.3-4.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
I know this is a common bug
Comment 11 Alexander Ivanov 2011-08-27 02:29:43 EDT
Package: smolt-1.4.3-4.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Starting Smolt from ABRT
Comment 12 hitman2 2011-09-02 07:31:17 EDT
Package: smolt-1.4.3-4.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
I dont remember
no
Comment 13 Carlos "casep" Sepulveda 2011-09-03 19:31:47 EDT
Package: smolt-1.4.3-4.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
While reporting a totem bug it offerd to use smolt to add extra info.
Comment 14 Horst H. von Brand 2011-09-06 11:52:09 EDT
Package: smolt-gui-1.4.3-3.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Installed and started smoltGui for the first time ever
Comment 15 unix63 2011-09-06 22:14:58 EDT
Package: smolt-1.4.3-4.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
abrt tried send smolt hardware profile
Comment 16 Fedora Update System 2011-09-06 23:32:23 EDT
smolt-1.4.3-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Adam Williamson 2011-09-07 15:51:25 EDT
*** Bug 733739 has been marked as a duplicate of this bug. ***
Comment 18 Adam Williamson 2011-09-07 15:55:34 EDT
this patch should probably get committed to http://git.fedorahosted.org/git/?p=smolt.git , seeing as how smolt is a fedoraland tool and all.
Comment 19 Adam Williamson 2011-09-07 15:58:47 EDT
filed https://fedorahosted.org/smolt/ticket/92 .
Comment 20 Andre Robatino 2011-11-05 13:56:47 EDT
On a clean F16 (AKA RC5) i386 install from live image, I see what looks very similar to bug 727797 which is marked as a dupe of this one. In firstboot, the hardware profile box was empty. Running smoltSendProfile manually tracebacks:

[andre@emachines-pc ~]$ smoltSendProfile 
Traceback (most recent call last):
  File "/usr/bin/smoltSendProfile", line 152, in <module>
    profile = smolt.get_profile()
  File "/usr/share/smolt/client/smolt.py", line 1414, in get_profile
    return Hardware()
  File "/usr/share/smolt/client/smolt.py", line 1004, in Hardware
    _hardware_instance = _Hardware()
  File "/usr/share/smolt/client/smolt.py", line 591, in __init__
    self.host = Host()
  File "/usr/share/smolt/client/smolt.py", line 306, in __init__
    self.systemVendor = cat('/sys/devices/virtual/dmi/id/sys_vendor')[0].strip()
  File "/usr/share/smolt/client/devicelist.py", line 76, in cat
    fd = open(file, 'r')
IOError: [Errno 2] No such file or directory: '/sys/devices/virtual/dmi/id/sys_vendor'
[andre@emachines-pc ~]$

Here is the F14 smolt profile of the same machine before I reinstalled:

 http://www.smolts.org/client/show/pub_d157199d-ccaa-4731-aca2-5bc53d75c516

Is this also in fact a dupe?
Comment 21 Mads Kiilerich 2011-11-05 14:05:32 EDT
Robatino: No, that is Bug 695075 / Bug 727513 / Bug 727518