Bug 756209

Summary: [abrt] fusion-icon-0.1.0-0.10.5e2dc9git.fc15: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
Product: [Fedora] Fedora Reporter: Joe Zeff <joe>
Component: fusion-iconAssignee: Karol Trzcionka <karlikt>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: jpazdziora, karlikt
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
Whiteboard: abrt_hash:3ab84c4b529be37e05d291bead725a783d8b7f34
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-03-21 14:04:38 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: environ
none
File: dso_list
none
File: build_ids
none
File: smolt_data
none
File: backtrace
none
File: maps none

Description Joe Zeff 2011-11-22 18:35:53 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/bin/fusion-icon -v
comment:        This started right after I used preupgrade to go from Fedora 14 to Fedora 16.  I've tried creating and using a different user, but I can't get Compiz running for either user.  One of the error messages in ~/.xsession-errors for my main user is "fusion-icon: error: option -s: invalid integer value: 'ession'" but I've not found it in the other user's .xsession-errors.
crash_function: __pyx_f_12compizconfig_GetType
executable:     /usr/bin/python
kernel:         2.6.35.14-103.fc14.i686.PAE
pid:            3194
pwd:            /home/joe/Desktop
reason:         Process /usr/bin/python was killed by signal 11 (SIGSEGV)
time:           Tue 22 Nov 2011 02:25:06 PM PST
uid:            500
username:       joe

backtrace:      Text file, 111884 bytes
build_ids:      Text file, 4879 bytes
dso_list:       Text file, 10609 bytes
environ:        Text file, 3018 bytes
maps:           Text file, 30082 bytes
smolt_data:     Text file, 2998 bytes

var_log_messages:
:Nov 22 14:03:47 barrayar yum[2788]: Updated: libreport-python-2.0.7-1.fc16.i686
:Nov 22 14:03:51 barrayar yum[2788]: Updated: abrt-addon-python-2.0.6-1.fc16.i686
:Nov 22 14:04:06 barrayar yum[2788]: Updated: policycoreutils-python-2.1.4-10.fc16.i686
:Nov 22 14:25:06 barrayar abrt[3222]: Saved core dump of pid 3194 (/usr/bin/python) to /var/spool/abrt/ccpp-2011-11-22-14:25:06-3194 (8564736 bytes)

xsession_errors:
:  File "/usr/lib/python2.7/site-packages/screenlets/session.py", line 472, in create_session
:  File "/usr/lib/python2.7/site-packages/screenlets/session.py", line 246, in start
:  File "/usr/lib/python2.7/socket.py", line 224, in meth
Comment 1 Joe Zeff 2011-11-22 18:35:56 EST
Created attachment 535237 [details]
File: environ
Comment 2 Joe Zeff 2011-11-22 18:35:57 EST
Created attachment 535238 [details]
File: dso_list
Comment 3 Joe Zeff 2011-11-22 18:35:58 EST
Created attachment 535239 [details]
File: build_ids
Comment 4 Joe Zeff 2011-11-22 18:35:59 EST
Created attachment 535240 [details]
File: smolt_data
Comment 5 Joe Zeff 2011-11-22 18:36:02 EST
Created attachment 535241 [details]
File: backtrace
Comment 6 Joe Zeff 2011-11-22 18:36:03 EST
Created attachment 535242 [details]
File: maps
Comment 7 Joe Zeff 2011-12-13 02:05:02 EST
I've also upgraded my desktop to Fedora 16 (The first report was for my laptop, if that matters.) and after a week of work, have it working, mostly, with XFCE, the same as my laptop.  The fusion-icon also fails here with a Segmentation Fault and I found this line in .xsession-errors:

fusion-icon: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
Comment 8 abrt-bot 2012-03-21 14:04:38 EDT
Backtrace analysis found this bug to be similar to bug #753067, closing as duplicate. This bug seems to belong to component python or compizconfig-python.

Bugs which were found to be similar to this bug: 
  ccsm: bug #753067, bug #759335, bug #760389, bug #766124
  fusion-icon: bug #751073, bug #758867

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 753067 ***