Bug 853590

Summary: 18 Final TC3 x86_64 XFCE Spin is > 700 MiB
Product: [Fedora] Fedora Reporter: Andre Robatino <robatino>
Component: distributionAssignee: Christoph Wickert <cwickert>
Status: CLOSED CURRENTRELEASE QA Contact: Bill Nottingham <notting>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: awilliam, cwickert, dennis, kevin, mrunge, oliver.zemann, rvokal, tla
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: AcceptedNTH
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-10 14:06:19 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 752665, 863722    

Description Andre Robatino 2012-08-31 23:52:31 EDT
Description of problem:
See Summary.

Version-Release number of selected component (if applicable):
18 Alpha TC5
Comment 1 Adam Williamson 2012-09-01 00:09:13 EDT
that's not an Alpha blocker. size requirements are Beta:

"The network installation image, DVD image, and live images for release-blocking desktops must meet current size requirements"

from *Beta*, not Alpha.
Comment 2 Bill Nottingham 2012-09-04 12:35:39 EDT
KDE has decided on > 700MB for F-18 anyway. GNOME is still under consideration for the same.
Comment 3 Andre Robatino 2012-09-04 12:40:10 EDT
We need a new https://fedoraproject.org/w/index.php?title=Releases/18/Spins page indicating this, then. The latest size page that actually exists is https://fedoraproject.org/wiki/Releases/16/Spins . We've been using that for size information.
Comment 4 Bill Nottingham 2012-09-04 14:18:24 EDT
OK, created with new sizes for Desktop & KDE. (Double-checking on KDE size, might be adjusted up or down slightly, but it's intended to be > 700MB.)
Comment 5 Andre Robatino 2012-09-04 14:22:12 EDT
(In reply to comment #4)
> OK, created with new sizes for Desktop & KDE. (Double-checking on KDE size,
> might be adjusted up or down slightly, but it's intended to be > 700MB.)

Shouldn't those sizes be 1 GB (not 1 GiB)? Flash drives have sizes measured in SI units, so a 1 GB flash drive really is 1 GB (1000^3 bytes).
Comment 6 Bill Nottingham 2012-09-04 14:27:39 EDT
I think the choice of GiB vs GB on that page depends primarily on what other entry you happen to be looking at at the time.
Comment 7 Andre Robatino 2012-09-04 14:34:58 EDT
(In reply to comment #6)
> I think the choice of GiB vs GB on that page depends primarily on what other
> entry you happen to be looking at at the time.

AFAICT, every entry was chosen correctly. For example, the 1 GB Design Suite Spin entry was chosen to target flash drives. The 4 GiB entries were chosen specifically due to the 4 GiB FAT file size limit (I disagreed with the decision, but it was not a careless error). Similarly for the 700 MiB CD size limit. I noticed that you changed the 4 GiB limits to 4 GB, can you revert these changes? Thanks. (Of course, the choice of units for the ~ 3 GiB limit was arbitrary. I asked once what the point of a vague limit was and never got an answer.)
Comment 8 Andre Robatino 2012-09-06 04:05:30 EDT
Changing Summary to reflect that the Gnome and KDE Lives only have to be <= 1 GB. For 18 Alpha TC6, all Lives pass size tests including XFCE which is now < 700 MiB.
Comment 9 Adam Williamson 2012-09-17 18:44:12 EDT
For Alpha final (RC3), all Live images are within their size targets except Xfce x86_64, which is 709MiB (should be under 700MiB). Adjusting summary and nominating as Beta NTH not blocker, as Xfce is not a release-blocking desktop.
Comment 10 Adam Williamson 2012-09-26 13:41:37 EDT
*** Bug 856894 has been marked as a duplicate of this bug. ***
Comment 11 Adam Williamson 2012-09-26 13:43:08 EDT
We discussed 856894, which is identical, at the 2012-09-26 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-09-26/f18-beta-blocker-review-1.2012-09-26-16.03.log.txt .

Accepted as NTH, non-blocking spins being over-size are NTH by definition.
Comment 12 Kevin Fenzi 2012-09-27 17:01:19 EDT
The nightly live xfce's are now both under 700MB... 

So I think we can close this, or I guess we could keep it open to check for at beta?
Comment 13 Adam Williamson 2012-09-28 16:20:52 EDT
Doesn't make a huge degree of difference really, we'll re-check it at Beta either way. Up to you how you want to handle it.
Comment 14 Kevin Fenzi 2012-09-28 18:14:33 EDT
Lets close this one. 

Re-open or file a new one if you see it going over again.
Comment 15 Andre Robatino 2012-10-03 01:20:12 EDT
Fedora-18-Beta-TC1-x86_64-Live-XFCE.iso is 758120448 bytes > 700 MiB. Fedora-18-Beta-TC1-i686-Live-XFCE.iso is 726663168 bytes < 700 MiB.
Comment 16 Kevin Fenzi 2012-10-03 17:28:03 EDT
Looking around, nothing big really seems to have crept in. 

The EFI stuff takes up a fair bit of room: 

4.8MB efiboot.img
20MB macboot.img

Here's the top 30 packages by installed size: 

127197570 kernel
117821449 glibc-common
93798681 java-1.7.0-openjdk
40651371 webkitgtk
39167947 xulrunner
36574107 mesa-dri-drivers
34904384 perl
33322531 linux-firmware
32444794 foomatic-db-ppds
31602396 opencv
29454189 gnumeric
28427650 firefox
28363236 libpinyin-data
27879319 libpurple
26038006 anthy
25009477 python-libs
22247740 libicu
21457344 llvm-libs
21094325 cjkuni-uming-fonts
20990480 gutenprint
20543461 libabiword
18504995 grub2-efi
17156348 wqy-zenhei-fonts
16799922 ghostscript
15989135 binutils
15914745 grub2-tools
15147402 claws-mail
14682121 selinux-policy-targeted
14233540 coreutils
14112293 iso-codes

An easy fix would be to remove webkitgtk (which drops midori and liferea), but I would prefer to avoid that if we can. Will look around some more.
Comment 17 Andre Robatino 2012-10-04 17:04:02 EDT
Fedora-18-Beta-TC2-i686-Live-XFCE.iso : 728760320 bytes (695 MiB)
Fedora-18-Beta-TC2-x86_64-Live-XFCE.iso : 760217600 bytes (725 MiB)
Comment 18 Andre Robatino 2012-10-04 23:51:08 EDT
Comparing to the other live images, the 64-bit version is typically about 30M larger than the 32-bit, so this is normal. (For install images, 64-bit is usually smaller.)
Comment 19 Andre Robatino 2012-10-05 01:07:05 EDT
Looking back in my records, the size difference for 64-bit vs. 32-bit lives started with 18 Alpha RC3. Prior to that, the 64-bits were about the same size or a little smaller than 32-bit.

18 Alpha RC2:

Fedora-18-Alpha-i686-Live-Desktop.iso : 786432000
Fedora-18-Alpha-i686-Live-KDE.iso : 832569344
Fedora-18-Alpha-i686-Live-LXDE.iso : 674234368
Fedora-18-Alpha-i686-Live-SoaS.iso : 554696704
Fedora-18-Alpha-i686-Live-XFCE.iso : 715128832

Fedora-18-Alpha-x86_64-Live-Desktop.iso : 783286272
Fedora-18-Alpha-x86_64-Live-KDE.iso : 834666496
Fedora-18-Alpha-x86_64-Live-LXDE.iso : 674234368
Fedora-18-Alpha-x86_64-Live-SoaS.iso : 553648128
Fedora-18-Alpha-x86_64-Live-XFCE.iso : 715128832

18 Alpha RC3:

Fedora-18-Alpha-i686-Live-Desktop.iso : 783286272
Fedora-18-Alpha-i686-Live-KDE.iso : 806354944
Fedora-18-Alpha-i686-Live-LXDE.iso : 671088640
Fedora-18-Alpha-i686-Live-SoaS.iso : 555745280
Fedora-18-Alpha-i686-Live-XFCE.iso : 710934528

Fedora-18-Alpha-x86_64-Live-Desktop.iso : 812646400
Fedora-18-Alpha-x86_64-Live-KDE.iso : 835715072
Fedora-18-Alpha-x86_64-Live-LXDE.iso : 702545920
Fedora-18-Alpha-x86_64-Live-SoaS.iso : 583008256
Fedora-18-Alpha-x86_64-Live-XFCE.iso : 743440384

Note that this bug was originally reported for 18 Alpha TC5, and at that point, both the 32- and 64-bit XFCE lives were oversized, by about the same amount.

18 Alpha TC5:

Fedora-18-Alpha-TC5-i686-Live-Desktop.iso : 775946240
Fedora-18-Alpha-TC5-i686-Live-KDE.iso : 790626304
Fedora-18-Alpha-TC5-i686-Live-SoaS.iso : 556793856
Fedora-18-Alpha-TC5-i686-Live-XFCE.iso : 761266176

Fedora-18-Alpha-TC5-x86_64-Live-Desktop.iso : 772800512
Fedora-18-Alpha-TC5-x86_64-Live-KDE.iso : 788529152
Fedora-18-Alpha-TC5-x86_64-Live-SoaS.iso : 554696704
Fedora-18-Alpha-TC5-x86_64-Live-XFCE.iso : 760217600
Comment 20 Adam Williamson 2012-10-05 04:47:23 EDT
Well, two interesting things happened around then: one of Bill's giant comps changes landed, IIRC, and livecd-tools stopped putting the UEFI bits on 32-bit images, since we don't support 32-bit UEFI.

The first factor could explain why overall image size got larger, and the second could explain why 32-bit images specifically got smaller...
Comment 21 Andre Robatino 2012-10-05 11:48:13 EDT
(In reply to comment #20)

> The first factor could explain why overall image size got larger, and the
> second could explain why 32-bit images specifically got smaller...

To me, it seems like the 32-bits stayed about the same size, while the 64-bits got about 30M larger. Since all the 18 TCs/RCs are still in stage, it's easy to browse in detail (although I keep size records due to the fact that the actual size is no longer the same as the ISO header size, so if they weren't there, I could post it somewhere).

If there is something fixable about the extra 30M in 64-bit, it would be good to get that fixed ASAP, since that would both fix this bug and postpone when all the other spins start hitting the size limit. (On a related note, the 32-bit install DVDs are getting uncomfortably close to the 4.7 GB size limit. I put comments on the TC1 and TC2 matrix pages.)
Comment 22 Kevin Fenzi 2012-10-06 20:13:55 EDT
*** Bug 863725 has been marked as a duplicate of this bug. ***
Comment 23 Andre Robatino 2012-10-09 18:07:29 EDT
Fedora-18-Beta-TC3-i686-Live-XFCE.iso : 728760320 (695 MiB)
Fedora-18-Beta-TC3-x86_64-Live-XFCE.iso : 759169024 (724 MiB)
Comment 24 Andre Robatino 2012-10-13 19:51:05 EDT
For 18 Beta TC4, within the size limit, but just barely.

Fedora-18-Beta-TC4-i686-Live-XFCE.iso : 703594496 (671 MiB)
Fedora-18-Beta-TC4-x86_64-Live-XFCE.iso : 732954624 (699 MiB)
Comment 25 Christoph Wickert 2012-10-14 13:57:40 EDT
Should we close this?
Comment 26 Andre Robatino 2012-10-14 14:23:25 EDT
(In reply to comment #25)
> Should we close this?

With only 1M leeway, It could easily go over the size limit again at any compose unless it's trimmed down, so personally I think it would be better to leave it open for now.
Comment 27 Kevin Fenzi 2012-10-14 14:33:43 EDT
There was an additional suggestion on the xfce list to exclude PackageKit and realmd

http://lists.fedoraproject.org/pipermail/xfce/2012-October/001585.html

Not sure how much that buys us though.
Comment 28 Christoph Wickert 2012-10-17 14:06:39 EDT
I have incorporated these changes in 
http://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?id=8d2573e3 and
http://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?h=f18&id=94fecade

Let's see what the next nightly brings us.
Comment 29 Andre Robatino 2012-10-19 21:40:51 EDT
A little better...

Fedora-18-Beta-TC5-i686-Live-XFCE.iso : 701497344 bytes (669 MiB)
Fedora-18-Beta-TC5-x86_64-Live-XFCE.iso : 730857472 bytes (697 MiB)
Comment 30 Andre Robatino 2012-10-20 01:05:14 EDT
Fedora-18-Beta-TC6-i686-Live-XFCE.iso : 701497344 bytes (669 MiB)
Fedora-18-Beta-TC6-x86_64-Live-XFCE.iso : 730857472 bytes (697 MiB)
Comment 31 Bill Nottingham 2012-10-22 15:18:13 EDT
*** Bug 868511 has been marked as a duplicate of this bug. ***
Comment 32 Andre Robatino 2012-11-03 01:18:59 EDT
Oversized again.

Fedora-18-Beta-TC7-i686-Live-XFCE.iso : 705691648 bytes (673 MiB)
Fedora-18-Beta-TC7-x86_64-Live-XFCE.iso : 735051776 bytes (701 MiB)
Comment 33 Adam Williamson 2012-11-03 01:29:30 EDT
FWIW, I noticed a 'minimal' install mysteriously grew to nearly 250 packages recently, which may have an influence on this (when I compared f17 and f18 minimal installs a few weeks back, it was around 200 packages). I have it on my todo list to figure out what grew, but didn't get around to it yet.
Comment 34 Bill Nottingham 2012-11-05 23:40:22 EST
Hm, comparing to an early October root I did, only additions were man, groff-base, and less. That accounts for 3-4MB uncompressed, but should be on the XFCE live in both cases anyway.
Comment 35 Bill Nottingham 2012-11-05 23:54:54 EST
Explicit additions to comps that may have affected the XFCE live image in the past couple of weeks:

105318	xfce4-about
214589	less
524316	sil-nuosu-fonts
1586590	gnu-free-mono-fonts
1861568	man-db
2817271	tar
3085512	gnu-free-sans-fonts
6145760	gnu-free-serif-fonts

Assumption would be the fonts, which were added to @fonts so we had default coverage for languages we didn't before. (bugs #868547, #871924). I'm assuming less/man-db/tar were already brought in by deps, so no change there.
Comment 36 Andre Robatino 2012-11-10 14:50:48 EST
TC8 is oversized.

Fedora-18-Beta-TC8-i686-Live-XFCE.iso : 706740224 bytes (674 MiB)
Fedora-18-Beta-TC8-x86_64-Live-XFCE.iso : 735051776 bytes (701 MiB)
Comment 37 Andre Robatino 2012-11-16 08:10:23 EST
TC9 is oversized.

Fedora-18-Beta-TC9-i686-Live-XFCE.iso : 706740224 bytes (674 MiB)
Fedora-18-Beta-TC9-x86_64-Live-XFCE.iso : 736100352 bytes (702 MiB)
Comment 38 Kevin Fenzi 2012-11-16 12:17:17 EST
I dropped gnumeric from the spin and now the nightlies are well under size. ;) 

Length: 721420288 (688M)
Comment 39 Andre Robatino 2012-11-20 21:38:04 EST
Confirmed that 18 Beta RC1 is within size limits.

Fedora-18-Beta-i686-Live-XFCE.iso : 692060160 bytes (660 MiB)
Fedora-18-Beta-x86_64-Live-XFCE.iso : 720371712 bytes (687 MiB)
Comment 40 Andre Robatino 2012-12-17 14:16:41 EST
Fedora-18-TC3-i686-Live-XFCE.iso : 696254464 bytes (664 MiB)
Fedora-18-TC3-x86_64-Live-XFCE.iso : 737148928 bytes (703 MiB)
Comment 41 Christoph Wickert 2012-12-17 14:37:23 EST
The spin basically increased by 50 MB DURING THE FREEZE. How can this happen?
Comment 42 Adam Williamson 2012-12-17 15:22:21 EST
Accepted as NTH: we agreed at 2012-12-17 NTH review meeting - http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-17/f18final-blocker-review-5.2012-12-17-16.40.log.txt - that over-size issues on non-blocking spins are accepted as NTH by policy without explicit discussion needed.
Comment 43 Adam Williamson 2012-12-17 15:23:19 EST
It went from 692MB (TC2) to 703MB (TC3), for x86-64. That's 11MB, not 50MB.
Comment 44 Christoph Wickert 2012-12-17 15:29:43 EST
Yeah, but before we freed up almost 40 MB by removing gnumeric and some claws plugins. lLl of this happened during beta freeze.
Comment 45 Kevin Fenzi 2012-12-17 16:30:48 EST
:( 

We could remove seahorse - saves us 6mb, might be enough.
Comment 46 Bill Nottingham 2012-12-18 13:45:08 EST
So, cracking open the live images shows that the disk usage of the ext4 fs image is roughly 30MB greater in TC3 than TC2, despite it only containing ~4MB more content in the accessible filesystem itself. Something during the creation process for TC3 causes that extra 25-30MB of image space to be allocated and then removed (but still in the filesystem image). This then translated to most of the ~11MB gain in the squashfs image, and the live image itself.

However, we don't have good enough logs or details to determine why this happened.
Comment 47 Kevin Fenzi 2012-12-18 14:03:18 EST
I dropped seahorse. 

Lets see if thats enough to get us under... in my local testing it should be.
Comment 48 Christoph Wickert 2012-12-27 14:46:01 EST
Once bug 856270 gets fixed, we'll have 22k for pulseaudio-libs-glib2 more, but that shouldn't really matter.
Comment 49 Andre Robatino 2013-01-03 04:24:15 EST
17 Final TC4 is back under the size limit.

Fedora-18-TC4-i686-Live-XFCE.iso : 694157312 bytes (662 MiB)
Fedora-18-TC4-x86_64-Live-XFCE.iso : 724566016 bytes (691 MiB)
Comment 50 Kevin Fenzi 2013-01-03 10:59:00 EST
Hopefully we are good until release now. ;)
Comment 51 Andre Robatino 2013-01-06 01:45:54 EST
18 Final RC1 is under the size limit (but very close).

Fedora-18-i686-Live-XFCE.iso : 694157312 bytes (662 MiB)
Fedora-18-x86_64-Live-XFCE.iso : 732954624 bytes (699 MiB)
Comment 52 Christoph Wickert 2013-01-08 16:53:18 EST
In F18 RC21. I added gnome-keyring-pam (because automatic unlocking of the default keyring is a desktop validation test case) and even though the package is just a single so file, we are now oversized again. :(

RC1 x86_64   732954624 bytes
RC2 x86_64   
RC2.1 x86_64 735051776 (spun because of bug 893098)
Target size  734003200

To fix this, I have omitted claws-mail-plugins-rssyl. It's three times bigger than gnome-keyring-pam and we already have lifearea as rss reader. Let's see what RC 2.2 will look like...
Comment 53 Andre Robatino 2013-01-08 23:44:26 EST
18 Final RC2.2 is under size limit:

Fedora-18-i686-Live-XFCE.iso : 694157312 bytes (662 MiB)
Fedora-18-x86_64-Live-XFCE.iso : 724566016 bytes (691 MiB)
Comment 54 Andre Robatino 2013-01-09 13:20:32 EST
18 Final RC3 is oversized:

Fedora-18-i686-Live-XFCE.iso : 695205888 bytes (663 MiB)
Fedora-18-x86_64-Live-XFCE.iso : 735051776 bytes (701 MiB)

Note that the exact actual size limit on most types of CD is something like 702.83 MiB (see https://lists.fedoraproject.org/pipermail/test/2010-April/089943.html ) so this size should be usable for most people. However, it IS larger than the advertised size of 700 MiB, so unless someone wants to write up something detailed on the exact size limit for all types of CD (which I don't think anyone has ever done, and I suspect no one would want to waste the required time on, for the roughly half a percent it would gain), it's safer and less confusing to keep using the advertised size.
Comment 55 Christoph Wickert 2013-01-09 13:27:15 EST
I still don't get how there can be 10 MB size difference between RC2.2 and RC3 and why this only happens on x86_64.

Is there a chance to respin only x86_64, just to see if it makes a difference?
Comment 56 Christoph Wickert 2013-01-09 13:31:00 EST
Oh, I just found RC4, which is well under the limit again (691 MB)
Comment 57 Christoph Wickert 2013-01-09 13:34:07 EST
Sorry, I confused RC4 and TC4. Let's wait for RC4 to finish then.
Comment 58 Andre Robatino 2013-01-09 16:26:49 EST
18 Final RC4 is within size limit:

Fedora-18-i686-Live-XFCE.iso : 694157312 bytes (662 MiB)
Fedora-18-x86_64-Live-XFCE.iso : 724566016 bytes (691 MiB)
Comment 59 Christoph Wickert 2013-01-10 14:06:19 EST
As RC4 was declared gold, we can close this.