This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 858628

Summary: Some buttons and labels in Anaconda can't be localized
Product: [Fedora] Fedora Reporter: xset1980
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: awilliam, g.kaviyarasu, jonathan, kparal, piotrdrag, rhe, robatino, stephent98, vanmeeuwen+fedora
Target Milestone: ---Keywords: i18n, Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedBlocker
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-02 12:30:53 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 875846, 877658, 888030, 889352    
Bug Blocks: 752661    
Attachments:
Description Flags
screenshot of language button error
none
[18.29] screenshot showing "DATE & TIME" not translated
none
[18.29] screenshot showing "KEYBOARD" not translated none

Description xset1980 2012-09-19 05:07:08 EDT
Created attachment 614281 [details]
screenshot of language button error

Description of problem:

When spanish language is selected from anaconda installer, the text over the combo box is correct, in spanish and fixed, but the button 'quit' and 'continue' is wrong.

The ubuntu installer or others, when i select the language, all change for the selected language. So, the button "continue" and "quit" will be "continuar" and "salir" respectly.

Version-Release number of selected component (if applicable):

Fedora 18 Alpha LiveCD KDE i686

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Attach image with indications
Comment 1 Chris Lumens 2012-10-04 11:05:32 EDT
*** Bug 681114 has been marked as a duplicate of this bug. ***
Comment 2 Chris Lumens 2012-11-05 12:37:52 EST
*** Bug 858634 has been marked as a duplicate of this bug. ***
Comment 3 Steve Tyler 2012-11-18 14:43:07 EST
Created attachment 647281 [details]
[18.29] screenshot showing "DATE & TIME" not translated
Comment 4 Steve Tyler 2012-11-18 14:45:09 EST
Created attachment 647282 [details]
[18.29] screenshot showing "KEYBOARD" not translated
Comment 5 Steve Tyler 2012-11-18 16:08:04 EST
Kamil: IIUC, this bug affects all languages with significant translation coverage, so I would like to propose it as an F18Blocker.[1]

Test procedure:
1. Select a language with 100% translation coverage for anaconda.[2]
2. Visit each spoke and note that the spoke title is in English.
   The spoke titles in the hub are translated, however.

[1] Per F18 Final criterion:

15. All critical path actions on release-blocking desktop environments should correctly display all sufficiently complete translations available for use 

Fedora 18 Final Release Criteria
https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria

[2] https://fedora.transifex.com/projects/p/anaconda/resource/master/

Tested with:
$ qemu-kvm -m 2048 -hda f18-test-1.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC9/Fedora-18-Beta-TC9-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse
Comment 6 Kamil Páral 2012-11-19 04:19:35 EST
It really seems that some buttons and labels in Anaconda are not i18n'd, so they can't be translated at all.

Steve, you don't need to CC me, just set the Blocks field according to https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process . Thanks. Doing that now.
Comment 7 Steve Tyler 2012-11-19 09:42:07 EST
Thanks, Kamil. I looked into this and found that there are a lot of things that can go wrong with translations ... :-)

'_Close' and 'USER SETTINGS' are not in anaconda.pot, but many more strings are in anaconda.pot:

$ egrep 'Cancel|Close|Continue|Done|OK|Quit|Reboot' anaconda-18.29-1/po/anaconda.pot | sort

$ egrep 'CONFIGURATION|DATE & TIME|INSTALLATION DESTINATION|INSTALLATION SOURCE|INSTALLATION SUMMARY|KEYBOARD|MANUAL PARTITIONING|NETWORK CONFIGURATION|PRE-RELEASE / TESTING|ROOT PASSWORD|SOFTWARE SELECTION|USER SETTINGS' anaconda-18.29-1/po/anaconda.pot | sort

$ grep '%(productName)s %(productVersion)s INSTALLATION' anaconda-18.29-1/po/anaconda.pot

BTW, I can only set Blocks on bugs I create.
Comment 8 Adam Williamson 2012-11-29 13:39:13 EST
Discussed at 2012-11-29 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-11-29/f18final-blocker-review-1.1.2012-11-29-17.01.log.txt . accepted as a blocker per criterion in comment #5.
Comment 9 Chris Lumens 2012-11-29 21:34:52 EST
*** Bug 875846 has been marked as a duplicate of this bug. ***
Comment 10 xset1980 2012-11-29 23:24:03 EST
Persistent on Fedora 18 KDE beta rc1 up to date. Same bug. Fresh install today.
Comment 11 Chris Lumens 2012-11-30 10:08:26 EST
*** Bug 882103 has been marked as a duplicate of this bug. ***
Comment 12 Chris Lumens 2012-11-30 10:08:45 EST
*** Bug 882102 has been marked as a duplicate of this bug. ***
Comment 13 Chris Lumens 2012-11-30 15:45:31 EST
I love it when bugzilla eats a comment.

Anyway, I've posted a pretty big set of translation-related patches to the list that takes care of everything in the initial comments and reduces the untranslated stuff down to:  some stock GTK buttons, the names of roots in the custom partitioning LHS, the ISO selection dialog (which is a GTK stock widget), and all of python-meh except the Quit button.

My concern with this bug report is that aside from the initial comment, it's grown into a "not everything is completely translated!" sort of bug.  Of course, not everything is ever going to be completely translated for one reason or another and having one massive bug that continues to be a blocker when the remaining translation problems continue to get smaller isn't workable.  So I'm going to put this one in POST, and you guys can debate what you want to do for the remainder of the problems I have outlined.  I would not consider a handful of untranslated buttons to be a blocker, incidentally.
Comment 14 Kamil Páral 2012-12-03 04:16:38 EST
Chris, when you write "untranslated button", you mean non-internationalized button, right?

Internationalization is the process of designing a software application so that it can be adapted to various languages and regions without engineering changes. Localization is the process of adapting internationalized software for a specific region or language by adding locale-specific components and translating text.
http://en.wikipedia.org/wiki/I18n

Because untranslated button is not a problem, we can't force translators to translate text, but they can do it if they want. This bug report concerns buttons and labels which _can't_ be translated, because they are not internationalized.

What is the problem with stock GTK buttons and other widgets? I would assume that stock GTK widgets are 1) already internationalized 2) already translated, just include the proper gettext .mo file in the filesystem.
Comment 15 Chris Lumens 2012-12-03 10:15:30 EST
What I mean is that there is a small number of buttons that are GTK stock widgets whose translations are not being displayed when you change languages on the welcome screen.  I don't know what causes that, though.
Comment 16 Chris Lumens 2012-12-04 16:35:57 EST
I have pushed an awful lot of commits for translation problems that will be in anaconda-18.35-1.  For the list of what's still not translated, please see:

https://lists.fedorahosted.org/pipermail/anaconda-patches/2012-November/002280.html
Comment 17 Adam Williamson 2012-12-13 19:29:42 EST
18.36 has gone stable, so the big set of fixes for this is in. Can l10n/i18n folks take a look at 18 Final TC1 or TC2 and let us know if they think the current state of translation is acceptable and this bug can be closed? Thanks.
Comment 18 Steve Tyler 2012-12-14 12:06:47 EST
It might be a good idea to add "i18n" as a keyword for this bug ...
Comment 19 Steve Tyler 2012-12-14 12:18:25 EST
This bug blocks testing the current translation status for some languages:
Bug 887236 - UnicodeDecodeError: 'ascii' codec can't decode byte 0xe6 in position 3: ordinal not in range(128)
Comment 20 Kamil Páral 2012-12-17 05:47:26 EST
I tested with Polish, which has 100% translation in Transifex. There are still a few strings unlocalized:

http://imgur.com/a/hBmFs

> Fedora NUMBER installation
> Set keyboard to default layout for selected language
> Test the selected layout below:

Some translations don't work on DVD, but work on LiveCD. I think appropriate GTK translations are either not included on DVD, or anaconda is telling GTK to display them in English (or something like that):
> ON-OFF sliders
> OK, Cancel

Some translations don't work on DVD, but can't be tested on LiveCD:
> Open, Cancel

Some buttons seem to be Anaconda-specific (not using GTK default buttons), because they are untranslated both on DVD and LiveCD:
> Remove, Close, Select, Cancel

Some desktop environments descriptions are missing translations. I have checked and exactly the same strings are also untranslated in French, so maybe there's some there's some problem even in comps.xml?
Comment 21 Chris Lumens 2012-12-17 11:49:07 EST
I've already laid out my thoughts on this in comment #13, but I can see it's becoming exactly what I said I didn't want - a bug for every single translation problem in the entire installer.  I'm really not going to have time to get back to this bug for F18, so how it is now is pretty much as good as it is going to get.
Comment 22 Steve Tyler 2012-12-17 12:17:21 EST
Thanks, Kamil. Here is a Spanish translation status inventory for the DVD[1]. Only the developers will be able to say for sure what new bugs should be opened against what components ...

FEDORA 18-TC2 INSTALLATION (all dialogs)

Welcome
    Set keyboard to default layout for selected language.[2]

Date & Time
    ON, OFF     (Network Time switch)[3]
    Cancel, OK  (NTP servers)

Keyboard
    Cancel, OK  (Layout Switching Options)

Network Configuration
    ON, OFF (switch)[3]
    Cancel  (Configure: Editing eth0)

Software Selection
    Some desktop and add-on descriptions[5]

Installation Destination
    Remove, Close (Selected Disks)
    Do not install bootloader (Selected Disks)[2]
    Cancel (Reclaim Disk Space)

Manual Partitioning
    Not enough free space on disks for automatic partitioning (error message)[4]
    Close (error message)

[1] Fedora-18-TC2-x86_64-DVD.iso
[2] Strings not translated at Transifex:
    https://fedora.transifex.com/projects/p/anaconda/resource/master/l/es/view/
[3] Bug 875846 - [i18n] "ON" and "OFF" not translated in switches on DVD
[4] Bug 877658 - [i18n] not translated: "Not enough free space on disks for automatic partitioning"
[5] Strings not listed under "comps" at Transifex:
    https://fedora.transifex.com/projects/p/comps/resource/default/l/es/view/
Comment 23 Piotr Drąg 2012-12-17 14:06:14 EST
(In reply to comment #20)
> > Set keyboard to default layout for selected language
> > Test the selected layout below:

These two are expected, since the new strings were added before the last anaconda release, and they should be translated in the next one. So, not related to this bug.

> > Fedora NUMBER installation
> > ON-OFF sliders
> > OK, Cancel
> > Open, Cancel
> > Remove, Close, Select, Cancel
> 

These look like bugs, as Chris mentioned in comment #13. I consider this a blocker for every locale except English, but of course it's up to developers and not me.

> Some desktop environments descriptions are missing translations. I have
> checked and exactly the same strings are also untranslated in French, so
> maybe there's some there's some problem even in comps.xml?

It's the case of comps translations not being updated in quite some time, we probably need to ask Bill Nottingham to update it in a new bug report. Again, not this bug report.
Comment 24 Chris Lumens 2012-12-17 14:18:52 EST
> > > Set keyboard to default layout for selected language
> > > Test the selected layout below:
> 
> These two are expected, since the new strings were added before the last
> anaconda release, and they should be translated in the next one. So, not
> related to this bug.

Correct.

> > > Fedora NUMBER installation
> > > ON-OFF sliders
> > > OK, Cancel
> > > Open, Cancel
> > > Remove, Close, Select, Cancel
> > 
> 
> These look like bugs, as Chris mentioned in comment #13. I consider this a
> blocker for every locale except English, but of course it's up to developers
> and not me.

Almost all of these are due to bug 875846, which I had marked as a dupe of this one.

The first one is due to pyanaconda/product.py not being in po/POTFILES.in.  I'll add that.

> > Some desktop environments descriptions are missing translations. I have
> > checked and exactly the same strings are also untranslated in French, so
> > maybe there's some there's some problem even in comps.xml?
> 
> It's the case of comps translations not being updated in quite some time, we
> probably need to ask Bill Nottingham to update it in a new bug report.
> Again, not this bug report.

Correct.

But it looks like there's only one thing left in this bug report for anaconda.  I'm going to make that change, push, and put this bug back into MODIFIED.  Everything else needs to be tracked elsewhere.  No catch-all bugs.
Comment 25 Steve Tyler 2012-12-17 15:59:35 EST
Thanks, Kamil and Piotr:
Bug 888030 - [i18n] some package set descriptions not translated
Comment 26 Fedora Update System 2012-12-18 20:34:54 EST
anaconda-18.37.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.37.4-1.fc18
Comment 27 Kamil Páral 2012-12-19 12:13:21 EST
There seems to be no change in 18.37.4. But e.g. this string
> Set keyboard to default layout for selected language
is translated into Polish inside Transifex. So maybe anaconda just haven't received the translations yet?

We can't verify, though. We'll have to check in the next build.
Comment 28 Steve Tyler 2012-12-19 12:50:53 EST
The Polish translation is in anaconda-18.37.4-1.fc18:
Set _keyboard to default layout for selected language.
Ustawienie _klawiatury na domyślny układ dla wybranego języka.

Verified by grepping:
/usr/share/locale/pl/LC_MESSAGES/anaconda.mo

This looks like a new bug ...

Tested with:
$ qemu-kvm -m 2048 -hda f18-test-3.img -cdrom ~/xfr/fedora/F18/F18-Final/TC3/Fedora-18-TC3-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse
Comment 29 Fedora Update System 2012-12-19 17:41:43 EST
Package anaconda-18.37.4-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.37.4-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20677/anaconda-18.37.4-1.fc18
then log in and leave karma (feedback).
Comment 30 Fedora Update System 2012-12-20 00:36:31 EST
anaconda-18.37.4-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 31 Kamil Páral 2012-12-20 06:48:04 EST
Comment 28 confirmed with anaconda 18.37.5. The string is translated and available in the .mo file, but it is always displayed in English in the UI. The other two strings:
> Fedora NUMBER installation
> Test the selected layout below:
are translated and displayed in Polish correctly.
Comment 32 Steve Tyler 2012-12-20 16:46:57 EST
Bug 889352 - [i18n] translated string not displayed in Welcome dialog: "Set keyboard to default layout for selected language."
Comment 33 Adam Williamson 2012-12-20 18:47:39 EST
Does this need to be open if we have a separate bug for that problem? Chris said he doesn't want this to be a catch-all 'translations are wrong' bug.
Comment 34 Adam Williamson 2012-12-20 22:42:01 EST
Steve: this is not a tracker bug.
Comment 35 Steve Tyler 2012-12-20 22:46:49 EST
A catch-all bug for translations is actually a good idea, since it is often not at all clear what the actual problem is. Indeed, Chris mistakenly duped Bug 875846 to this one (Read Comment 24 carefully for an oblique admission ... :-)).

Instead, I have made four translation-related bugs blockers for this one. Doing that is analogous to setting up release blockers.

Call this a translation tracker bug, if you like ... :-)
Comment 36 Adam Williamson 2012-12-20 22:50:44 EST
No, let's not call it that, because it's not that, and Chris expressly said that he doesn't want it to be that.

If you want to have one of those, file a new one.
Comment 37 Kamil Páral 2012-12-21 07:40:02 EST
(In reply to comment #33)
> Does this need to be open if we have a separate bug for that problem? Chris
> said he doesn't want this to be a catch-all 'translations are wrong' bug.

Yes he said that, but he didn't say which problems he wants to have tracked here and which problems he wants to have filed separately. Also there is no information which strings is anaconda-18.37.4-1.fc18 supposed to fix, so I can't really say whether this bug should be closed or kept open. That's why I left it open and up to Chris' consideration.
Comment 38 Chris Lumens 2013-01-02 10:59:40 EST
Please see comment #16, comment #24, and bug 875846.  If you have any new problems, open a new bug.  I'm done with this one.
Comment 39 Adam Williamson 2013-01-02 12:30:53 EST
If you're done with it, let's close it. Please just file translation issues from any build after 18.37.4 separately, folks. Thanks.