Bug 862972

Summary: AttributeError: 'NoneType' object has no attribute 'resizable'
Product: [Fedora] Fedora Reporter: Mark Hamzy <hamzy>
Component: anacondaAssignee: Chris Lumens <clumens>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: awilliam, cwickert, g.kaviyarasu, jonathan, jsedlak, ljozsa, mbanas, petersen, psklenar, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: ppc64   
OS: Unspecified   
Whiteboard: abrt_hash:55af814abdd87a3949e984c4f3da848654865cc10e330f3ed7c540d116041748
Fixed In Version: anaconda-18.15-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-11-22 21:45:25 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
File: anaconda-tb
File: product
File: type
File: environ
File: storage.log
File: version
File: program.log
File: anaconda.log
File: syslog
File: hashmarkername
File: packaging.log
File: cmdline_file
File: release
File: description none

Description Mark Hamzy 2012-10-04 00:27:40 EDT
Version-Release number of selected component:

Additional info:
libreport version: 2.0.12
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.0-2.fc18.ppc64
Comment 1 Mark Hamzy 2012-10-04 00:27:43 EDT
Created attachment 621322 [details]
File: anaconda-tb
Comment 2 Mark Hamzy 2012-10-04 00:27:44 EDT
Created attachment 621323 [details]
File: product
Comment 3 Mark Hamzy 2012-10-04 00:27:46 EDT
Created attachment 621324 [details]
File: type
Comment 4 Mark Hamzy 2012-10-04 00:27:48 EDT
Created attachment 621325 [details]
File: environ
Comment 5 Mark Hamzy 2012-10-04 00:27:50 EDT
Created attachment 621326 [details]
File: storage.log
Comment 6 Mark Hamzy 2012-10-04 00:27:52 EDT
Created attachment 621327 [details]
File: version
Comment 7 Mark Hamzy 2012-10-04 00:27:58 EDT
Created attachment 621328 [details]
File: program.log
Comment 8 Mark Hamzy 2012-10-04 00:27:59 EDT
Created attachment 621329 [details]
File: anaconda.log
Comment 9 Mark Hamzy 2012-10-04 00:28:01 EDT
Created attachment 621330 [details]
File: syslog
Comment 10 Mark Hamzy 2012-10-04 00:28:03 EDT
Created attachment 621331 [details]
File: hashmarkername
Comment 11 Mark Hamzy 2012-10-04 00:28:04 EDT
Created attachment 621332 [details]
File: packaging.log
Comment 12 Mark Hamzy 2012-10-04 00:28:06 EDT
Created attachment 621333 [details]
File: cmdline_file
Comment 13 Mark Hamzy 2012-10-04 00:28:07 EDT
Created attachment 621334 [details]
File: release
Comment 14 Mark Hamzy 2012-10-04 00:28:09 EDT
Created attachment 621335 [details]
File: description
Comment 15 Chris Lumens 2012-10-04 10:06:47 EDT
Can you see why getDeviceByPath is failing at that point?
Comment 16 Chris Lumens 2012-10-05 10:35:02 EDT
*** Bug 863353 has been marked as a duplicate of this bug. ***
Comment 17 Christoph Wickert 2012-10-07 17:14:16 EDT
I tried to install Fedora over an existing install. It took me several attempts to figure out how to 'reclaim free space' works, and when I finally told it to wipe all partitions, i selected automatic creation of mountpoints in the next screen. Went back to the main hub and anaconda crashed.

Package: anaconda-18.12
Architecture: i686
OS Release: Fedora release 18-Beta-TC2
Comment 18 Chris Lumens 2012-10-08 10:38:00 EDT
*** Bug 864086 has been marked as a duplicate of this bug. ***
Comment 19 Chris Lumens 2012-10-09 10:04:34 EDT
*** Bug 864488 has been marked as a duplicate of this bug. ***
Comment 20 Chris Lumens 2012-10-09 10:24:21 EDT
*** Bug 864180 has been marked as a duplicate of this bug. ***
Comment 21 Chris Lumens 2012-10-09 10:45:06 EDT
How can I reliably reproduce this?  I've tried screwing with the resize dialog quite a bit and haven't hit this yet.
Comment 22 Mark Hamzy 2012-10-09 10:51:47 EDT
Why would you close the bug with the reproduction information in it as well as some debug information in it?
Comment 23 Mark Hamzy 2012-10-09 12:52:34 EDT
Copying over the reproduction details from bug 864180 as the excetption is still occurring.

1) Select "Software Selection," choose "Minimal install," select Done.
2) Select "Installation Destination," deselect disk, select Done.
3) Select "Installation Destination," select disk, select Done.
4) Select "Installation Destination," select Continue.
5) Select "Reclaim Space," select "/ (Fedora Linux 18 for ppc64)," change action to Delete, select "Reclaim Space."
6) Select "Reclaim Space," anaconda traps

The anaconda updates.img file contains the following because I am unable to change the execution line number back to the dev = getDevicesByPath() line

[root@bluebill anaconda-18.13-1]# git diff
diff --git a/pyanaconda/ui/gui/spokes/lib/resize.py b/pyanaconda/ui/gui/spokes/lib/resize.py
index fcccbeb..14b8982 100644
--- a/pyanaconda/ui/gui/spokes/lib/resize.py
+++ b/pyanaconda/ui/gui/spokes/lib/resize.py
@@ -120,6 +120,11 @@ class ResizeDialog(GUIObject):
             for part in disk.format.partitions:
                 dev = self.storage.devicetree.getDeviceByPath(part.path)
+                if dev is None:
+                    import pdb
+                    pdb.set_trace()
+                    self.storage.devicetree.getDeviceByPath(part.path)
                 if dev.isExtended and disk.format.logicalPartitions:

> /tmp/updates/pyanaconda/storage/devicetree.py(2062)getDeviceByPath()
-> if not path:
(Pdb) print path
(Pdb) print preferLeaves
(Pdb) path in [d.path for d in self._devices]
(Pdb) [d.path for d in self._devices]
['/dev/sda', '/dev/sda1', '/dev/sda2', '/dev/sda3', '/dev/sda4', '/dev/sr0', '/run/install/repo/LiveOS/squashfs.img', '/dev/loop0', '/LiveOS/rootfs.img', '/dev/loop1', '/overlay (deleted)', '/dev/loop2', '/dev/mapper/live-rw']

So it seems that the extended partition is no longer in _devices.

[anaconda root@sharpie /]# fdisk -l /dev/sda

Disk /dev/sda: 32.2 GB, 32212254720 bytes, 62914560 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x90570900

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048       10239        4096   41  PPC PReP Boot
/dev/sda2           10240     1034239      512000   83  Linux
/dev/sda3         1034240     9324543     4145152   82  Linux swap / Solaris
/dev/sda4         9324544    62914559    26795008    5  Extended
/dev/sda5         9326592    62914559    26793984   83  Linux
Comment 24 Fedora Update System 2012-10-10 21:05:26 EDT
anaconda-18.15-1.fc18 has been submitted as an update for Fedora 18.
Comment 25 Fedora Update System 2012-10-10 22:59:04 EDT
Package anaconda-18.15-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.15-1.fc18'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).
Comment 26 Chris Lumens 2012-10-11 10:28:41 EDT
*** Bug 865322 has been marked as a duplicate of this bug. ***
Comment 27 Fedora Update System 2012-10-11 21:07:15 EDT
anaconda-18.16-1.fc18 has been submitted as an update for Fedora 18.
Comment 28 Fedora Update System 2012-10-16 23:10:19 EDT
anaconda-18.17-1.fc18 has been submitted as an update for Fedora 18.
Comment 29 Fedora Update System 2012-10-17 22:39:05 EDT
anaconda-18.18-1.fc18 has been submitted as an update for Fedora 18.
Comment 30 Fedora Update System 2012-10-19 21:34:54 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
Comment 31 Adam Williamson 2012-11-22 21:45:25 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.