Bug 902917

Summary: [abrt] coreutils-8.12-9.fc16: keycompare_mb: Process /bin/sort was killed by signal 11 (SIGSEGV)
Product: [Fedora] Fedora Reporter: Leif Nixon <nixon>
Component: coreutilsAssignee: Ondrej Vasik <ovasik>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: admiller, kdudka, kzak, matthew.hooper, ovasik, p, twaugh
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:f8ff689118fd497fab42620d9525b88dff699400
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-01 11:27:32 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: var_log_messages
none
File: backtrace none

Description Leif Nixon 2013-01-22 12:56:48 EST
libreport version: 2.0.10
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        sort -d
crash_function: keycompare_mb
executable:     /bin/sort
kernel:         3.6.10-2.fc16.x86_64
pid:            8348
pwd:            /home/nixon
time:           Tue 22 Jan 2013 06:44:24 PM CET
uid:            500
username:       nixon

backtrace:      Text file, 35586 bytes
var_log_messages: Text file, 8773 bytes

build_ids:
:e7160fedcf92e2c07f8883f15c71d703b9e7abcb
:3ff616a5dd71e3f09451dfb4186163a797825395
:2e4f144d6c8fb2dbb214fdbea0c327b05fa70a78
:f8f4d8e260ee8f3b262936920270ace01b2da537

comment:
:perl -e 'print "1","A"x50000000,"\r\n\r\n"' | sort -d
:
:*ka-blow*

dso_list:
:/lib64/libpthread-2.14.90.so glibc-2.14.90-24.fc16.9.x86_64 (Fedora Project) 1347023402
:/usr/lib/locale/locale-archive glibc-common-2.14.90-24.fc16.9.x86_64 (Fedora Project) 1347023414
:/usr/lib64/gconv/gconv-modules.cache glibc-2.14.90-24.fc16.9.x86_64 (Fedora Project) 1347023402
:/lib64/libc-2.14.90.so glibc-2.14.90-24.fc16.9.x86_64 (Fedora Project) 1347023402
:/bin/sort coreutils-8.12-9.fc16.x86_64 (Fedora Project) 1358410391
:/lib64/ld-2.14.90.so glibc-2.14.90-24.fc16.9.x86_64 (Fedora Project) 1347023402

environ:
:XDG_VTNR=8
:SSH_AGENT_PID=18248
:XDG_SESSION_ID=5
:rvm_bin_path=/home/nixon/.rvm/bin
:SAL_USE_VCLPLUGIN=gtk
:HOSTNAME=stuor.nsc.liu.se
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GEM_HOME=/home/nixon/.rvm/gems/ruby-1.9.2-p320
:TERM=xterm
:XDG_MENU_PREFIX=lxde-
:SHELL=/bin/bash
:XDG_SESSION_COOKIE=81d6fce0be411691496a9c174b7e581c-1358416552.934047-1882449594
:HISTSIZE=1000
:IRBRC=/home/nixon/.rvm/rubies/ruby-1.9.2-p320/.irbrc
:QTDIR=/usr/lib64/qt-3.3
:GNOME_KEYRING_CONTROL=/tmp/keyring-PzEJN2
:QTINC=/usr/lib64/qt-3.3/include
:MY_RUBY_HOME=/home/nixon/.rvm/rubies/ruby-1.9.2-p320
:IMSETTINGS_MODULE=IBus
:USER=nixon
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.html=00;33:*.wpd=00;33:
:__array_start=0
:rvm_path=/home/nixon/.rvm
:SSH_AUTH_SOCK=/tmp/ssh-pNhHxDe18165/agent.18165
:USERNAME=nixon
:escape_flag=1
:rvm_prefix=/home/nixon
:DESKTOP_SESSION=LXDE
:MAIL=/var/spool/mail/nixon
:PATH=/home/nixon/.rvm/gems/ruby-1.9.2-p320/bin:/home/nixon/.rvm/gems/ruby-1.9.2-p320@global/bin:/home/nixon/.rvm/rubies/ruby-1.9.2-p320/bin:/home/nixon/.rvm/bin:/home/nixon/bin:/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/nixon/.rvm/bin:/home/nixon/.rvm/bin
:QT_IM_MODULE=xim
:PWD=/home/nixon
:XMODIFIERS=@im=ibus
:EDITOR=emacs
:GNOME_KEYRING_PID=18161
:LANG=en_US.UTF-8
:KDE_IS_PRELINKED=1
:KDEDIRS=/usr
:_second=1
:GDMSESSION=LXDE
:_LXSESSION_PID=18165
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:rvm_env_string=ruby-1.9.2-p320
:'rvm_version=1.16.20 (stable)'
:SHLVL=2
:HOME=/home/nixon
:M2_HOME=/usr/share/java/maven
:XDG_SEAT=seat0
:XDG_CONFIG_HOME=/home/nixon/.config
:rvm_ruby_string=ruby-1.9.2-p320
:_first=0
:LOGNAME=nixon
:CVS_RSH=ssh
:QTLIB=/usr/lib64/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-gmye5bE4Ug,guid=505befec957b53cbab3dea9900021a97
:GEM_PATH=/home/nixon/.rvm/gems/ruby-1.9.2-p320:/home/nixon/.rvm/gems/ruby-1.9.2-p320@global
:rvm_rubygems_path=/home/nixon/.rvm/rubygems
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=8
:XDG_RUNTIME_DIR=/run/user/nixon
:DISPLAY=:0
:XDG_CURRENT_DESKTOP=LXDE
:RUBY_VERSION=ruby-1.9.2-p320
:XAUTHORITY=/var/run/gdm/auth-for-nixon-BqksY6/database
:_=/bin/sort

maps:
:00400000-00419000 r-xp 00000000 fd:01 13041                              /bin/sort
:00618000-00619000 r--p 00018000 fd:01 13041                              /bin/sort
:00619000-0061a000 rw-p 00019000 fd:01 13041                              /bin/sort
:0244b000-0246c000 rw-p 00000000 00:00 0                                  [heap]
:7f208c7c3000-7f2090577000 rw-p 00000000 00:00 0 
:7f2090f60000-7f2090f61000 rw-p 00000000 00:00 0 
:7f2091782000-7f2097ba5000 r--p 00000000 fd:01 53399                      /usr/lib/locale/locale-archive
:7f2097ba5000-7f2097d52000 r-xp 00000000 fd:01 46040                      /lib64/libc-2.14.90.so
:7f2097d52000-7f2097f52000 ---p 001ad000 fd:01 46040                      /lib64/libc-2.14.90.so
:7f2097f52000-7f2097f56000 r--p 001ad000 fd:01 46040                      /lib64/libc-2.14.90.so
:7f2097f56000-7f2097f58000 rw-p 001b1000 fd:01 46040                      /lib64/libc-2.14.90.so
:7f2097f58000-7f2097f5d000 rw-p 00000000 00:00 0 
:7f2097f5d000-7f2097f74000 r-xp 00000000 fd:01 46064                      /lib64/libpthread-2.14.90.so
:7f2097f74000-7f2098173000 ---p 00017000 fd:01 46064                      /lib64/libpthread-2.14.90.so
:7f2098173000-7f2098174000 r--p 00016000 fd:01 46064                      /lib64/libpthread-2.14.90.so
:7f2098174000-7f2098175000 rw-p 00017000 fd:01 46064                      /lib64/libpthread-2.14.90.so
:7f2098175000-7f2098179000 rw-p 00000000 00:00 0 
:7f2098179000-7f209819b000 r-xp 00000000 fd:01 46730                      /lib64/ld-2.14.90.so
:7f209836e000-7f2098371000 rw-p 00000000 00:00 0 
:7f2098392000-7f2098399000 r--s 00000000 fd:01 44307                      /usr/lib64/gconv/gconv-modules.cache
:7f2098399000-7f209839a000 rw-p 00000000 00:00 0 
:7f209839a000-7f209839b000 r--p 00021000 fd:01 46730                      /lib64/ld-2.14.90.so
:7f209839b000-7f209839c000 rw-p 00022000 fd:01 46730                      /lib64/ld-2.14.90.so
:7f209839c000-7f209839d000 rw-p 00000000 00:00 0 
:7fffe4f27000-7fffe4f48000 rw-p 00000000 00:00 0                          [stack]
:7fffe4f54000-7fffe4f55000 r-xp 00000000 00:00 0                          [vdso]
:ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]
Comment 1 Leif Nixon 2013-01-22 12:56:54 EST
Created attachment 685350 [details]
File: var_log_messages
Comment 2 Leif Nixon 2013-01-22 12:56:57 EST
Created attachment 685351 [details]
File: backtrace
Comment 3 Ondrej Vasik 2013-01-22 15:24:05 EST
Thanks for report... yet another issue with multibyte patch. I'll check what's wrong in this case (we have 10+ known issues in this patch, many not easy to fix...)... Using C locales (LC_ALL=C) before sort to make sort using singlebyte code path should help here...
Comment 4 Fedora Update System 2013-01-24 15:46:14 EST
coreutils-8.17-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/coreutils-8.17-8.fc18
Comment 5 Fedora Update System 2013-01-25 16:24:19 EST
Package coreutils-8.17-8.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing coreutils-8.17-8.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1455/coreutils-8.17-8.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-01-30 11:18:56 EST
coreutils-8.15-10.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/coreutils-8.15-10.fc17
Comment 7 Fedora Update System 2013-02-01 11:27:34 EST
coreutils-8.17-8.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-03-12 04:51:21 EDT
coreutils-8.15-10.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Ondrej Vasik 2013-03-15 10:38:45 EDT
*** Bug 922021 has been marked as a duplicate of this bug. ***
Comment 10 Ondrej Vasik 2013-03-15 10:40:43 EDT
*** Bug 922027 has been marked as a duplicate of this bug. ***
Comment 11 Ondrej Vasik 2013-03-15 10:41:17 EDT
*** Bug 922025 has been marked as a duplicate of this bug. ***