Bug 992666

Summary: perl-Language-Expr: FTBFS in rawhide
Product: [Fedora] Fedora Reporter: Dennis Gilmore <dennis>
Component: perl-Language-ExprAssignee: Orphan Owner <extras-orphan>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: awilliam, me, mhroncok, michael.wiktowy, paul, ppisar, woodsjaya
Target Milestone: ---Keywords: CommonBugs
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: https://fedoraproject.org/wiki/Common_F20_bugs#perlLangExpr-depend-error
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-06-01 03:51:36 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1009919    
Bug Blocks: 991858, 992675, 997835, 1105908    

Description Dennis Gilmore 2013-08-05 01:51:01 EDT
Your package perl-Language-Expr failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=5737206

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/7206/5737206/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/7206/5737206/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/7206/5737206/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
Comment 1 Jitka Plesnikova 2013-08-15 10:30:17 EDT
Should be fix by the latest upstream version Language-Expr-0.21.
Please update it.
Comment 2 Paul Howarth 2013-08-15 10:43:37 EDT
I don't think so; it depends on Regexp::Grammars, which blurts out a huge warning and croaks when used. It might work with an older version of Regexp::Grammars that doesn't have that, perhaps.
Comment 3 Paul Howarth 2013-08-19 04:44:17 EDT
It still doesn't work with the new Regexp::Grammars 1.031 either. Looks like we might have to wait for Perl 5.18.2.
Comment 4 Miro Hrončok 2013-08-19 09:10:50 EDT
Yes it seems we have to wait https://rt.cpan.org/Public/Bug/Display.html?id=87880#txn-1250566
Comment 5 Fedora End Of Life 2013-09-16 12:50:53 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 20 development cycle.
Changing version to '20'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora20
Comment 6 Miro Hrončok 2013-09-17 06:34:51 EDT
Affects both Rawhide and F20.
Comment 7 Miro Hrončok 2013-10-09 06:15:53 EDT
*** Bug 1016693 has been marked as a duplicate of this bug. ***
Comment 8 Paul Howarth 2013-10-30 17:29:01 EDT
*** Bug 1025004 has been marked as a duplicate of this bug. ***
Comment 9 Miro Hrončok 2013-10-30 18:01:00 EDT
Is there something I can do to prevent failures such as bz1025004? E.g. delete the package from F20 somehow?
Comment 10 Paul Howarth 2013-10-30 18:12:25 EDT
Well you could retire the package and anything that depended on it but then you'd still have the problem that people with the package installed at F-19 would have dependency errors trying to upgrade to F-20. And it would then need re-reviewing before it could be re-introduced into Fedora once fixed.

If it was my package I'd just sit it out until 5.18.2 came out, which will hopefully result in a fix.
Comment 11 Patrick Uiterwijk 2013-12-17 15:09:28 EST
This is still broken in the Fedora 20 release, and draws quite some packages with it (amongst which are uuid, perl-OpenGL, some perl-Math parts, and perl-Digest-SHA1).

I think this should just be fixed, and should certainly not be removed.
Comment 12 Miro Hrončok 2013-12-17 15:42:55 EST
I'm not quite sure if this is going to be fixed as it depends on "bug" in Perl itself. I didn't mean to break anything, all I wanted was to prevent broken updates to F20.
Comment 13 Patrick Uiterwijk 2013-12-17 16:59:24 EST
Okay, though I would really like to see this being fixed.

Please note that I was mistaken: it isn't a dep for all of the packages I said, yum was tricking me with the remove-leaves plugin.

The list of packages that depend on perl-Language-Expr according to repoquery is:
perl-Math-NumSeq-0:55-2.fc19.noarch
perl-Math-NumSeq-0:66-1.fc19.noarch
perl-Math-PlanePath-0:98-2.fc19.noarch
perl-Math-PlanePath-0:110-1.fc19.noarch
slic3r-0:0.9.9-5.fc19.noarch
slic3r-0:0.9.10b-4.fc19.noarch
Comment 14 Miro Hrončok 2013-12-17 17:31:13 EST
All of them no longer depend on this in F20.
Comment 15 Adam Williamson 2013-12-19 22:07:43 EST
Dropping CommonBugs, as this doesn't actually appear to be an issue in F20.
Comment 16 Miro Hrončok 2013-12-20 06:28:13 EST
It's an issue when upgrading to F20
Comment 17 Adam Williamson 2013-12-20 14:03:38 EST
If no other app depends on perl-Language-Expr any more, why?
Comment 18 Paul Howarth 2013-12-20 14:21:22 EST
Because an F-19 system with perl-Language-Expr installed can't be upgraded without breaking dependencies?

The perl-Language-Expr package can't be uninstalled on the F-19 system prior to upgrading because it's a dependency of various packages on F-19 even though they don't have that dependency on F-20.
Comment 19 Adam Williamson 2013-12-20 14:34:30 EST
I still don't see what dependencies are broken on an F20 upgrade if *nothing in F20 requires perl-Language-Expr*. Has someone actually checked this and encountered some kind of dependency issue? If so, what?
Comment 20 Adam Williamson 2013-12-20 14:35:18 EST
Oh, https://bugzilla.redhat.com/show_bug.cgi?id=1025004 , I see.
Comment 21 Paul Howarth 2014-02-18 10:03:23 EST
Bad news:

  "The bug in Perl that is breaking Regexp::Grammars is still present in
   5.18.2. I have raised the issue again with the folks who may be able to
   expedite a fix."

https://rt.cpan.org/Public/Bug/Display.html?id=79149#txn-1326842
Comment 22 Miro Hrončok 2014-06-09 06:18:56 EDT
*** Bug 1106092 has been marked as a duplicate of this bug. ***
Comment 23 Fedora Admin XMLRPC Client 2014-06-28 06:22:35 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 24 Petr Pisar 2014-06-30 04:46:40 EDT
This package has been removed from Fedora 21.
Comment 25 Fedora End Of Life 2015-05-29 05:16:15 EDT
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 26 Petr Pisar 2015-06-01 03:51:36 EDT
Resolved in Fedora 21.