Bug 10001 - RFE: Detect Solaris partitions and dont format as swap
RFE: Detect Solaris partitions and dont format as swap
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
: FutureFeature
: 11590 21262 21333 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-05 23:20 EST by postroom
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-14 12:29:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description postroom 2000-03-05 23:20:48 EST
Solaris partition destroyed by RH6.2Beta install process.

On Intel solaris 2.7 uses type 82 to idenify it's disk partition, The 6.2
version of the install program (custom FTP install from a local machine
containing RH6.2Beta downloaded from sunsite.unc.edu 3/4/2000 @ 23:00 MST)
automatically formatted all linux swap partitions.

My current RH version (6.0) seeks confirmation of which swap partitions to
use thus allowing opportunity to de-select the solaris partition.

While this is likely to affect very few users the consequences are
dramatic. I can appreciate the desire to simplify the installation process
but under normal circumstances would not appreciate having one of my other
operating systems trashed. As it happens no harm was done as I was
rebuilding the machine following H/W upgrades and intended to reinstall
Solaris anyway.

I would suggest at minimum a BIG warning in the manual about this
incompatiability or better still either reinstate the swap selection
screen or selectively query 'large' swap partitions. I ended up with
4480Mb of swap when I was expecting 384Mb.


Thanks Ray Sutton
Comment 1 Jay Turner 2000-03-06 07:33:59 EST
This will not be resolved in the latest release, but we are looking at ways of
dealing with it in future releases.
Comment 2 Michael Fulbright 2000-06-14 09:56:58 EDT
*** Bug 11590 has been marked as a duplicate of this bug. ***
Comment 3 Michael Fulbright 2000-09-26 12:10:31 EDT
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED
Comment 4 Michael Fulbright 2000-09-26 12:56:13 EDT
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED
Comment 5 Michael Fulbright 2000-11-29 14:13:53 EST
*** Bug 21262 has been marked as a duplicate of this bug. ***
Comment 6 Brock Organ 2000-12-04 13:55:17 EST
*** Bug 21333 has been marked as a duplicate of this bug. ***
Comment 7 Michael Fulbright 2001-09-14 12:29:14 EDT
Fixed.
Comment 8 Dan Anderson 2005-03-24 03:00:21 EST
Starting with Solaris 10, Solaris x86  no longer creates NEW partions using 0x82,
which is also used for Linux Swap partitions.

Solaris 10 now uss 0xbf for Solaris partitions.

Disclaimer: I do not speak for my employer.

Note You need to log in before you can comment on or make changes to this bug.