Bug 100909 - rpmbuild script cant find autoconf
rpmbuild script cant find autoconf
Status: CLOSED DUPLICATE of bug 97692
Product: Red Hat Linux Beta
Classification: Retired
Component: gnome-print (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Jay Turner
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-07-26 19:14 EDT by Donald R. Gray Jr
Modified: 2015-01-07 19:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donald R. Gray Jr 2003-07-26 19:14:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
[root@adsl-66-159-199-151 SPECS]# nice rpmbuild -ba --target=i686 gnome-print.spec
Building target platforms: i686
Building for target i686
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.54002
+ umask 022
+ cd /usr/src/redhat/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ cd /usr/src/redhat/BUILD
+ rm -rf gnome-print-0.37
+ /usr/bin/bzip2 -dc /usr/src/redhat/SOURCES/gnome-print-0.37.tar.bz2
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd gnome-print-0.37
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ echo 'Patch #2 (gnome-print-0.30-nofontmaps.patch):'
Patch #2 (gnome-print-0.30-nofontmaps.patch):
+ patch -p1 -b --suffix .nofontmaps -s
+ echo 'Patch #3 (gnome-print-0.34.90-version.patch):'
Patch #3 (gnome-print-0.34.90-version.patch):
+ patch -p1 -b --suffix .version -s
+ echo 'Patch #4 (gnome-print-0.37-perfprint.patch):'
Patch #4 (gnome-print-0.37-perfprint.patch):
+ patch -p1 -b --suffix .perfprint -s
+ echo 'Patch #5 (gnome-print-0.35-kofont.patch):'
Patch #5 (gnome-print-0.35-kofont.patch):
+ patch -p1 -b --suffix .kofont -s
+ tar zxf /usr/src/redhat/SOURCES/hack-macros.tar.gz
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.60370
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd gnome-print-0.37
+ LANG=C
+ export LANG
+ unset DISPLAY
+ libtoolize --copy --force
You should update your `aclocal.m4' by running aclocal.
+ aclocal-1.4 -I macros
+ automake-1.4
+ autoconf-2.13
FATAL ERROR: Autoconf version 2.50 or higher is required for this script
error: Bad exit status from /var/tmp/rpm-tmp.60370 (%build)
 
 
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.60370 (%build)
[root@adsl-66-159-199-151 SPECS]# rpm -qa |grep autoconf
[root@adsl-66-159-199-151 SPECS]# rpm -qa |grep autoconf
[root@adsl-66-159-199-151 SPECS]# rpm -qa |grep autoconf
autoconf-2.57-3
autoconf213-2.13-6


Version-Release number of selected component (if applicable):
gnome-print-0.37-5

How reproducible:
Always

Steps to Reproduce:
1.rpmbuild -ba --target=i686 gnome-print.spec (gnome-print-0.37-5.src.rpm
2.when i try a rpm -qa |grep autoconf it takes a few tries to get a reply 
3.
    

Expected Results:  1.the script should have built the packages
2. rpm -qa |grep autoconf should show installed versions each attempt


Additional info:
Comment 1 Owen Taylor 2003-08-28 17:41:18 EDT

*** This bug has been marked as a duplicate of 97692 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:57:46 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.