Bug 100925 - Should kudzu really run with a 30 second timeout if rhgb prevents user from providing feedback?
Summary: Should kudzu really run with a 30 second timeout if rhgb prevents user from p...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: kudzu (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 101602 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-07-27 06:44 UTC by George Karabin
Modified: 2014-03-17 02:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-08 17:31:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description George Karabin 2003-07-27 06:44:36 UTC
While trying to debug Bug #58201 a little bit, I'm coming to this question:

Should /etc/rc.d/init.d/kudzu really run with the '-t 30' argument when rhgb is
part of the boot process? If I understand this proprerly, rhgb (appears to)
prevent a user from providing any feedback during boot.

Wouldn't the '-q' argument be more appropriate than the timeout, so that kudzu
can run and do something useful? I don't see anything in hwconf.c to make it
clear why kudzu wouldn't always timeout in this case.

Am I missing something here? I feel like I must, because if I were right, I
would expect a timeout to occur every time kudzu runs during the initscripts,
and then I'd expect to see a record of it via the "initlog" function call from
/etc/rc.d/init.d/kudzu, which I'm not. Still, better to ask than not, since
sometimes rhgb seems to sit a while without updating its progress bar. Things
were pretty snappy on my last reboot though - I wonder if this has something to
do with the push I gave kudzu when looking at Bug #58021?

Comment 1 George Karabin 2003-07-27 06:45:59 UTC
Oops - I meant Bug #58021...


Comment 2 Bill Nottingham 2003-07-28 01:14:49 UTC
Actually, the plan is to have GUI windows from kudzu pop up.

Comment 3 George Karabin 2003-07-28 06:54:35 UTC
Ah, cool. Is anything in CVS? I took a look at the pserver access on rhl and
didn't see anything obvious, at least not on the head branch.


Comment 4 Bill Nottingham 2003-07-28 16:08:16 UTC
Nope, no code in CVS yet.

Comment 5 Bill Nottingham 2003-08-04 18:52:38 UTC
*** Bug 101602 has been marked as a duplicate of this bug. ***

Comment 6 Jonathan Blandford 2003-10-08 17:31:23 UTC
It's there now.  I'm not really happy w/ the kudzu screen, but it'll do until we
rework kudzu.


Note You need to log in before you can comment on or make changes to this bug.