Bug 1009278 - UnicodeDecodeError: 'ascii' codec can't decode byte 0xe6 in position 0: ordinal not in range(128)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe6 in position 0: ordin...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
abrt_hash:be40e219b18f7b7f07aa71032b6...
: CommonBugs
: 1009380 1013222 1016723 (view as bug list)
Depends On:
Blocks: F20BetaBlocker
  Show dependency treegraph
 
Reported: 2013-09-18 02:23 EDT by Akira TAGOH
Modified: 2013-10-08 11:31 EDT (History)
31 users (show)

See Also:
Fixed In Version: anaconda-20.19-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 03:49:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (202.37 KB, text/plain)
2013-09-18 02:23 EDT, Akira TAGOH
no flags Details
File: anaconda.log (4.12 KB, text/plain)
2013-09-18 02:23 EDT, Akira TAGOH
no flags Details
File: environ (441 bytes, text/plain)
2013-09-18 02:23 EDT, Akira TAGOH
no flags Details
File: lsblk_output (2.23 KB, text/plain)
2013-09-18 02:23 EDT, Akira TAGOH
no flags Details
File: nmcli_dev_list (4.17 KB, text/plain)
2013-09-18 02:23 EDT, Akira TAGOH
no flags Details
File: os_info (291 bytes, text/plain)
2013-09-18 02:23 EDT, Akira TAGOH
no flags Details
File: program.log (39.78 KB, text/plain)
2013-09-18 02:23 EDT, Akira TAGOH
no flags Details
File: storage.log (140.90 KB, text/plain)
2013-09-18 02:23 EDT, Akira TAGOH
no flags Details
File: ifcfg.log (486 bytes, text/plain)
2013-09-18 02:23 EDT, Akira TAGOH
no flags Details

  None (edit)
Description Akira TAGOH 2013-09-18 02:23:20 EDT
Description of problem:
This problem happened during installing from Live f20 alpha RC3.

Version-Release number of selected component:
anaconda-20.17-1.fc20.x86_64

The following was filed automatically by anaconda:
anaconda 20.17-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/keyboard.py", line 553, in get_layout_variant_description
    Xkb_(layout_info.desc))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/keyboard.py", line 301, in status
    return self._xkl_wrapper.get_layout_variant_description(self._store[0][0])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 259, in _updateCompleteness
    spoke.selector.set_property("status", spoke.status)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 213, in _createBox
    self._updateCompleteness(spoke)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 368, in refresh
    self._createBox()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 727, in _on_continue_clicked
    nextAction.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 68, in _on_continue_clicked
    cb()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 314, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 72, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe6 in position 0: ordinal not in range(128)

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-20-Al rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
product:        Fedora
release:        Fedora release 20 (Heisenbug)
type:           anaconda
version:        20
Comment 1 Akira TAGOH 2013-09-18 02:23:26 EDT
Created attachment 799104 [details]
File: anaconda-tb
Comment 2 Akira TAGOH 2013-09-18 02:23:30 EDT
Created attachment 799105 [details]
File: anaconda.log
Comment 3 Akira TAGOH 2013-09-18 02:23:33 EDT
Created attachment 799106 [details]
File: environ
Comment 4 Akira TAGOH 2013-09-18 02:23:38 EDT
Created attachment 799107 [details]
File: lsblk_output
Comment 5 Akira TAGOH 2013-09-18 02:23:41 EDT
Created attachment 799108 [details]
File: nmcli_dev_list
Comment 6 Akira TAGOH 2013-09-18 02:23:45 EDT
Created attachment 799109 [details]
File: os_info
Comment 7 Akira TAGOH 2013-09-18 02:23:50 EDT
Created attachment 799110 [details]
File: program.log
Comment 8 Akira TAGOH 2013-09-18 02:23:54 EDT
Created attachment 799111 [details]
File: storage.log
Comment 9 Akira TAGOH 2013-09-18 02:23:58 EDT
Created attachment 799112 [details]
File: ifcfg.log
Comment 10 David Shea 2013-09-18 09:38:04 EDT
*** Bug 1009380 has been marked as a duplicate of this bug. ***
Comment 11 Kamil Páral 2013-09-19 05:44:23 EDT
This error popped up when I wanted to add a new keyboard layout. I used "plus" button in the keymap spoke.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-20-Al rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.18-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 20: ordinal not in range(128)
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 12 Kamil Páral 2013-09-19 05:46:34 EDT
Proposing for Alpha blocker. Trivial to reproduce: Run Live installer, go to Keyboard spoke and click on + button.
Comment 13 Tim Flink 2013-09-19 05:59:55 EDT
I booted the F20 RC4 live desktop image (x64) in a VM and attempted to add a keyboard in the installer

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-20-Al rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.18-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 20: ordinal not in range(128)
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 14 Tim Flink 2013-09-19 06:02:26 EDT
However, I do not see the same crash when attempting to reproduce with the RC4 x64 DVD iso in the same VM
Comment 15 Adam Williamson 2013-09-19 06:34:07 EDT
is this a change from previous RCs, or we just never noticed it?
Comment 16 Tim Flink 2013-09-19 06:59:23 EDT
I can add a keyboard in the RC1 and RC2 desktop live so it appears to be a regression between RC2 and RC3 since that's what the original report was against.
Comment 17 Jaroslav Reznik 2013-09-19 07:55:42 EDT
Available (and already reviewed) patch fixes this issue, simple one-liner.
Comment 18 Mike Ruckman 2013-09-19 14:08:51 EDT
Discussed this in the F20 Alpha Go/No-Go meeting [1]. While nasty, this only affects live images and there are acceptable workarounds (update anaconda before install, use DVD/netinstall). Therefore, it was decided that this isn't serious enough to block release of F20 alpha and is rejected as a release blocking bug.

[1] http://meetbot.fedoraproject.org/fedora-meeting-2/2013-09-19/
Comment 19 Kamil Páral 2013-09-20 03:36:15 EDT
Re-proposing for Beta.
Comment 20 Mikhail 2013-09-24 13:10:30 EDT
Try to config layout during anaconda install process

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-20-Al rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.18-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 20: ordinal not in range(128)
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 21 Mikhail 2013-09-24 13:12:46 EDT
Occurs when I try configure keyboard layout during anaconda install process

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-20-Al rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.18-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 20: ordinal not in range(128)
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 22 Artur Szymczak 2013-09-25 06:03:23 EDT
I started installer (mate-spin). Selected proper timezone (Poland/Warsaw), then I pressed keyboard to add (+), and it happends.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-MATE-Compiz-x86_64-2 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.18-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 20: ordinal not in range(128)
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 23 thekdp 2013-09-25 10:41:23 EDT
I try to select my keyboard setting during install.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-20-Al rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.18-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 20: ordinal not in range(128)
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 24 Mike Ruckman 2013-09-25 13:09:05 EDT
Discussed in 2013-09-25 Blocker Review Meeting [1]. Acknowledged as an AcceptedBlocker - Violates the following F20 alpha criterion for liveinstalls with a non-default keyboard: "When using the dedicated installer images, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces." [2]

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-25/
[2] https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Installation_interfaces
Comment 25 Aleksandra Bookwar 2013-09-26 03:50:23 EDT
1. Start "Install to Hard Drive" from LiveCD
2. Choose English as an installation language
3. Go to Keyboard Layout options and hit "+"

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-20-Al rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.18-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 20: ordinal not in range(128)
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 26 Kamil Páral 2013-09-26 03:59:31 EDT
I selected Czech language and confirmed my fate.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-i686-20-Alph rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.i686
package:        anaconda-20.18-1.fc20.i686
packaging.log:  
product:        Fedora
reason:         UnicodeDecodeError: 'ascii' codec can't decode byte 0xc4 in position 0: ordinal not in range(128)
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 27 Wellington Poi 2013-09-27 13:43:13 EDT
Configuring keyboard for a instalation of Fedora 20 Alpha.
When adding a keyboard layout, anaconda freezes.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-20-Al rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.18-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 20: ordinal not in range(128)
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 28 Nix\ 2013-09-28 22:33:20 EDT
1.- Start Live CD of Fedora 20 Alpha4 KDE
2.- Click on installer
3.- Select Spanish as language, refine in Spanish from Argentina
4.- Click on "Continuar" (continue)
5.- Crash

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-KDE-i686-20-Alpha-4 rootfstype=auto ro rd.live.image rd.luks=0 rd.md=0 rd.dm=0 BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.i686
package:        anaconda-20.18-1.fc20.i686
packaging.log:  
product:        Fedora
reason:         UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 4: ordinal not in range(128)
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 29 Nix\ 2013-09-28 22:50:07 EDT
David Shea 2013-09-19 09:32:51 EDT
Status: POST → MODIFIED
Fixed In Version: anaconda-20.19-1
===================================

According with the David Shea comment, was fixed in 20.19.

Updating the LiveCD in Live mode, to anaconda 20.21-1.fc20 i can confirm that was fixed, using anaconda 20.21 at least.
Comment 30 David Shea 2013-09-30 09:32:59 EDT
*** Bug 1013222 has been marked as a duplicate of this bug. ***
Comment 31 Matías Kreder 2013-10-03 17:18:55 EDT
1. Get Fedora 20 Alpha CD
2. Choose English as primary lang
3. Try to change the keyboard layout

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-20-Al rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.18-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 20: ordinal not in range(128)
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 32 Wellington Poi 2013-10-03 17:44:33 EDT
Using a liveCD and updating anaconda before start the install process solved the problem here, too.

Using now anaconda-20.21-1.fc20.x86_64
Comment 33 wwp 2013-10-04 04:06:41 EDT
from within vmware workstation 8, installing fedora 20 alpha x86 from live CD, got an unknown program error while attempting to add a keyboard layout more.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-i686-20-Alph rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
event_log:      2013-10-04-05:44:27> ('report_uReport' completed successfully)
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.i686
package:        anaconda-20.18-1.fc20.i686
packaging.log:  
product:        Fedora
reason:         UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 20: ordinal not in range(128)
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 34 klaus 2013-10-07 09:22:48 EDT
tried to install fedora mate compiz version 20 alpha. At the point where I wanted to remove the English keyboard layout to make space for the german layout, the installer produced an error message and wanted to shutdown the program.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-MATE-Compiz-x86_64-2 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.18-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 20: ordinal not in range(128)
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 35 Wellington Poi 2013-10-07 09:46:48 EDT
Try to update anaconda before start the installation process. The package anaconda-20.21-1.fc20 should work like a charm.
Comment 36 Adam Williamson 2013-10-07 12:31:05 EDT
This ought to be fixed in Beta TC1: can anyone confirm? if so, we can move this bug along and close it out soon. thanks!
Comment 37 klaus 2013-10-07 13:46:47 EDT
Well, nice to hear from you all, but 

I try to install from Fedora-Live-MATE-Compiz-x86_64-20-Alpha-4.iso dvd
So how can i update anaconda on an iso before installation? I mean, the iso
is not accessible for an update, maybe i missed out on some basics there?
(Apart from missing the experience - sorry)
Comment 38 Adam Williamson 2013-10-07 15:17:36 EDT
klaus: are you *sure*? All other testing seemed to indicate this only affected live images. You can update anaconda on a live image just by running 'yum update anaconda' before starting the installer (or possibly 'yum --enablerepo=updates-testing update anaconda'; and sometimes you might need to update python-blivet too). On a DVD, you can't, though you can use an updates image.

Still, as mentioned above, this ought to be fixed in Beta TC1, so if this really is affecting you with the DVD, you could just try that.
Comment 39 Kamil Páral 2013-10-08 03:49:38 EDT
I've verified that this is fixed with F20 Beta TC1 (anaconda 20.21).
Comment 40 David Shea 2013-10-08 11:31:07 EDT
*** Bug 1016723 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.