Bug 1016152 - tigervnc module 1.3.0-7.fc19 doesn't load: undefined symbol key_is_down
tigervnc module 1.3.0-7.fc19 doesn't load: undefined symbol key_is_down
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
: 1014956 1017277 1024807 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 11:35 EDT by Henrique Martins
Modified: 2013-11-17 21:57 EST (History)
11 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.14.4-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-15 15:29:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henrique Martins 2013-10-07 11:35:18 EDT
Description of problem:
This seems to be a recurrent problem with every other tigervnc build:-)  Tigervnc module doesn't load with an undefined symbol key_is_down.

Version-Release number of selected component (if applicable):
tigervnc-1.3.0-7.fc19

How reproducible:
Every time

Steps to Reproduce:
1. configure vnc module
2. restart X or reboot

Actual results:
tigervnc-module doesn't load.  Error message in X.org.0.log is:
 Failed to load /usr/lib64/xorg/modules/extensions/libvnc.so: /usr/lib64/xorg/modules/extensions/libvnc.so: undefined symbol: key_is_down

Expected results:
working vnc module

Additional info:
Also, it seems that some scriplet on the install likes to move my 10-libvnc.conf to 10-libvnc.conf.rpmsave and disable the loading of the module.  I can file that in another bug report or maybe it could be looked at while fixing this one.
Comment 1 Tim Waugh 2013-10-07 12:25:25 EDT
*** Bug 1014956 has been marked as a duplicate of this bug. ***
Comment 2 Tim Waugh 2013-10-09 08:37:05 EDT
The fix for this issue caused another issue that also affected the Xvnc server.
Comment 3 Tim Waugh 2013-10-09 08:42:48 EDT
Reported upstream.
Comment 4 Tim Waugh 2013-10-09 12:46:13 EDT
*** Bug 1017277 has been marked as a duplicate of this bug. ***
Comment 5 Tim Waugh 2013-10-10 07:35:32 EDT
Changing component. Upstream opinion is that this symbol ought to be exported.
http://sourceforge.net/mailarchive/message.php?msg_id=31504295
Comment 6 Bjoern Rasmussen 2013-10-15 13:44:56 EDT
(In reply to Tim Waugh from comment #5)
> Changing component. Upstream opinion is that this symbol ought to be
> exported.
> http://sourceforge.net/mailarchive/message.php?msg_id=31504295

Hi, any chance that xorg will export the symbol?
Comment 7 john.haxby@oracle.com 2013-10-25 04:59:05 EDT
I don't suppose for a minute that I'm the only person that discovered this on the one day that they urgently needed it!
Comment 8 Eli Wapniarski 2013-10-25 08:10:56 EDT
You can get the previous version from koji at

http://koji.fedoraproject.org/koji/packageinfo?packageID=7868

Hey... we all discovered this on the day that you urgently needed it. lol
Comment 9 Tim Waugh 2013-10-30 12:06:42 EDT
*** Bug 1024807 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2013-11-13 02:45:25 EST
xorg-x11-server-1.14.4-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.14.4-3.fc19
Comment 11 Harald Reindl 2013-11-13 06:51:49 EST
confirmed - xvnc on display 0 works again
thank you!

Nov 13 12:49:53 Updated: xorg-x11-server-common-1.14.4-3.fc19.x86_64
Nov 13 12:49:53 Updated: xorg-x11-server-Xorg-1.14.4-3.fc19.x86_64
Comment 12 Fedora Update System 2013-11-13 17:01:02 EST
xorg-x11-server-1.14.4-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.14.4-3.fc20
Comment 13 Fedora Update System 2013-11-13 22:35:44 EST
Package xorg-x11-server-1.14.4-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-server-1.14.4-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21285/xorg-x11-server-1.14.4-3.fc19
then log in and leave karma (feedback).
Comment 14 Henrique Martins 2013-11-14 00:32:42 EST
Already left karma on fedoraproject (different logon there).
Thanks for the fix.
Comment 15 Fedora Update System 2013-11-15 15:29:19 EST
xorg-x11-server-1.14.4-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-11-17 21:57:03 EST
xorg-x11-server-1.14.4-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.