Bug 101813 - prelink 0.3.0-1 gives assertion failure
Summary: prelink 0.3.0-1 gives assertion failure
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: prelink   
(Show other bugs)
Version: beta1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-08-07 09:37 UTC by Michael Young
Modified: 2007-04-18 16:56 UTC (History)
1 user (show)

Fixed In Version: 0.3.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-11 12:52:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File prelink fails on. (16.93 KB, application/octet-stream)
2003-08-07 15:00 UTC, Michael Young
no flags Details

Description Michael Young 2003-08-07 09:37:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
I am testing prelink-0.3.0-1 (starting with a prelink -ua ; prelink -a to start
from a clean situation). However now when I run prelink -qa I get some probably
unimportant errors, then an assertion failure. See below for the errors. I can
attempt simple debugging if required.

prelink: /usr/lib/mozilla-1.4/mozilla-bin: Could not parse
`/usr/lib/mozilla-1.4/mozilla-bin: error while loading shared libraries:
libmozjs.so: cannot open shared object file: No such file or directory'
prelink: /usr/lib/mozilla-1.4/regchrome: Could not parse
`/usr/lib/mozilla-1.4/regchrome: error while loading shared libraries:
libxpcom.so: cannot open shared object file: No such file or directory'
prelink: /usr/lib/openoffice/program/pkgchk.bin: Could not parse
`/usr/lib/openoffice/program/pkgchk.bin: error while loading shared libraries:
libsal.so.3: cannot open shared object file: No such file or directory'
prelink: exec.c:890: prelink_exec: Assertion `dso->shdr[new_dynbss + 1].sh_type
!= 8 || data->d_buf == ((void *)0)' failed.
Aborted

Comment 1 Jakub Jelinek 2003-08-07 14:38:49 UTC
Can you please add -vvv to the prelink options and retry?
If the assertion failure happens again, I'm interested in what program
or library was it currently prelinking (and a copy of that binary resp. library
as attachement).

Comment 2 Michael Young 2003-08-07 15:00:19 UTC
Created attachment 93484 [details]
File prelink fails on.

The problem is in linking /usr/sbin/cpqarrayd which I have confirmed by running
									       

prelink -vvvq /usr/sbin/cpqarrayd
I am attaching this file.

Comment 3 Jakub Jelinek 2003-08-07 15:57:40 UTC
Can you please pack all the libraries it uses as well?
tar cjhf /tmp/libs.tar.bz2 `ldd /usr/sbin/cpqarrayd  | awk ' { print $3 } '`
should do the job.
I have hard time reproducing it so far.

Comment 4 Jakub Jelinek 2003-08-08 08:24:23 UTC
Please try ftp://people.redhat.com/jakub/prelink/0.3.0-2/

Comment 5 Michael Young 2003-08-08 09:43:54 UTC
0.3.0-2 no longer gives the assertion failure. rpm -vVa reports 3 "prelinked
file was modified" errors, but I have a previous open bug (bug 89953) about this
problem with an earlier prelink which I will update accordingly.


Note You need to log in before you can comment on or make changes to this bug.