Bug 1020580 - Cannot set account to have no password during install
Cannot set account to have no password during install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
: Reopened
: 1023029 1023683 1027362 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 22:50 EDT by Robert Hancock
Modified: 2013-11-23 23:00 EST (History)
11 users (show)

See Also:
Fixed In Version: pykickstart-1.99.46-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-23 23:00:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Hancock 2013-10-17 22:50:53 EDT
Description of problem:
When setting up a user account during install from live image, Anaconda refuses to allow you to unselect "Require a password for this account" and complains that the passwords do not match.

Version-Release number of selected component (if applicable):
anaconda-20.25-1.fc20.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Start install from live image
2. Create user account when option is available
3. Unselect "Require a password to use this account" and hit Done

Actual results:
Error "The passwords do not match". No password was entered.

Expected results:
Account creation works. Or a proper error message if this isn't actually supported.

Additional info:
Comment 1 Fedora Update System 2013-10-21 20:32:03 EDT
anaconda-20.25.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.25.2-1.fc20
Comment 2 Fedora Update System 2013-10-22 14:52:34 EDT
Package anaconda-20.25.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.25.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19692/anaconda-20.25.2-1.fc20
then log in and leave karma (feedback).
Comment 3 David Shea 2013-10-24 10:09:53 EDT
*** Bug 1023029 has been marked as a duplicate of this bug. ***
Comment 4 David Shea 2013-10-28 09:43:59 EDT
*** Bug 1023683 has been marked as a duplicate of this bug. ***
Comment 5 David Shea 2013-11-06 11:22:49 EST
*** Bug 1027362 has been marked as a duplicate of this bug. ***
Comment 6 Robert Hancock 2013-11-13 22:43:21 EST
Appears to be fixed with current nightly image.
Comment 7 Fedora Update System 2013-11-15 21:13:08 EST
anaconda-20.25.8-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.25.8-1.fc20
Comment 8 Fedora Update System 2013-11-17 02:04:27 EST
Package anaconda-20.25.8-1.fc20, pykickstart-1.99.46-1.fc20, python-blivet-0.23.5-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.25.8-1.fc20 pykickstart-1.99.46-1.fc20 python-blivet-0.23.5-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21553/pykickstart-1.99.46-1.fc20,python-blivet-0.23.5-1.fc20,anaconda-20.25.8-1.fc20
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-11-23 23:00:39 EST
pykickstart-1.99.46-1.fc20, python-blivet-0.23.5-1.fc20, anaconda-20.25.9-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.