This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1031296 - [abrt] WARNING: CPU: 1 PID: 0 at kernel/time/tick-broadcast.c:667 tick_broadcast_oneshot_control+0x181/0x190()
[abrt] WARNING: CPU: 1 PID: 0 at kernel/time/tick-broadcast.c:667 tick_broadc...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:22e3300c3a733c3e4c5cfab38e2...
:
: 1025045 1063108 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-16 10:11 EST by Kai Arne
Modified: 2014-11-12 09:19 EST (History)
13 users (show)

See Also:
Fixed In Version: kernel-3.13.3-201.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-17 16:04:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (88.71 KB, text/plain)
2013-11-16 10:11 EST, Kai Arne
no flags Details
amd_e400_c1e_clockevents.patch (560 bytes, text/plain)
2014-01-29 11:49 EST, Stanislaw Gruszka
no flags Details
tick_broadcast_v2.patch (433 bytes, text/plain)
2014-02-10 02:35 EST, Stanislaw Gruszka
no flags Details
dmesg 3.12.10-300.bz1031296_v2.fc20.x86_64+debug - devices pm_test - S3 (14.99 KB, text/plain)
2014-02-10 20:05 EST, poma
no flags Details

  None (edit)
Description Kai Arne 2013-11-16 10:11:34 EST
Additional info:
reporter:       libreport-2.1.9
WARNING: CPU: 1 PID: 0 at kernel/time/tick-broadcast.c:667 tick_broadcast_oneshot_control+0x181/0x190()
Modules linked in: ppp_deflate zlib_deflate bsd_comp ppp_async crc_ccitt ppp_generic slhc vfat fat option usb_wwan usb_storage fuse fcoe libfcoe libfc scsi_transport_fc 8021q garp mrp scsi_tgt nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6t_REJECT xt_conntrack ebtable_nat ebtable_broute bridge stp llc ebtable_filter ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_security ip6table_raw ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_security iptable_raw snd_hda_codec_hdmi powernow_k8 kvm_amd kvm serio_raw k8temp sp5100_tco snd_hda_codec_via i2c_piix4 snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_page_alloc atl1e snd_timer snd soundcore asus_atk0110 mperf uinput ata_generic pata_acpi hid_logitech_dj nouveau pata_atiixp video firewire_ohci mxm_wmi i2c_algo_bit firewire_core drm_kms_helper crc_itu_t ttm drm i2c_core wmi
CPU: 1 PID: 0 Comm: swapper/1 Not tainted 3.11.7-200.fc19.i686 #1
Hardware name: System manufacturer System Product Name/M4A78-E, BIOS 2603    04/13/2011
 00000000 00000000 f40d7ecc c0978ffe 00000000 f40d7efc c0447ace c0b0b938
 00000001 00000000 c0b18441 0000029b c049a101 c049a101 00000001 00000004
 f73a8780 f40d7f0c c0447b92 00000009 00000000 f40d7f34 c049a101 00000000
Call Trace:
 [<c0978ffe>] dump_stack+0x41/0x52
 [<c0447ace>] warn_slowpath_common+0x7e/0xa0
 [<c049a101>] ? tick_broadcast_oneshot_control+0x181/0x190
 [<c049a101>] ? tick_broadcast_oneshot_control+0x181/0x190
 [<c0447b92>] warn_slowpath_null+0x22/0x30
 [<c049a101>] tick_broadcast_oneshot_control+0x181/0x190
 [<c0498e8f>] clockevents_notify+0x11f/0x150
 [<c0409f32>] amd_e400_idle+0x62/0xe0
 [<c040a596>] arch_cpu_idle+0x26/0x30
 [<c049081b>] cpu_startup_entry+0x9b/0x200
 [<c042d38b>] ? setup_APIC_timer+0xab/0x130
 [<c042bbf8>] start_secondary+0x208/0x2d0

Potential duplicate: bug 1025045
Comment 1 Kai Arne 2013-11-16 10:11:48 EST
Created attachment 824906 [details]
File: dmesg
Comment 2 Josh Boyer 2013-11-18 10:02:22 EST
Was this after a resume from suspend/hibernate or did it happen randomly?
Comment 3 Michele Baldessari 2013-11-24 06:47:32 EST
*** Bug 1025045 has been marked as a duplicate of this bug. ***
Comment 4 Michael Convey 2013-12-01 13:06:10 EST
Just got this crash again this morning during an Apper update.
Comment 5 igor.redhat@gmail.com 2013-12-04 14:23:17 EST
Description of problem:
This showed up upon resume from suspend.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.9
cmdline:        BOOT_IMAGE=/vmlinuz-3.11.10-300.fc20.x86_64 root=UUID=c07db0f8-16c8-4d06-9f59-5a04a34fb2b1 ro rd.md=0 rd.lvm=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8
kernel:         3.11.10-300.fc20.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 1 PID: 0 at kernel/time/tick-broadcast.c:667 tick_broadcast_oneshot_control+0x170/0x180()
Modules linked in: ipt_MASQUERADE iptable_nat nf_nat_ipv4 nf_nat xt_CHECKSUM iptable_mangle tun bridge stp llc ebtable_nat ebtables fuse arc4 ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack lm90 nf_conntrack ip6_tables snd_hda_codec_analog b43 bcma snd_hda_intel mac80211 snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm cfg80211 powernow_k8 kvm_amd snd_page_alloc kvm snd_timer snd tg3 ssb hp_wmi ptp pps_core sparse_keymap rfkill soundcore edac_core ppdev k8temp edac_mce_amd mmc_core serio_raw sp5100_tco hp_accel i2c_piix4 shpchp wmi parport_pc video lis3lv02d input_polldev parport mperf binfmt_misc radeon firewire_ohci i2c_algo_bit ata_generic pata_acpi firewire_core drm_kms_helper crc_itu_t yenta_socket ttm pata_atiixp drm i2c_core
CPU: 1 PID: 0 Comm: swapper/1 Not tainted 3.11.10-300.fc20.x86_64 #1
Hardware name: Hewlett-Packard HP Compaq 6715b (RK156AV)/30C2, BIOS 68YTT Ver. F.07 07/16/2007
 0000000000000009 ffff880139ea7de8 ffffffff816441bb 0000000000000000
 ffff880139ea7e20 ffffffff8106715d 0000000000000001 0000000000000004
 ffff88013fd0dc80 0000000000000002 ffffffff81cb7400 ffff880139ea7e30
Call Trace:
 [<ffffffff816441bb>] dump_stack+0x45/0x56
 [<ffffffff8106715d>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff8106723a>] warn_slowpath_null+0x1a/0x20
 [<ffffffff810c02d0>] tick_broadcast_oneshot_control+0x170/0x180
 [<ffffffff810beb38>] clockevents_notify+0x178/0x1a0
 [<ffffffff8101ae95>] amd_e400_idle+0x75/0x100
 [<ffffffff8101b646>] arch_cpu_idle+0x26/0x30
 [<ffffffff810b6695>] cpu_startup_entry+0xe5/0x280
 [<ffffffff8103ed47>] start_secondary+0x217/0x2c0
Comment 6 Fred Erickson 2013-12-05 02:19:40 EST
Description of problem:
Turned laptop on - from 'Power Off' state. Logged in to Mate, when desktop loaded, bugzilla reported error.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.9
cmdline:        BOOT_IMAGE=/vmlinuz-3.11.9-200.fc19.x86_64 root=/dev/mapper/fedora_satellite-root ro rd.md=0 rd.lvm.lv=fedora_satellite/swap rd.dm=0 rd.lvm.lv=fedora_satellite/root vconsole.keymap=us rd.luks=0 vconsole.font=latarcyrheb-sun16 rhgb quiet LANG=en_US.UTF-8
kernel:         3.11.9-200.fc19.x86_64
runlevel:       unknown
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 0 PID: 0 at kernel/time/tick-broadcast.c:667 tick_broadcast_oneshot_control+0x170/0x180()
Modules linked in:
CPU: 0 PID: 0 Comm: swapper/0 Not tainted 3.11.9-200.fc19.x86_64 #1
Hardware name: TOSHIBA Satellite A215/IALAA, BIOS V2.00 06/10/2008
 0000000000000009 ffffffff81c01e00 ffffffff8164764b 0000000000000000
 ffffffff81c01e38 ffffffff8106715d 0000000000000000 0000000000000004
 ffff8800b7a0dc80 0000000000000002 ffffffff81c238c0 ffffffff81c01e48
Call Trace:
 [<ffffffff8164764b>] dump_stack+0x45/0x56
 [<ffffffff8106715d>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff8106723a>] warn_slowpath_null+0x1a/0x20
 [<ffffffff810c02f0>] tick_broadcast_oneshot_control+0x170/0x180
 [<ffffffff810beb58>] clockevents_notify+0x178/0x1a0
 [<ffffffff8101ae65>] amd_e400_idle+0x75/0x100
 [<ffffffff8101b616>] arch_cpu_idle+0x26/0x30
 [<ffffffff810b669e>] cpu_startup_entry+0xce/0x280
 [<ffffffff8163d937>] rest_init+0x77/0x80
 [<ffffffff81d0eef5>] start_kernel+0x40a/0x416
 [<ffffffff81d0e8f4>] ? repair_env_string+0x5c/0x5c
 [<ffffffff81d0e120>] ? early_idt_handlers+0x120/0x120
 [<ffffffff81d0e5dc>] x86_64_start_reservations+0x2a/0x2c
 [<ffffffff81d0e6e6>] x86_64_start_kernel+0x108/0x117
Comment 7 Michael 2013-12-10 11:46:24 EST
Description of problem:
Happened immediately after startup.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.9
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.11.9-200.fc19.x86_64 root=UUID=219f2749-f79a-4770-9aa3-7d70e25ae21a ro rd.md=0 rd.lvm=0 rd.dm=0 vconsole.keymap=us rd.luks=0 vconsole.font=latarcyrheb-sun16 LANG=en_US.UTF-8 rhgb quiet
kernel:         3.11.9-200.fc19.x86_64
runlevel:       unknown
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 0 PID: 0 at kernel/time/tick-broadcast.c:667 tick_broadcast_oneshot_control+0x170/0x180()
Modules linked in:
CPU: 0 PID: 0 Comm: swapper/0 Not tainted 3.11.9-200.fc19.x86_64 #1
Hardware name: Micro-Star International MS-1244/MS-1244, BIOS A1244AMS Ver1.0B 09/30/2010
 0000000000000009 ffffffff81c01e00 ffffffff8164764b 0000000000000000
 ffffffff81c01e38 ffffffff8106715d 0000000000000000 0000000000000004
 ffff88022fc0dc80 0000000000000002 ffffffff81c238c0 ffffffff81c01e48
Call Trace:
 [<ffffffff8164764b>] dump_stack+0x45/0x56
 [<ffffffff8106715d>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff8106723a>] warn_slowpath_null+0x1a/0x20
 [<ffffffff810c02f0>] tick_broadcast_oneshot_control+0x170/0x180
 [<ffffffff810beb58>] clockevents_notify+0x178/0x1a0
 [<ffffffff8101ae65>] amd_e400_idle+0x75/0x100
 [<ffffffff8101b616>] arch_cpu_idle+0x26/0x30
 [<ffffffff810b669e>] cpu_startup_entry+0xce/0x280
 [<ffffffff8163d937>] rest_init+0x77/0x80
 [<ffffffff81d0eef5>] start_kernel+0x40a/0x416
 [<ffffffff81d0e8f4>] ? repair_env_string+0x5c/0x5c
 [<ffffffff81d0e120>] ? early_idt_handlers+0x120/0x120
 [<ffffffff81d0e5dc>] x86_64_start_reservations+0x2a/0x2c
 [<ffffffff81d0e6e6>] x86_64_start_kernel+0x108/0x117
Comment 8 Michael 2013-12-14 17:53:52 EST
Description of problem:
Happened immediately after startup.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.9
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.11.10-200.fc19.x86_64 root=UUID=219f2749-f79a-4770-9aa3-7d70e25ae21a ro rd.md=0 rd.lvm=0 rd.dm=0 vconsole.keymap=us rd.luks=0 vconsole.font=latarcyrheb-sun16 LANG=en_US.UTF-8 rhgb quiet
kernel:         3.11.10-200.fc19.x86_64
runlevel:       unknown
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 0 PID: 0 at kernel/time/tick-broadcast.c:667 tick_broadcast_oneshot_control+0x170/0x180()
Modules linked in:
CPU: 0 PID: 0 Comm: swapper/0 Not tainted 3.11.10-200.fc19.x86_64 #1
Hardware name: Micro-Star International MS-1244/MS-1244, BIOS A1244AMS Ver1.0B 09/30/2010
 0000000000000009 ffffffff81c01df8 ffffffff8164768b 0000000000000000
 ffffffff81c01e30 ffffffff8106715d 0000000000000000 0000000000000004
 ffff88022fc0dc80 0000000000000002 ffffffff81c238c0 ffffffff81c01e40
Call Trace:
 [<ffffffff8164768b>] dump_stack+0x45/0x56
 [<ffffffff8106715d>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff8106723a>] warn_slowpath_null+0x1a/0x20
 [<ffffffff810c02f0>] tick_broadcast_oneshot_control+0x170/0x180
 [<ffffffff810beb58>] clockevents_notify+0x178/0x1a0
 [<ffffffff8101ae65>] amd_e400_idle+0x75/0x100
 [<ffffffff8101b616>] arch_cpu_idle+0x26/0x30
 [<ffffffff810b66b5>] cpu_startup_entry+0xe5/0x280
 [<ffffffff8163d977>] rest_init+0x77/0x80
 [<ffffffff81d0eef5>] start_kernel+0x40a/0x416
 [<ffffffff81d0e8f4>] ? repair_env_string+0x5c/0x5c
 [<ffffffff81d0e120>] ? early_idt_handlers+0x120/0x120
 [<ffffffff81d0e5dc>] x86_64_start_reservations+0x2a/0x2c
 [<ffffffff81d0e6e6>] x86_64_start_kernel+0x108/0x117
Comment 9 Michele Baldessari 2013-12-25 18:02:46 EST
In both:
https://bugzilla.redhat.com/show_bug.cgi?id=989718
https://bugzilla.redhat.com/show_bug.cgi?id=996973

reporters mentioned that sometime in 3.11.X the issue had gone.
So this one is just not fixed yet.

Issue goes back in similar forms to 3.1.X:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=656196
Comment 10 Michael Convey 2014-01-12 16:31:05 EST
This issue still occurs regularly on my machine.
Comment 11 Fred Erickson 2014-01-12 17:03:30 EST
(In reply to Fred Erickson from comment #6)
> Description of problem:
> Turned laptop on - from 'Power Off' state. Logged in to Mate, when desktop
> loaded, bugzilla reported error.
> 
> Version-Release number of selected component:
> kernel
> 
> Additional info:
> reporter:       libreport-2.1.9
> cmdline:        BOOT_IMAGE=/vmlinuz-3.11.9-200.fc19.x86_64
> root=/dev/mapper/fedora_satellite-root ro rd.md=0
> rd.lvm.lv=fedora_satellite/swap rd.dm=0 rd.lvm.lv=fedora_satellite/root
> vconsole.keymap=us rd.luks=0 vconsole.font=latarcyrheb-sun16 rhgb quiet
> LANG=en_US.UTF-8
> kernel:         3.11.9-200.fc19.x86_64
> runlevel:       unknown
> type:           Kerneloops
> 
> Truncated backtrace:
> WARNING: CPU: 0 PID: 0 at kernel/time/tick-broadcast.c:667
> tick_broadcast_oneshot_control+0x170/0x180()
> Modules linked in:
> CPU: 0 PID: 0 Comm: swapper/0 Not tainted 3.11.9-200.fc19.x86_64 #1
> Hardware name: TOSHIBA Satellite A215/IALAA, BIOS V2.00 06/10/2008
>  0000000000000009 ffffffff81c01e00 ffffffff8164764b 0000000000000000
>  ffffffff81c01e38 ffffffff8106715d 0000000000000000 0000000000000004
>  ffff8800b7a0dc80 0000000000000002 ffffffff81c238c0 ffffffff81c01e48
> Call Trace:
>  [<ffffffff8164764b>] dump_stack+0x45/0x56
>  [<ffffffff8106715d>] warn_slowpath_common+0x7d/0xa0
>  [<ffffffff8106723a>] warn_slowpath_null+0x1a/0x20
>  [<ffffffff810c02f0>] tick_broadcast_oneshot_control+0x170/0x180
>  [<ffffffff810beb58>] clockevents_notify+0x178/0x1a0
>  [<ffffffff8101ae65>] amd_e400_idle+0x75/0x100
>  [<ffffffff8101b616>] arch_cpu_idle+0x26/0x30
>  [<ffffffff810b669e>] cpu_startup_entry+0xce/0x280
>  [<ffffffff8163d937>] rest_init+0x77/0x80
>  [<ffffffff81d0eef5>] start_kernel+0x40a/0x416
>  [<ffffffff81d0e8f4>] ? repair_env_string+0x5c/0x5c
>  [<ffffffff81d0e120>] ? early_idt_handlers+0x120/0x120
>  [<ffffffff81d0e5dc>] x86_64_start_reservations+0x2a/0x2c
>  [<ffffffff81d0e6e6>] x86_64_start_kernel+0x108/0x117

Additional comments I probably should have added to original: Since F19 was installed on this laptop, the login screen has not been readable. Looks like the screen has been sliced in to a series of irregular triangles like a puzzle and not assembled correctly. I am the only user, so pressing enter, then typing in my password brings up the desktop. 
If I log out later, the login screen is displayed properly. 
I have used Fedora on this laptop since it was new and 19 is the only version I've used that has behaved this way.
Comment 12 Stanislaw Gruszka 2014-01-24 06:48:45 EST
(In reply to Michael Convey from comment #10)
> This issue still occurs regularly on my machine.

Does it also happen on kernel 3.12 ? I do not see reports with that kernel version, looks like update fix the problem.
Comment 13 Michael Convey 2014-01-25 00:28:53 EST
(In reply to Stanislaw Gruszka from comment #12)
> (In reply to Michael Convey from comment #10)
> > This issue still occurs regularly on my machine.
> 
> Does it also happen on kernel 3.12 ? I do not see reports with that kernel
> version, looks like update fix the problem.

Just happened again:
$ uname -rvs
Linux 3.12.7-200.fc19.x86_64 #1 SMP Fri Jan 10 15:32:06 UTC 2014
Comment 14 Michael Convey 2014-01-26 16:29:51 EST
And again: 
$ uname -rvs
Linux 3.12.8-200.fc19.x86_64 #1 SMP Thu Jan 16 04:18:11 UTC 2014
Comment 15 Stanislaw Gruszka 2014-01-29 11:49:21 EST
Created attachment 857157 [details]
amd_e400_c1e_clockevents.patch

Proposed fix for the bug.

I launched kernel build with it here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=6468631
(bz1058268 number in the name is wrong, but that kernel includes proper patch)

Please test it, it can make problem gone, but either can crash the kernel :-)
Comment 16 Stanislaw Gruszka 2014-02-04 17:15:32 EST
Any test results /re kernel from comment 15 ?
Comment 17 Michael Convey 2014-02-04 17:45:48 EST
(In reply to Stanislaw Gruszka from comment #16)
> Any test results /re kernel from comment 15 ?

Forgive my ignorance, can you provide the steps for me to update my kernel with your build? Then, I will run your kernel for a week or so and see if this bug occurs. Will that suffice?
Comment 18 Michael Convey 2014-02-04 17:46:50 EST
(In reply to Stanislaw Gruszka from comment #16)
> Any test results /re kernel from comment 15 ?

Forgive my ignorance, can you provide the steps for me to update my kernel with your build? Then, I will run your kernel for a week or so and see if this bug occurs. Will that suffice?
Comment 19 Stanislaw Gruszka 2014-02-05 03:46:43 EST
You have to download kernel package from above link for your architecture, i.e. for x86_64 it would be:
> http://kojipkgs.fedoraproject.org//work/tasks/8635/6468635/kernel-3.12.9-301.bz1058268.fc20.x86_64.rpm
Then install it using rpm -ivh kernel-3.12.9-301.bz1058268.fc20.x86_64.rpm command. If there will be dependency or other installation problem, you can use --force and --nodeps rpm options. Then boot into new installed kernel.
Comment 20 Michael Convey 2014-02-09 16:07:06 EST
Sorry for the delay. I just installed your kernel. 
$ uname -rvs
Linux 3.12.9-301.bz1058268.fc20.x86_64 #1 SMP Wed Jan 29 17:26:47 UTC 2014
I'll report back in a week or so (or earlier if this bug shows up).
Comment 21 Michael Convey 2014-02-09 22:15:31 EST
I just got this bug using the following kernel:

$ uname -rvs
Linux 3.12.9-301.bz1058268.fc20.x86_64 #1 SMP Wed Jan 29 17:26:47 UTC 2014
Comment 22 Stanislaw Gruszka 2014-02-10 02:35:39 EST
Created attachment 861273 [details]
tick_broadcast_v2.patch

New patch, hopefully this one would be better.
Kernel build with the launched here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=6511401
Please test it.
Comment 23 Stanislaw Gruszka 2014-02-10 06:00:07 EST
*** Bug 1063108 has been marked as a duplicate of this bug. ***
Comment 24 poma 2014-02-10 13:43:24 EST
I almost forgot how the kernel ring buffer looks without errors ...
All tests[1] have PASSED. :)
Patched & tested with 3.14.0-0.rc1.git5.7.fc21.1.x86_64.

Thanks Stanislaw!

https://lists.fedoraproject.org/pipermail/users/2014-January/446267.html
Comment 25 poma 2014-02-10 20:05:25 EST
Created attachment 861642 [details]
dmesg 3.12.10-300.bz1031296_v2.fc20.x86_64+debug - devices pm_test - S3
Comment 26 poma 2014-02-10 20:08:53 EST
For comparison with a 3.14, this[1] happens exclusively with a 3.12.10-300.bz1031296_v2.fc20.x86_64+debug.
But yeah, "tick_broadcast" is gone. :)

[1] https://bugzilla.redhat.com/attachment.cgi?id=861642
Comment 27 Stanislaw Gruszka 2014-02-11 02:39:13 EST
(In reply to poma from comment #26)
> For comparison with a 3.14, this[1] happens exclusively with a
> 3.12.10-300.bz1031296_v2.fc20.x86_64+debug.

Not sure how those ATA errors are releted with the patch, they do not happen on 3.12 kernel without the patch? BTW, what is +debug ?
Comment 28 poma 2014-02-11 05:05:23 EST
(In reply to Stanislaw Gruszka from comment #27)
> (In reply to poma from comment #26)
> > For comparison with a 3.14, this[1] happens exclusively with a
> > 3.12.10-300.bz1031296_v2.fc20.x86_64+debug.
> 
> Not sure how those ATA errors are releted with the patch, they do not happen
> on 3.12 kernel without the patch? BTW, what is +debug ?

Sorry, It should be stated "FYI" i.e. "FTR".
It's only for comparison(3.14 vs. 3.12) with respect to testing.
Not related to the patch per se.

BTW patched & tested with 3.14.0-0.rc2.git0.10.fc21.x86_64.
"tick_broadcast" is gone.
Everything is OK. ;)

"+debug" supplements kernel's name, 
i.e. /boot/vmlinuz-3.12.10-300.bz1031296_v2.fc20.x86_64+debug
Comment 29 poma 2014-02-11 05:07:03 EST
Comment on attachment 861642 [details]
dmesg 3.12.10-300.bz1031296_v2.fc20.x86_64+debug - devices pm_test - S3

It's only for comparison(3.14 vs. 3.12) with respect to testing.
Not related to the patch per se.
Comment 30 poma 2014-02-11 21:33:45 EST
http://marc.info/?l=linux-pm&m=139212870024923&q=raw
http://marc.info/?l=linux-kernel&m=139212871024925&q=raw

Subject: tick: Clear broadcast pending bit when switching to oneshot
From: Thomas Gleixner <tglx@linutronix.de>
Date: Tue, 11 Feb 2014 14:35:40 +0100

AMD systems which use the C1E workaround in the amd_e400_idle routine
trigger the WARN_ON_ONCE in the broadcast code when onlining a CPU.

The reason is that the idle routine of those AMD systems switches the
cpu into forced broadcast mode early on before the newly brought up
CPU can switch over to high resolution / NOHZ mode. The timer related
CPU1 bringup looks like this:

  clockevent_register_device(local_apic);
  tick_setup(local_apic);
  ...
  idle()
	tick_broadcast_on_off(FORCE);
	tick_broadcast_oneshot_control(ENTER)
	  cpumask_set(cpu, broadcast_oneshot_mask);
	halt();

Now the broadcast interrupt on CPU0 sets CPU1 in the
broadcast_pending_mask and wakes CPU1. So CPU1 continues:

	local_apic_timer_interrupt()
	   tick_handle_periodic();
	   softirq()
	     tick_init_highres();
	       cpumask_clr(cpu, broadcast_oneshot_mask);
	
	tick_broadcast_oneshot_control(ENTER)
	   WARN_ON(cpumask_test(cpu, broadcast_pending_mask);

So while we remove CPU1 from the broadcast_oneshot_mask when we switch
over to highres mode, we do not clear the pending bit, which then
triggers the warning when we go back to idle.

The reason why this is only visible on C1E affected AMD systems is
that the other machines enter the deep sleep states via
acpi_idle/intel_idle and exit the broadcast mode before executing the
remote triggered local_apic_timer_interrupt. So the pending bit is
already cleared when the switch over to highres mode is clearing the
oneshot mask.

The solution is simple: Clear the pending bit together with the mask
bit when we switch over to highres mode.

Reported-by: poma <pomidorabelisima@gmail.com>
Cc: stable@vger.kernel.org # 3.10+
Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
---
 kernel/time/tick-broadcast.c |    1 +
 1 file changed, 1 insertion(+)

Index: linux-2.6/kernel/time/tick-broadcast.c
===================================================================
--- linux-2.6.orig/kernel/time/tick-broadcast.c
+++ linux-2.6/kernel/time/tick-broadcast.c
@@ -756,6 +756,7 @@ out:
 static void tick_broadcast_clear_oneshot(int cpu)
 {
 	cpumask_clear_cpu(cpu, tick_broadcast_oneshot_mask);
+	cpumask_clear_cpu(cpu, tick_broadcast_pending_mask);
 }
 
 static void tick_broadcast_init_next_event(struct cpumask *mask,
Comment 31 Stanislaw Gruszka 2014-02-12 02:55:56 EST
Josh, plese apply above patch as fix for this bug.
Comment 32 Josh Boyer 2014-02-12 10:23:36 EST
Fixed in Fedora git.  Thanks Stanislaw and poma!
Comment 33 Fedora Update System 2014-02-14 10:54:21 EST
kernel-3.13.3-200.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.13.3-200.fc20
Comment 34 Fedora Update System 2014-02-14 10:56:42 EST
kernel-3.12.11-200.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.12.11-200.fc19
Comment 35 Fedora Update System 2014-02-15 01:58:20 EST
Package kernel-3.12.11-200.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.12.11-200.fc19'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-2556/kernel-3.12.11-200.fc19
then log in and leave karma (feedback).
Comment 36 Fedora Update System 2014-02-17 16:04:52 EST
kernel-3.13.3-201.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.