Bug 104015 - [PATCH] redhat-logviewer.desktop does not seem to be automatically updated
[PATCH] redhat-logviewer.desktop does not seem to be automatically updated
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-logviewer (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Tammy Fox
:
: 104004 104005 104006 104007 104008 104009 104010 104011 104012 104013 104014 (view as bug list)
Depends On:
Blocks: 103999
  Show dependency treegraph
 
Reported: 2003-09-08 20:23 EDT by Miloslav Trmac
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-15 14:54:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to use intltool (4.86 KB, patch)
2003-09-10 20:56 EDT, Miloslav Trmac
no flags Details | Diff

  None (edit)
Description Miloslav Trmac 2003-09-08 20:23:18 EDT
Description of problem:
There does not seem to be any mechanism for automatically
adding/updating translations to the .desktop file.

Version-Release number of selected component (if applicable):
redhat-logviewer-0.9.2-2
Comment 1 Miloslav Trmac 2003-09-10 20:56:29 EDT
Created attachment 94402 [details]
Patch to use intltool

Attached patch changes the build process to using intltool for message
extraction (including the .desktop.in file) and automatically building
the .desktop file using translations in the .po files.
The intltool package should be added as a build requirement.
Comment 2 Tammy Fox 2003-09-15 01:43:59 EDT
The translations for the .desktop files do not get updated that often, and I
would rather update them by hand and use gettext.
Comment 3 Miloslav Trmac 2003-09-15 13:58:58 EDT
The main point is that this way adding/changing translations requires
no manual intervention. At the time the patch was created,
Hungarian and Brazilian Portugese translations were missing from the
desktop file and several translations differed from translations
in the PO file.

It seems the desktop file has been last updated on Feb 18. As you point
out, the resulting .desktop file does not change that often, but
that means that it is easy to forget to update it (essentialy,
you'd have to either watch the PO files for changes to the 2 strings
in question or rebuild the .desktop file anyway and compare them).
Integratingthe translations automatically during the build process
makes all this go away.

Furthermore, the strings for translations are extracted directly from
the .desktop.in file, removing the need for ugly warts like this
(LogViewerGui.py:173):
        #so the comment string for the desktop file will be translated
        commentString = _("Examine system log files")
(including the need to keep this consistent with the English string
in the .desktop file).

Please reconsider your decision.
Comment 4 Tammy Fox 2003-09-15 14:54:30 EDT
I rebuilt with the latest desktop a few days ago. I do watch the po commits and
rebuild before we release a final product with any new desktop file
translations. I do not feel it is worth engineering time to change this.
Comment 5 Brent Fox 2003-09-15 15:48:49 EDT
*** Bug 104004 has been marked as a duplicate of this bug. ***
Comment 6 Brent Fox 2003-09-15 15:49:01 EDT
*** Bug 104010 has been marked as a duplicate of this bug. ***
Comment 7 Brent Fox 2003-09-15 15:49:21 EDT
*** Bug 104005 has been marked as a duplicate of this bug. ***
Comment 8 Brent Fox 2003-09-15 15:49:28 EDT
*** Bug 104011 has been marked as a duplicate of this bug. ***
Comment 9 Brent Fox 2003-09-15 15:49:47 EDT
*** Bug 104006 has been marked as a duplicate of this bug. ***
Comment 10 Brent Fox 2003-09-15 15:49:58 EDT
*** Bug 104007 has been marked as a duplicate of this bug. ***
Comment 11 Brent Fox 2003-09-15 15:50:51 EDT
*** Bug 104008 has been marked as a duplicate of this bug. ***
Comment 12 Brent Fox 2003-09-15 15:51:02 EDT
*** Bug 104009 has been marked as a duplicate of this bug. ***
Comment 13 Brent Fox 2003-09-15 15:51:40 EDT
*** Bug 104012 has been marked as a duplicate of this bug. ***
Comment 14 Brent Fox 2003-09-15 15:51:49 EDT
*** Bug 104013 has been marked as a duplicate of this bug. ***
Comment 15 Brent Fox 2003-09-15 15:51:58 EDT
*** Bug 104014 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.