Bug 104396 - (gnome.ui.About) gnome.ui.About() segfaults
gnome.ui.About() segfaults
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: gnome-python2 (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
: 104088 106027 (view as bug list)
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-09-14 16:06 EDT by Andre Moraes
Modified: 2007-04-18 12:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.0.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-02 20:06:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Trace file following the execution of redhat-control-network (559.84 KB, text/plain)
2003-09-14 16:10 EDT, Andre Moraes
no flags Details

  None (edit)
Description Andre Moraes 2003-09-14 16:06:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
When I try to get more information about a given network connection by pressing
info button on redhat-control-network, the applet crashes without any warnings.

I've tried this with Ethernet and DSL connections.

Version-Release number of selected component (if applicable):
1.3.1-1

How reproducible:
Always

Steps to Reproduce:
1. Open redhat-control-network
2. Select any network connection
3. Press the Info button

    

Actual Results:  The applet closes with a Segmentation Fault

Additional info:

I'm using severn with pt_BR language.
Comment 1 Andre Moraes 2003-09-14 16:10:14 EDT
Created attachment 94484 [details]
Trace file following the execution of redhat-control-network

The file was created when I'm running redhat-control-network. I've started
strace with the following command line:
# strace -o redhat-control-network.trace redhat-network-trace

After applet starts, I choose the Ethernet connection and press the Info
button. As soon as I did it, the applet closes with seg fault.
Comment 3 Harald Hoyer 2003-09-15 04:46:05 EDT
*** Bug 104088 has been marked as a duplicate of this bug. ***
Comment 4 Harald Hoyer 2003-09-15 04:52:51 EDT
this seems to be a pygtk problem...
please try this:
$ python
>>> import gnome.ui
>>> dlg = gnome.ui.About("name", "version", "blah", "blubb", [ "a", "ø"])
>>> dlg.run()
Comment 5 Andre Moraes 2003-09-15 20:23:52 EDT
Harald,

I did the test the you suggest. The results follows:

[root@ncc1701d root]# python
Python 2.2.3 (#1, Jun 10 2003, 16:41:13)
[GCC 3.3 20030604 (Red Hat Linux 3.3-5)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gnome.ui
>>> dlg = gnome.ui.About("name", "version", "blah", "blubb", [ "a", "ø"])
Falha de segmentação
[root@ncc1701d root]#


Hope it helps.
Comment 6 Harald Hoyer 2003-10-02 05:52:53 EDT
*** Bug 106027 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.