Bug 105796 - Missing Encoding keys
Missing Encoding keys
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-menus (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
: Triaged
: 105793 (view as bug list)
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-09-27 13:04 EDT by Ville Skyttä
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-29 18:13:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add Encoding's and use Terminal=false (9.20 KB, patch)
2003-09-27 13:06 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2003-09-27 13:04:59 EDT
Various desktop entry files from redhat-menus are missing the Encoding key and
use the deprecated "Terminal=0".  Will attach a patch.
Comment 1 Ville Skyttä 2003-09-27 13:06:09 EDT
Created attachment 94782 [details]
Add Encoding's and use Terminal=false

Oh, and BTW, the tarball is a bzipped but the filename is *.gz ... :)
Comment 2 Ville Skyttä 2003-09-27 13:08:05 EDT
*** Bug 105793 has been marked as a duplicate of this bug. ***
Comment 3 Havoc Pennington 2003-10-06 14:59:30 EDT
Patch applied to cvs, thanks. Need to rebuild.
Comment 4 Bill Nottingham 2003-10-20 18:15:59 EDT
*** Bug 107597 has been marked as a duplicate of this bug. ***
Comment 5 Ville Skyttä 2005-04-04 16:23:53 EDT
As of 3.7.1-9, the following still lack the Encoding key:

/etc/X11/starthere/preferences.desktop
/usr/share/desktop-menu-patches/gnome-pilot.desktop
/usr/share/desktop-menu-patches/gnome-accessibility.desktop
/usr/share/desktop-menu-patches/redhat-gnomemeeting.desktop
/usr/share/desktop-menu-patches/redhat-diagrams.desktop
Comment 6 Ray Strode [halfline] 2007-03-29 18:13:42 EDT
assuming the build finishes okay, this should be fixed in tomorrow rawhide.
Comment 7 Todd Zullinger 2007-03-30 12:13:23 EDT
Isn't the Encoding key now deprecated in the desktop entry spec?  From
http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-1.0.html#deprecated-items
(bullet point 4):

The Encoding key is deprecated. It was used to specify whether keys of type
localestring were encoded in UTF-8 or in the specified locale. Possible values
are UTF-8 and Legacy-Mixed. See Appendix D, The Legacy-Mixed Encoding
(Deprecated) for more details.
Comment 8 Ville Skyttä 2007-03-30 14:34:40 EDT
That's true, it's deprecated nowadays.  It wasn't in 2003 nor 2005 when I
reported/commented on this bug ;)

I think the spec is somewhat unclear about how exactly should the encodings be
specified nowadays, but I guess it's like Comment[fi.ISO-8859-1]=... and for
things of type localestring only (encoding being optional, and defaulting to
UTF-8, in which case it can be omitted).

http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-1.0.html#localized-keys
Comment 9 Ray Strode [halfline] 2007-03-31 11:38:23 EDT
It doesn't hurt to add it as long as it's set to UTF-8, though.

It just makes the file more compatible.

Note You need to log in before you can comment on or make changes to this bug.