Bug 106460 - distroverpkg is wrong
Summary: distroverpkg is wrong
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
: 107098 107521 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-10-07 12:23 UTC by Michael Schwendt
Modified: 2014-01-21 22:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-12 20:57:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix it (543 bytes, patch)
2003-10-07 20:07 UTC, Bill Nottingham
no flags Details | Diff

Description Michael Schwendt 2003-10-07 12:23:54 UTC
This is about updated Fedora Core 0.94:

/etc/yum.conf contains

  distroverpkg=redhat-release

which causes Yum to fail determining the OS version because the "redhat-release"
package has been replaced with the "fedora-release" package. Changing the line to

  distroverpkg=fedora-release

works for me.


Version-Release number of selected component (if applicable):
yum-2.0.3-1

How reproducible:
Always

Steps to Reproduce:
yum info 2>&1 | grep Server


Actual Results:  Server: Red Hat Linux Null - i386 - Base


Expected Results:  Server: Red Hat Linux 0.94 - i386 - Base

Comment 1 Doug Stewart 2003-10-07 19:55:00 UTC
I can verify that the above solution solves the problem.

Comment 2 Bill Nottingham 2003-10-07 20:07:09 UTC
Created attachment 94995 [details]
patch to fix it

This patch may be a better long term solution.

Comment 3 Bill Nottingham 2003-10-07 20:07:55 UTC
Actually, doing *both* is probably best. s/Red Hat Linux/Fedora Core/ in
yum.conf too.

Comment 4 Seth Vidal 2003-10-11 18:45:51 UTC
ok - s/name/provides/ has occurred for the config.py code. Thanks.

I can build a package w/whatever config you want, as, I'm sure, you can.


Comment 5 Bill Nottingham 2003-10-15 02:59:06 UTC
*** Bug 107098 has been marked as a duplicate of this bug. ***

Comment 6 Jeff Johnson 2003-10-20 13:31:00 UTC
*** Bug 107521 has been marked as a duplicate of this bug. ***

Comment 7 Bill Nottingham 2003-10-21 20:42:51 UTC
should be fixed in 2.0.4-1

Comment 8 Nils Philippsen 2004-05-12 06:49:33 UTC
yum-2.0.7-1.1 references redhat-release again.

Comment 9 Seth Vidal 2004-05-12 20:57:14 UTC
spoke with sopwith, who made these changes. having it be
redhat-release means it works in fedora core and rhel w/o any change.

that make sense?
so I'm reclosing.



Note You need to log in before you can comment on or make changes to this bug.