Bug 106716 - New cdrecord version requires patch to xcdroast for it to work
New cdrecord version requires patch to xcdroast for it to work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xcdroast (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
http://www.xcdroast.org/
:
: 106877 107106 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-10-09 16:25 EDT by John Thacker
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-13 09:40:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Thacker 2003-10-09 16:25:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030927

Description of problem:
With version 2.01a17 of cdrecord, it changed how its version string gets
reported.  xcdroast attempts to check the version of cdrecord to make sure that
all its features are supported before running.  With the packages for 2.01a19
installed from updates, xcdroast can't parse the new version string, and halts
with an error message when trying to load.

One can force it to load by disabling version checking with the '-n' flag, but
this also disables features like on-the-fly audio support that depend on
features in later version of cdrecord.

The xcdroast webpage has a comment about this problem:
http://www.xcdroast.org/

The website provides patches which can be applied to fix the problem as well as
a few other nasty bugs, like a false error message:
http://www.xcdroast.org/xcdr098/patches/

These patches should be applied to the source used to build the xcdroast
package, and then all will be fine.  (The next xcdroast release will incorporate
these patches.)

Version-Release number of selected component (if applicable):
xcdroast-0.98alpha14-1 cdrecord-2.01-0.a19.1

How reproducible:
Always

Steps to Reproduce:
1. Update to cdrecord-2.01-0.a19.1 from RHN or rawhide
2. Run 'xcdroast'
    

Actual Results:  xcdroast fails to start, giving a warning message:
"** WARNING **: Invalid cdrecord version Clone found.
        Expecting at least version 1.11a34
        Start xcdroast with the -n option to override (not recommended!)"

Expected Results:  xcdroast loads normally

Additional info:
Comment 1 raxet 2003-10-12 17:47:28 EDT
*** Bug 106877 has been marked as a duplicate of this bug. ***
Comment 2 Harald Hoyer 2003-10-15 02:53:18 EDT
*** Bug 107106 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.