Bug 106982 - console mouse services fails to start properly
console mouse services fails to start properly
Status: CLOSED DUPLICATE of bug 109613
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 105703 108791 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-14 02:13 EDT by louisgtwo
Modified: 2014-03-16 22:39 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description louisgtwo 2003-10-14 02:13:31 EDT
gpm tries to startup twice: 

Oct 11 16:20:33 tiger sshd:  succeeded
Oct 11 16:20:33 tiger xinetd: xinetd startup succeeded
Oct 11 16:20:34 tiger gpm: gpm startup succeeded      <----
Oct 11 16:20:34 tiger crond: crond startup succeeded
Oct 11 16:20:34 tiger xinetd[2752]: xinetd Version 2.3.12 started with
libwrap loadavg options compiled in.
Oct 11 16:20:34 tiger xinetd[2752]: Started working: 1 available service
Oct 11 16:20:35 tiger xfs: xfs startup succeeded
Oct 11 16:20:35 tiger anacron: anacron startup succeeded
Oct 11 16:20:35 tiger atd: atd startup succeeded
Oct 11 16:20:35 tiger xfs: ignoring font path element
/usr/X11R6/lib/X11/fonts/cyrillic (unreadable)
Oct 11 16:20:35 tiger rc: Starting firstboot:  succeeded
Oct 11 16:20:35 tiger messagebus: messagebus startup succeeded
Oct 11 16:20:35 tiger rhnsd[2855]: Red Hat Network Services Daemon
starting up.
Oct 11 16:20:35 tiger rhnsd: rhnsd startup succeeded
Oct 11 16:20:37 tiger modprobe: modprobe: Can't locate module
char-major-10-134
Oct 11 16:20:43 tiger gpm[2762]: O0o.oops(): [gpm.c(949)]:   <----
Oct 11 16:20:43 tiger gpm[2762]: mouse initialization failed   <----

As a result fails to shutdown.

This might be causing the firstboot problems with the mouse.
Comment 1 Bill Nottingham 2003-10-14 11:20:52 EDT
Can you attach the full log?
Comment 2 Gerry Tool 2003-10-14 15:19:28 EDT
This is happening to me with Test 3

First noticed it as [FAILED] during shutdown.

results of cat /var/log/messages | grep gpm
===========================================
Oct 14 08:33:07 gstpc gpm: gpm startup succeeded
Oct 14 08:33:14 gstpc gpm[5248]: O0o.oops(): [gpm.c(949)]:
Oct 14 08:33:14 gstpc gpm[5248]: mouse initialization failed
Oct 14 09:08:42 gstpc gpm: gpm shutdown failed
Oct 14 09:10:09 gstpc gpm: gpm startup succeeded
Oct 14 09:10
Comment 3 Eido Inoue 2003-10-14 15:21:37 EDT
*** Bug 105703 has been marked as a duplicate of this bug. ***
Comment 4 Gerry Tool 2003-10-14 15:23:40 EDT
Full comment did not appear in submission.  Here it is again.

results of cat /var/log/messages | grep gpm
===========================================

Oct 14 08:33:07 gstpc gpm: gpm startup succeeded
Oct 14 08:33:14 gstpc gpm[5248]: O0o.oops(): [gpm.c(949)]:
Oct 14 08:33:14 gstpc gpm[5248]: mouse initialization failed
Oct 14 09:08:42 gstpc gpm: gpm shutdown failed
Oct 14 09:10:09 gstpc gpm: gpm startup succeeded
Oct 14 09:10:16 gstpc gpm[5234]: O0o.oops(): [gpm.c(949)]:
Oct 14 09:10:16 gstpc gpm[5234]: mouse initialization failed

============================================
for last two reboots
Comment 5 Bill Nottingham 2003-10-14 15:38:18 EDT
Let me guess... this happens every time you boot with rhgb, and doesn't happen
otherwise?
Comment 6 Marc Williams 2003-12-27 09:45:01 EST
I get the same thing but have figured out why (partially).

I just added a new mouse and started seeing the red [Failed] by
"Shutting down console mouse services" when shutting down.  Except
everything seems to work fine.

There's nothing special about my mouse, just a generic wheel mouse so
that's what I told FC1 to use.  Since I'm using the USB / PS2 adapter
that came with the mouse, I'm using that also and told FC1 to use PS/2
instead of USB.  But I discovered that if I simply remove the adapter
and tell FC1 that it's a USB mouse instead of a PS/2 mouse, my warning
goes away.

So in my case at least, there seems to be something funky with the USB
/ PS2 adapter or with how FC1 handles it.  In either case, the mouse
functions fine, including console cut n paste.  The only difference is
whether or not I receive that failure message when shutting down.
Comment 7 Jonathan Blandford 2004-02-03 14:48:02 EST
*** Bug 108791 has been marked as a duplicate of this bug. ***
Comment 8 Bart Martens 2004-03-12 00:47:32 EST
Comment #5 : true.

initscripts-7.42.2-1
gpm-1.20.1-38

Setting version to 1. Lowering severity and priority.
Comment 9 Bart Martens 2004-03-12 01:08:28 EST

*** This bug has been marked as a duplicate of 109613 ***
Comment 10 Red Hat Bugzilla 2006-02-21 13:59:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.