Bug 107896 - bugzilla's not sending me as much mail as before
bugzilla's not sending me as much mail as before
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.8
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-24 00:17 EDT by Bill Nottingham
Modified: 2014-03-16 22:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-21 16:56:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2003-10-24 00:17:13 EDT
It does not appear to be sending mail on bug creation correctly;
it doesn't send me mail when I create a bug that's assigned to me, nor
when that bug is created with a blocker bug of a bug that's assigned
to me.

(I'm using bugzilla-css, if that matters.)
Comment 1 David Lawrence 2003-10-24 12:43:08 EDT
Should be working now. Please re-open if not the case.
Comment 2 Bill Nottingham 2003-10-26 21:56:26 EST
I did not recieve any notification of:

http://bugzilla.redhat.com/bugzilla-css/show_bug.cgi?id=108022
Comment 3 David Lawrence 2003-10-27 12:59:36 EST
I am receiving mail fine for stuff meant to go to me. I have the
sendmail queue set to 5m, on the new machine. Are you giving it enough
time to reach you?
Comment 4 Bill Nottingham 2003-10-27 15:08:45 EST
As far as I know, yes.  Basically, there are new bug reports that I just don't
get mail for.
Comment 5 Göran Uddeborg 2003-10-28 16:49:28 EST
It happens all the time for me.  Nobody ever gets any mail when I do changes. 
As an example, I just added
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=108386 and bugzilla came to
the conclusion

Bug 108386 has been added to the database
Email sent to: no one
Excluding: notting@redhat.com, goeran@uddeborg.se 

So it is not a sendmail problem; bugzilla did choose not to send any mail.  But
why?  Myself I have set my preferences so I should get mail even for my own
changes.  And I doubt Bill has disabled his mails when he becomes the assignee
of a newly created bug.

Other examples are bug 58942 where nobody was told I added myself to cc the
other day, and bug 75040 and bug 91233 where I added comments and everybody was
excluded.  In the latter case <davidj@fy.chalmers.se> later added himself as a
cc.  THEN I got a mail with both my own changes, and David's.
Comment 6 Vadim Nasardinov 2003-10-29 10:49:59 EST
We are seeing the same problems.  See, for example,
http://post-office.corp.redhat.com/archives/ccm-engineering-list/2003-October/msg00164.html

Speaking for myself, I posted a comment on a ticket this morning and got this

Changes submitted for bug 108430
Email sent to: no one
Excluding: ccm-bugs-list@redhat.com, randyg@redhat.com, jorris@redhat.com

None of these emails should have been excluded.  The ccm-bugs-list@redhat.com
is the default assignee.  randyg is the submitter.  jorris@redhat.com is our
QA department and normally gets cc'ed on all tickets in the Red Hat CCM category.

Comment 7 Mattias Dahlberg 2003-10-29 10:58:50 EST
The same thing has happened to me. One example is bug 108014.
Comment 8 Vadim Nasardinov 2003-10-29 11:18:11 EST
This happened two minutes ago:

Bug 108443 has been added to the database
Email sent to: no one
Excluding: vadimn@redhat.com, ccm-bugs-list@redhat.com, jorris@redhat.com
Comment 9 Elton Woo 2003-10-29 13:28:21 EST
I can concur that this appears to be happening to me (as of this morning - 29
OCT.). Usually within a few minutes of posting a report I receive the usual email.
This has not happened today (Bugs 107652 and 108453).
Comment 10 Paul W. Frields 2003-10-29 17:41:07 EST
Another METOO. Just closed bug #106826 at 2003-10-29 17:20, and bugzilla
notified me it was sending mail to no one. It put everyone listed in the bug's
CC field in the "excluded" list -- including me -- despite the fact that my
prefs have not changed, and indicate I should have been mailed at closure. (The
previous status was MODIFIED, so I would expect that the modifier -- in this
case Jeremy Katz -- normally expects e-mail to show that the reporter has
verified the fix and closed the bug.)
Comment 11 Mike Bonnet 2003-10-30 11:25:41 EST
Yet another me too.  Just created a new bug, and got this:

Bug 108601 has been added to the database
Email sent to: no one
Excluding: ccm-bugs-list@redhat.com, mikeb@redhat.com, jorris@redhat.com

Everyone on the excluded list should have received the email.
Comment 12 Leonard den Ottolander 2003-10-30 12:27:39 EST
It appears to me that bugzilla somehow delays the messaging of some events. F.e.
I added myself to the CC list after comment #9, but the message of this state
change came in the same mail as the text of comment #10. I believe these should
have generated separate messages (please correct me if I'm wrong):

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=107896


leonardjo@hetnet.nl changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |leonardjo@hetnet.nl




------- Additional Comments From stickstr5@hotmail.com  2003-10-29 17:41 -------
Another METOO. Just closed bug #106826 at 2003-10-29 17:20, and bugzilla
notified me it was sending mail to no one. It put everyone listed in the bug's
<snip>
Comment 13 Leonard den Ottolander 2003-10-30 12:32:29 EST
Funny, after the last comment I got:

Changes submitted for bug 107896
Email sent to: dkl@redhat.com, notting@redhat.com, davidj@fy.chalmers.se,
goeran@uddeborg.se, vadimn@redhat.com, voz@home.se
Excluding: leonardjo@hetnet.nl

instead of Email sent to: no one

Not sure if somebody is trying to fix something somewhere or that the behaviour
is just as inconsistent as this...
Comment 14 David Lawrence 2003-10-30 12:42:48 EST
Its just that inconsistent *sigh* digging some more.
Comment 15 Vadim Nasardinov 2003-10-30 12:52:07 EST
David, I don't know if all of this additional data is of any help,
but here goes.

Mike's bug 108601 (see comment #11 above) generated a delayed alert
after someone else posted a comment on it.  The alert contains
Mike's original description of the bug, as well as the additional
comment.  See
http://post-office.corp.redhat.com/archives/ccm-bugs-list/2003-October/msg00461.html
Comment 16 David Lawrence 2003-10-31 13:39:21 EST
I have made some changes to the mail handling routines in Bugzilla.
Seems that the date math stuff I was using for the older Postgresql
database was returning different results than before since I upgraded
the server. We will try this for a little while.
Comment 17 Göran Uddeborg 2004-08-21 16:56:10 EDT
I haven't had any problems for a long time now.  Presumably, the fixes
mentioned in comment 16 helped.  I'll close this bug, since it seems
to be forgotten.

Note You need to log in before you can comment on or make changes to this bug.