Bug 109751 - ATI Radeon 9800 Pro drivers not working.
ATI Radeon 9800 Pro drivers not working.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
: 116285 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-11 11:26 EST by Scott Gant
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 06:45:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Gant 2003-11-11 11:26:05 EST
Description of problem: 
Installation program hangs when booting into the graphical
installation when using a ATI Radeon 9800 Pro using the auto-detected
drivers.


Version-Release number of selected component (if applicable):


How reproducible:
Place in boot CD and hit enter at the install prompt to use the
graphical installation.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
System hangs.

Expected results:


Additional info:
Installation continues if you choose 'linux text' at the install
prompt. But will hang again at 'first boot' after install.
Comment 1 Scott Gant 2003-11-11 11:30:10 EST
Work around so far is to use 'linux rescue', chroot, change
/etc/inittab to reboot into text mode. Have the ATI made driver RPM
for the 9800 and install. Run the 'fglrxconfig' utility that is
included with the drivers to config the monitor system. After that,
change back the /etc/inittab and reboot. Everything should be fine
then. Will have 2D AND 3D support with FSAA etc etc.
Comment 2 Harald Glatt 2003-11-14 13:13:18 EST
It`s also easyier to do following instead using of using the boot
rescue mode:

Just hit a at the grub prompt and append "3 nogb" to the kernel
parameters...

3 tells the system to only start into runlevel 3 (without xdm, so no
xfree server is started)
nogb tells the system that you do not want to use graphical boot (so x
doesnt get started...)

Afterwards you can do the changes you explained above.. but you dont
need the cd to do it... I think this way is easier...
Comment 3 Shawn Walker 2003-11-21 11:59:52 EST
This is a duplicate of bug 109256
Comment 4 Syst3m Snip3r 2003-12-27 03:27:37 EST
I have some questions regarding Scott Grants post. I need to change 
my card back the VESA as well so I can actually use Linux. But I'm 
quite new to Linux and need some help.

1. How do you "change /etc/inittab to reboot into text mode"?
2. I have the ATI driver on a floppy can I install from floppy?
3. How do I "Run the 'fglrxconfig' utility that is included with the 
drivers to config the monitor system"
4. How do I "After that, change back the /etc/inittab and reboot" (I 
know how to reboot).

Thanks very much, I am not running a Radeon 9800 but a Radeon 9600 XT 
but I still need to start my Linux up.
Comment 5 Dave Habben 2004-02-13 17:42:16 EST
This bug should probably be updated to Version: test1 as this still
happens in the FC 1.90 release. 

lspci:
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon
R350 [Radeon 9800]
0000:01:00.1 Display controller: ATI Technologies Inc Radeon R350
[Radeon 9800] (Secondary)
Upon loading the graphical installer it freezes with a white screen
with a mouse pointer on it. 

It can be installed using: linux text at the boot prompt, then after
it finishes installing booting to init 3 and changing the radeon
driver to vesa

I have had success using the XFree86 4.4.0 pre-release radeon driver
with this card. Any chance of a driver backport into FC's XFree86 4.3?
Comment 6 Mike A. Harris 2004-02-13 19:28:51 EST
Yes, this problem is still present, as I haven't touched the Radeon
driver in many months.

I will update all Radeon related bug reports that are open in bugzilla
when I have a chance to spend time on these issues.  It wont be for
a while at least.

The 4.4.0 driver is drastically changed, it isn't just some small
updates.  Updating the driver would destabilize RHEL 3 potentially,
and I'm not willing to do that.  I need to keep one single src.rpm
building between all OS releases we support, to minimize maintenance.

Comment 7 Erich Hoover 2004-02-14 19:00:37 EST
I've been having the same problem with all FC releases (All-In-Wonder 
9800 Pro), but it works in RedHat 9 where the card is detected as 
generic.  Couldn't you guys have a command-line option like "linux 
forcegeneric" so that we don't have to use the text install anymore?
Comment 8 Dave Habben 2004-02-15 20:53:30 EST
I've found that if I enable the option:
Section "Screen"
 Option "XaaNoScreenToScreenCopy"

It solves all the lockups that I've had on my 9800 and 9600XT, plus I
get the added benefit of using a refresh rate above 60 Hz. Sadly this
Xaa option also seems to cause the greatest slowdown to this driver. 

I used the list of options I found here to try and determine the cause:
http://www.xfree86.org/current/XF86Config.5.html#sect10

I also have a config that works most of the time, with the exception
of opening Mozilla Mail, that causes it to freeze.

Section "Screen"
        #Option "XaaNoScreenToScreenCopy"
	Option "XaaNoImageWriteRect"
	Option "XaaNoOffscreenPixmaps"
	Option "XaaNoSolidFillRect"

Anyone else care to give it a try?
Comment 9 Shawn Walker 2004-02-16 00:43:15 EST
This is really disappointing that it can't be fixed.

I'm currently using RedHat Professional Workstation and it has the
same issue. In fact, there it's even worse, X won't even start.

Fedora Core 1.90 obviously doesn't work either as stated above.

I used to be able to use RedHat 9 with the 9800 by overriding the
Chipset ID and forcing X to think it was on of the older radeon
9x00's. That allowed me to get fully working 2D without using ATi's
shoddy drivers.
Comment 10 Mike A. Harris 2004-02-16 01:51:20 EST
> This is really disappointing that it can't be fixed.

Nobody's said it can't be fixed.  It can be fixed, it just is not
fixed right now currently.

I'm currently using RedHat Professional Workstation and it has the
same issue. In fact, there it's even worse, X won't even start.

>Fedora Core 1.90 obviously doesn't work either as stated above.
>
>I used to be able to use RedHat 9 with the 9800 by overriding the
>Chipset ID and forcing X to think it was on of the older radeon
>9x00's. That allowed me to get fully working 2D without using ATi's
>shoddy drivers.

Radeon 9200, 9600, 9800 are not supported at all in any way by
XFree86 4.3.0.  XFree86 4.3.0 was released on February 27, 2003,
a month or two before the ATI Radeon 9200/9600/9800 hardware was
publically available, and as such, that hardware is not supported
in 4.3.0 at all.

ATI contributed patches to XFree86.org to add experimental support
for the new hardware, which got committed to CVS in April or
thereabouts.  That code was just _preliminary_ support for the
new hardware, and not complete in any way.  I backported this
code to 4.3.0 and made some additional fixes.  I later backported
further ATI contributed code as well, however ALL of this code
is experimental only, and not considered "complete".

Months later, ATI came out with another new generation of variants
of the original 9200/9600/9800 with "SE" and "XT" suffixes.  Later
they contributed patches to provide initial support for these new
cards also.  All of that support is in XFree86 CVS as well, and
again, I've backported some of it.  Again, it is _EXPERIMENTAL_.

So as it currently stands, neither XFree86.org's official XFree86
4.3.0 release, nor Red Hat "officially" support the Radeon 9200,
9600, or 9800 in any way.  The driver support for these chips
is expermental only, and provided "as-is" in hopes that it works
for someone, and in order to have people test it and provide
feedback so that problems can be fixed in a future "official"
release which officially supports this hardware.

The problem however, is that by adding "experimental" support
in this fashion, many people _expect_ it to work, and to work
flawlessly, and get very upset if it does not.  Many people also
demand that problems get fixed immediately, or as soon as possible,
assuming that because the driver detects their card, that the
card is "supported".

I must admit, that this was a huge mistake on my part, because
now there are many users out there who are upset that the driver
does not work on their card, and are misled into believing that
their card is supported, due to the config tools autodetecting
and autoconfiguring the hardware.

In order to correct this problem, I will no longer be including
experimental driver support for new hardware in our XFree86
releases, until I can personally test each and every card, and
either fix problems found myself, or obtain fixes from ATI or
other vendors, or elsewhere.

All unsupported hardware, will either be redirected to the generic
unsupported "vesa" driver in the future, or if we know that vesa
doesn't work, the hardware will remain unmapped to a driver.

I sincerly apologize to all Radeon users affected by the current
Radeon driver's instabilities on unsupported hardware, for the
inconvenience that my personal efforts as a volunteer on the
weekend to backport Radeon driver support to XFree86 4.3.0
have failed to result in a flawless user experience for many
Radeon 9200/9600/9800 users.

I have learned the hard way, that it is better to have no support
at all, than to have something experimental that does not work
for everyone, but conveys the incorrect message to them that it
is a supported.

I will make my best efforts very soon, to either fix the Radeon
driver, or to remove all Radeon support patches for newer hardware
in which I know it does not work properly due to the bug reports
received.

Again, my apologies.
Comment 11 Mike A. Harris 2004-02-16 02:02:56 EST
Oops, the following comment in my last comment was supposed to
be a quote from comment 9 above, which I forgot to add ">" to
the beginning of.

"I'm currently using RedHat Professional Workstation and it has the
same issue. In fact, there it's even worse, X won't even start."

Just clarifying here, that that was a quote, and not my own words.
Comment 12 Erich Hoover 2004-02-16 15:16:30 EST
It's not your fault the drivers aren't fully compatible.  I do think
that at least for the initial installation that experimental drivers
should not be used, or at least some sort of warning message:
"The drivers for your video card are experimental, would you like to
use the experimental driver or a generic driver?"
Comment 13 Andrej Potokar 2004-02-19 15:00:15 EST
*** Bug 116285 has been marked as a duplicate of this bug. ***
Comment 14 Harald Glatt 2004-03-02 23:07:17 EST
I once was also one of the Fedora/Redhat newbies that opened a bug
about this issue and said there that this should be blocking the Core
1 Release and so on...

Mike Harris: I am sorry that this is happening to you, but you should
know that this is not a personal offence :/ People can`t know what you
did to try to improve the XFree used in Fedora... They really just
can't know that! You should not feel offended by bugs like this and
like mine (months ago). I know you are a good guy and hope you won't
take it too personal ;)

Good luck to you and your coding ;)
Comment 15 Ken Roser 2004-04-04 00:08:43 EST
I notice that Core 2, Test 2 seems to work with the Radeon 9800.  Has
this bug been fixed or is it just luck that things seem to work now?
Comment 16 Mike A. Harris 2004-04-04 07:10:09 EDT
Neither actually.

Fedora Core 1 ships with XFree86 4.3.0.  Stock 4.3.0 does not
support the Radeon 9800 at all because the Radeon 9800 did not
exist when 4.3.0 was released.  Red Hat XFree86 4.3.0 has some
patches added to it taken from XFree86 CVS after 4.3.0 was released,
which were added as experimental code to try to get the 9800 working.
It does work on some Radeon 9800 models, but not all.  That is not
really a bug per se, because the experimental patches are not
officially supported by Red Hat.

On the luck side of your question...  it is not luck, it is because
FC2t2 does not have XFree86 4.3.0 anymore.  FC2t2 ships with
an entirely brand new X server implementation - Xorg X11, which
is based on XFree86 4.4.0 prior to the license change.  Xorg X11
does support the various Radeon 9800 variants, so you'll probably
find it works much better.

Hope this helps.

Thanks for testing.
Comment 17 Shawn M. Jones 2004-05-02 16:03:46 EDT
Possible dupe of bug 121604?
Comment 18 Shawn M. Jones 2004-05-02 18:27:07 EDT
That teaches me to do 10 things at once.  Bug 121604 is a dupe of this
bug.  Sorry, I got mixed up.
Comment 19 Mike A. Harris 2004-09-21 06:45:14 EDT
Radeon 9800 and various variants should now work correctly in
Fedora Core development, and should also autodetect with our
config tools.  Please test Fedora Core 3 test2 beta test release
and if there are problems, please open a new bug report against
Fedora Core 3 test2.

Thanks in advance.

Setting status to "RAWHIDE"

Note You need to log in before you can comment on or make changes to this bug.