Bug 1122583 - [RFE] Need an ability to specify per infrastructure network if Foreman/Staypuft admin node should provide network DNS service
Summary: [RFE] Need an ability to specify per infrastructure network if Foreman/Staypu...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 6)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: z1
: Installer
Assignee: Marek Hulan
QA Contact: Omri Hochman
URL:
Whiteboard:
: 1122606 (view as bug list)
Depends On: 1122550 1122553 1127449
Blocks: 1119353 1122606
TreeView+ depends on / blocked
 
Reported: 2014-07-23 14:28 UTC by arkady kanevsky
Modified: 2016-04-26 22:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1122587 (view as bug list)
Environment:
Last Closed: 2014-08-06 21:16:13 UTC


Attachments (Terms of Use)

Description arkady kanevsky 2014-07-23 14:28:52 UTC
Description of problem:
For OSP deployments some networks require DNS service to be provided 

Version-Release number of selected component (if applicable):
N/A

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Mike Burns 2014-07-25 13:34:26 UTC
*** Bug 1122587 has been marked as a duplicate of this bug. ***

Comment 3 Mike Burns 2014-07-25 13:34:58 UTC
*** Bug 1122606 has been marked as a duplicate of this bug. ***

Comment 4 arkady kanevsky 2014-08-04 18:22:23 UTC
Actually we need both DHCP and DNS services for some network.
That will allow automatic IP address assignment.
For example, for storage cluster network that is used for ceph cluster- there is not need to manually assign IP addresses.

We also need to decide on IPv4 or IPv6 or both support for DNS and DHCP.


Note You need to log in before you can comment on or make changes to this bug.