Bug 1142256 - remote engine-reports-setup does not write conf file to allow accessing reports from engine
Summary: remote engine-reports-setup does not write conf file to allow accessing repor...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-reports
Version: 3.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Yedidyah Bar David
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
: 1142750 1147435 (view as bug list)
Depends On:
Blocks: 1144079
TreeView+ depends on / blocked
 
Reported: 2014-09-16 12:57 UTC by Yedidyah Bar David
Modified: 2015-03-02 11:13 UTC (History)
14 users (show)

Fixed In Version: oVirt-3.5 GA ovirt-engine-reports-3.5.0-1.fc19.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1144079 (view as bug list)
Environment:
Last Closed: 2014-10-17 12:35:31 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 32989 master ABANDONED packaging: setup: write reports conf 2020-05-27 12:39:15 UTC
oVirt gerrit 33238 None MERGED packaging: setup: config engine to access reports 2020-05-27 12:39:15 UTC

Description Yedidyah Bar David 2014-09-16 12:57:51 UTC
Description of problem:

Following bug #1116851 , the engine expects in its configuration files a new setting ENGINE_REPORTS_BASE_URL, and other related settings, instead of a row in vdc_options.

The engine now also expects the certificate of reports to be in its truststore.

engine-setup, if running engine and reports on same host, should create such a file and update the truststore, and if not, ask the user to do that.

Comment 1 Yedidyah Bar David 2014-09-16 13:01:47 UTC
workaound: do this manually after setup. E.g.:

Create a file /etc/ovirt-engine/engine.conf.d/10-my-reports.conf with this content:

ENGINE_REPORTS_BASE_URL=https://REPORTS_FQDN/ovirt-engine-reports
ENGINE_REPORTS_DASHBOARD_URL=${ENGINE_REPORTS_BASE_URL}/flow.html?viewAsDashboardFrame=true
ENGINE_REPORTS_PROXY_URL=${ENGINE_REPORTS_BASE_URL}/ovirt/reports-interface
ENGINE_REPORTS_VERIFY_HOST=true
ENGINE_REPORTS_VERIFY_CHAIN=true
ENGINE_REPORTS_READ_TIMEOUT=

replace above REPORTS_FQDN with the fqdn of the reports server (same as engine if on same server).

Imported reports cert to truststore with the following command:

keytool -importcert -alias reportscacert -file /etc/pki/ovirt-engine/certs/reports.cer -keystore /etc/pki/ovirt-engine/.truststore -storepass mypass

If on remote host, replace above '/etc/pki/ovirt-engine/certs/reports.cer' with a file name containing the reports cert.

service ovirt-engine restart

Comment 2 Yedidyah Bar David 2014-09-16 13:03:51 UTC
(In reply to Yedidyah Bar David from comment #1)
> workaound: do this manually after setup. E.g.:
> 
> Create a file /etc/ovirt-engine/engine.conf.d/10-my-reports.conf with this
> content:
> 
> ENGINE_REPORTS_BASE_URL=https://REPORTS_FQDN/ovirt-engine-reports
> ENGINE_REPORTS_DASHBOARD_URL=${ENGINE_REPORTS_BASE_URL}/flow.
> html?viewAsDashboardFrame=true

Sorry, this should be:

ENGINE_REPORTS_DASHBOARD_URL=${ENGINE_REPORTS_BASE_URL}/flow.html?viewReportFlow=true

> ENGINE_REPORTS_PROXY_URL=${ENGINE_REPORTS_BASE_URL}/ovirt/reports-interface
> ENGINE_REPORTS_VERIFY_HOST=true
> ENGINE_REPORTS_VERIFY_CHAIN=true
> ENGINE_REPORTS_READ_TIMEOUT=
> 
> replace above REPORTS_FQDN with the fqdn of the reports server (same as
> engine if on same server).
> 
> Imported reports cert to truststore with the following command:
> 
> keytool -importcert -alias reportscacert -file
> /etc/pki/ovirt-engine/certs/reports.cer -keystore
> /etc/pki/ovirt-engine/.truststore -storepass mypass
> 
> If on remote host, replace above '/etc/pki/ovirt-engine/certs/reports.cer'
> with a file name containing the reports cert.
> 
> service ovirt-engine restart

Comment 3 Shirly Radco 2014-09-16 13:32:01 UTC
Barak, Arthur,

This means that 3.5 will require the workaround in order to setup reports in local and remote installations.

Do you approve?

Comment 4 Barak 2014-09-16 13:44:54 UTC
This should definitely make it to 3.5.1,
From my point of view this is a must.

Comment 5 Yedidyah Bar David 2014-09-17 05:51:28 UTC
Current http://gerrit.ovirt.org/32989 is on engine side, works only if both are on same host. Another patch will be required on reports side when it's remote.

Comment 6 Shirly Radco 2014-09-18 19:19:16 UTC
*** Bug 1142750 has been marked as a duplicate of this bug. ***

Comment 7 Sandro Bonazzola 2014-09-22 08:09:37 UTC
Not blocking 3.5.0 GA since it has been targeted for 3.5.1 only

Comment 8 Yedidyah Bar David 2014-09-23 12:18:31 UTC
Eventually solved both this one and bug 1144079 with a single patch, leaving open for qe verification.

Comment 9 Shirly Radco 2014-09-29 10:26:47 UTC
*** Bug 1147435 has been marked as a duplicate of this bug. ***

Comment 10 Sandro Bonazzola 2014-10-17 12:35:31 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.