Bug 114266 - stack trace attempting to create new user
Summary: stack trace attempting to create new user
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: system-config-users (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
: 114473 116183 116636 118016 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-25 18:26 UTC by Alexandre Oliva
Modified: 2007-04-18 17:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-03 23:52:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2004-01-25 18:26:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031202

Description of problem:
When you request the creation of a new user, you get a stack trace.

Version-Release number of selected component (if applicable):
system-config-users-1.2.8-1

How reproducible:
Always

Steps to Reproduce:
1.Enter user information for new account
2.Click Ok

Actual Results:  Traceback (most recent call last):
  File "/usr/share/system-config-users/userWindow.py", line 227, in
on_userWin_ok_button_clicked
    if self.homeDirCheck.get_active() == gtk.TRUE:
TypeError: argument 2 must be list, not str

Expected Results:  Should create new account.

Additional info:

Comment 1 Sammy 2004-01-27 16:01:13 UTC
Your patch fails due to use of BUFFERSIZE on top. Should this 
be &buf_size? 

Comment 2 Brent Fox 2004-02-02 23:48:52 UTC
*** Bug 114473 has been marked as a duplicate of this bug. ***

Comment 3 Brent Fox 2004-02-02 23:50:35 UTC
I suspect that something may be wrong with pygtk2 here.  That
traceback   doesn't make sense to me.  get_active() shouldn't expect
any arguments.

Comment 4 Brent Fox 2004-02-02 23:54:11 UTC
If I upgrade system-config-users on my FC 1 box, it works fine.  If I
install the same RPM on a FC 2 test1-ish box, it fails.  The
system-config-users code hasn't changed in over a year.

Comment 5 Jonathan Blandford 2004-02-03 21:33:08 UTC
what is self.homeDirCheck there?

also, why are you doing '== gtk.TRUE'?

Comment 6 Brent Fox 2004-02-03 23:18:14 UTC
self.homeDirCheck is a gtkCheckButton which is defined in the glade file.

So,  self.homeDirCheck.get_active() should return a boolean to which
I'm comparing it to gtk.TRUE.  

However, if I change the code to "if self.homeDirCheck.get_active()",
I get the same effect without the traceback.  

Why would removing the comparison to gtk.TRUE avoid the problem?

Comment 7 Brent Fox 2004-02-03 23:52:50 UTC
Anyway, I removed the comparison to gtk.TRUE so I could rebuild and
fix the problem, but I'm still curious as to why this happened in the
first place.  The same code worked fine on a FC1 system.

Should be fixed in system-config-users-1.2.9-1.

Comment 8 Brent Fox 2004-02-20 02:19:50 UTC
*** Bug 116183 has been marked as a duplicate of this bug. ***

Comment 9 Brent Fox 2004-02-24 03:51:39 UTC
*** Bug 116636 has been marked as a duplicate of this bug. ***

Comment 10 Alexandre Oliva 2004-02-24 19:19:18 UTC
Confirmed fixed in 1.2.9-1.1, thanks.

Comment 11 Brent Fox 2004-03-12 00:44:29 UTC
*** Bug 118016 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.