Bug 114299 - Segfault in /sbin/loader
Segfault in /sbin/loader
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
: 115605 115956 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-26 07:41 EST by Tim Waugh
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 15:02:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mtrace patch (1.81 KB, patch)
2004-02-25 14:04 EST, Tim Waugh
no flags Details | Diff

  None (edit)
Description Tim Waugh 2004-01-26 07:41:40 EST
Description of problem:
Trying to install FC2-re0123.1 on a Dell Inspiron 3500 with 'ks vnc'
or 'ks text' gives this:

running /sbin/loader
install exited abnormally -- received signal 11
Comment 1 Tim Waugh 2004-01-26 08:30:04 EST
Also happens with rawhide-20040126.
Comment 2 Tim Waugh 2004-01-27 05:38:33 EST
Still happens in FC2-re0126.0 (anaconda 9.90-2).
Comment 3 Tim Waugh 2004-01-27 07:37:31 EST
It's happenening in probeDevices.
Comment 4 Tim Waugh 2004-01-27 10:37:00 EST
In fact it's happening inside strdup. :-(

Removing all device entries in /etc/pcmcia/config except for the
Xircom CE3 network card it needs to install from gets it past the
segfault.
Comment 5 Bill Nottingham 2004-01-27 13:33:12 EST
Can you attach the /etc/pcmcia/config?
Comment 6 Tim Waugh 2004-01-28 04:04:05 EST
It's the one from the boot.iso initrd.  Or do you mean the edited-down
one?  I found that it still crashes if I remove all but one of the
(for me) unneeded entries, it just crashes in a different place.
Comment 7 Bill Nottingham 2004-01-28 04:08:58 EST
Whatever one makes it crash. :)
Comment 8 Tim Waugh 2004-01-28 04:11:23 EST
It crashes without any modifications from the initrd in boot.iso.
Comment 9 Bill Nottingham 2004-01-28 15:01:00 EST
OK, running kudzu -p -b pcmcia doesn't segfault for me, and neither
does a test program linked against the diet stack.
Comment 10 Tim Waugh 2004-01-28 18:14:16 EST
How about with a PCMCIA network device plugged in?  If I pull mine out
it doesn't segfault, but I can't get much further in the install that
way. ;-)
Comment 11 Bill Nottingham 2004-01-28 20:48:46 EST
16-bit pcmcia, I'm assuming. Damn, should have waited to read this
before going home without one. :)
Comment 12 Tim Waugh 2004-01-29 10:54:02 EST
It's this one:

$ grep CE3 /etc/pcmcia/config
card "Xircom CE3-10/100 Fast Ethernet"
  version "Xircom", "*", "CE3-10/100"
Comment 13 Tim Waugh 2004-02-10 09:18:50 EST
Still happens with rawhide-20040210.
Comment 14 Tim Waugh 2004-02-13 17:54:41 EST
Apparently also happens with an Intel Pro 10/100 pcmcia network card.
Comment 15 Bill Nottingham 2004-02-14 02:09:07 EST
Yeah, probably happens with anything PCMCIA. Only happens in the
loader, could be diet related.
Comment 16 Dax Kelson 2004-02-14 23:43:52 EST
On my Dell Inspiron 4150 with a builtin/internal PCMCIA wireless nic
as soon as I choose "English" I get a sig 11.

Is this the same bug?
Comment 17 Tim Waugh 2004-02-15 14:23:57 EST
Very possibly.
Comment 18 Mike Becker 2004-02-16 08:30:38 EST
FYI - tried to do a clean install of FC2T1 on my Gateway M500 laptop
however when the installation got to the point where it runs
'/sbin/loader' a signal 11 error was produced.  I then tried to
install again using 'linux apm=off acpi=off pci=noacpi' with the same
results.
Comment 19 Aaron Bennett 2004-02-17 11:20:43 EST
It also happens on a Dell C640, but not a Dell D600.  However this
isn't after "Choose English," but rather right after mediacheck --
regardless of if the mediacheck is done or skipped, the next thing you
get is a signal 11.
Comment 20 Bill Nottingham 2004-02-17 11:37:15 EST
*** Bug 115956 has been marked as a duplicate of this bug. ***
Comment 21 Aaron Bennett 2004-02-17 11:42:21 EST
Differences between the symptons I've observed and those in this bug
and in 115956:

- this bug says problem happens with "ks text" or "ks vnc"  I observe
this happening all the time, regardless of boot options

- 115956 reports this happens after "probing USB devices."  I observe
it happens right after the end of mediacheck.
Comment 22 Stephen Gerstacker 2004-02-17 11:47:02 EST
Bug #115605 seems to be a duplicate of this bug.  

I have the same symptoms on my Dell Inspiron 8200.  It occurs directly
after the media check screen on an installation cd bootup and directly
after the language selection on the boot.iso
Comment 23 Tim Waugh 2004-02-17 11:48:46 EST
Aaron: This happens for me without 'ks' too, the same as you.

The nature of this bug is that at some stage, yet unknown, the heap is
upset -- this is the bug.  Then at a later time, the symptom
(segfault) is seen.

It could be a memory scribble, or it could be an incorrectly-freed
object.  But whatever it is occurs some time before the segfault
happens. (Just by adding some printfs to the code I was able to make
the segfault happen in an entirely different place.)
Comment 24 Bill Nottingham 2004-02-17 12:12:45 EST
*** Bug 115605 has been marked as a duplicate of this bug. ***
Comment 25 Aleksey Nogin 2004-02-17 18:27:46 EST
Seing the same thing as mentioned in comment #16 - when booting Dell
Lattitude C640 (with builtin PCMCIA NIC) from the PXEboot
vmlinuz/initrd (from Feb 17th Raw Hide), I get the "signal 11" message
right after I select the language (does not matter whather I select
"English" or "Russian"). 

P.S. I am bumping the severity level since this bug makes it
impossible to install.
Comment 26 Aleksey Nogin 2004-02-17 19:34:47 EST
Re: comment #25

If I boot with the "nopcmcia" option, it does not crash (but then
network does not work :-( ).
Comment 27 Stephen Gerstacker 2004-02-17 21:33:39 EST
Using noprobe lets you continue with the install.  I had to setup the network card later, but 
it worked.
Comment 28 Aleksey Nogin 2004-02-17 21:43:58 EST
With the "noprobe" option I arrive at the following screen:

> You have multiple network devices on this system.
> Which would you like to install through?
>
>   eth - 3Com Corporation|3c905C-TX/TX-M [Tornado]
>   eth - Intersil PRISM2 11 Mbps Wireless Adepter

Note that there is no number after either "eth"! (BTW, is this a
separate bug, or another manifistation of this one?) Selecting either
of the two results in "* pump told us: SIOCSIFADDR: No such device"
being printed on the 3rd v.console and it still does not work :-(
Comment 29 Tim Waugh 2004-02-24 08:15:40 EST
I tried linking an /sbin/loader with glibc rather than dietlibc, and
getting its main() to setenv("MALLOC_CHECK_","1",1) first thing.  No
change at all.  I'd been hoping for a diagnostic message from malloc().
Comment 30 Bill Nottingham 2004-02-24 12:03:42 EST
Yes, when I tested, it only seems to happen in conjunction with diet.
Comment 31 Tim Waugh 2004-02-25 14:04:11 EST
Created attachment 98048 [details]
mtrace patch

FWIW (probably not much), I tried using mtrace() to investigate this problem
further.  The resulting trace didn't say much interesting.  But /sbin/loader
crashes much much earlier with this patch -- 'looking for usb controllers' is
the last message on VT3.
Comment 32 Bill Nottingham 2004-02-25 15:59:49 EST
Fixed in CVS.
Comment 33 Simeon Bateman 2004-03-23 12:46:51 EST
Running Dell inspiron 8100, had same error,  looked at cnt+alt+4 and
saw that it was trying to load the wireless drivers for my orinoco
wifi card.  removed card from pcmcia, and installer moves past and
starts graphical install.
Comment 34 Tim Waugh 2004-03-23 12:56:44 EST
Simeon: er, which version?  This has been fixed for a while.  I also
have one of these cards and it works fine for me with current rawhide.
 Probably something that will be fixed in test 2.
Comment 35 bjorn l. 2004-09-22 16:06:15 EDT
Same problem with FC3 test2 (FC3-test2-i386-DVD.iso).  I do not have
the problem with FC2, so I don't know if this is exactly the same
as above.  The system prints out:
  running /sbin/loader
  install exited abnormally -- received signal 11

I tried some combinations of noprobe, nopcmcia, nousbstorage, but
cannot get it to install.  Removing pcmcia cards does not help
either.  Install is from a hard drive, and the md5sum checks good,
so I don't think it's a media issue.

System is a Dell Latitude CS laptop.

Let me know if you want additional tests/info.
Comment 36 bjorn l. 2004-10-01 13:43:07 EDT
Please ignore the last comment (additional comment #35).
While the symptoms were the same, the actual cause was code
added after the previous comment (#34) date.  The new bug
is fixed and identified as bug #133996.
Comment 37 Stuned 2005-03-10 17:45:42 EST
I have a problem with this bug. I am not trying to install the "test"
version. and useing CDs instead of DVD. I have tried noprobe and
nopcmcia with no luck. What happens is, I get select lang, then
keyboard. fine so far. Then it is select install location. I select
"local CDROM" (I should point out that this I get this far if I wait
for about 2 minutes on the "running /sbin/loader" hangup). after
selecting that I get a blue screen, see some text fly by and Call
Trace: is where it would "seem" the problem is. This is what I see.

[<c030007b>] xfrm_state_lookup+0xea/0x151
Code: 00 00 89 44 24 04 b8 02 00 00 00 e8 d1 19 00 00 58 8b 04 24 85
c0 74 05 e8
7b fc ff ff 58 c3 ff 75 24 04 e8 7c ff ff ff 89 c2 58 <8b> 02 a8 01 75
09 89 d0 
e8 a7 fd ff ff 89 c2 89 d0 c3 53 31 db
install exited abnormally -- recieved signal 11

I should point out that [<c030007b>] is not the first line I see on
Call Trace:

there is about 12 before it.

And I am trying to install on a Dell CPi
Comment 38 Jeremy Katz 2006-04-24 15:02:51 EDT
Mass-closing lots of old bugs which are in MODIFIED (and thus presumed to be
fixed).  If any of these are still a problem, please reopen or file a new bug
against the release which they're occurring in so they can be properly tracked.

Note You need to log in before you can comment on or make changes to this bug.