Bug 1144452 - "Open Support Case" must support all layered products
Summary: "Open Support Case" must support all layered products
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER04
: JON 3.3.0
Assignee: Libor Zoubek
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: JON3-12
TreeView+ depends on / blocked
 
Reported: 2014-09-19 12:21 UTC by Libor Zoubek
Modified: 2015-11-02 00:44 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-12-11 14:03:40 UTC


Attachments (Terms of Use)

Description Libor Zoubek 2014-09-19 12:21:14 UTC
Description of problem:

It must be possible to open support case on server resources for bellow products:

EAP 6.x
JBossFuse - see Bug 1140637 
JBoss Fuse Service Works (SOA-P) 6.x
JDG (Enterprise Data Grid) 6.x
EDS (Data Virtualization) 6.x
BRMS / BPMS 6.x

In case given product (and version) can provide JDR report, this report must be possible to attach to case (comes as checked by default)

Version-Release number of selected component (if applicable):
JON 3.3.0.ER03

Actual results:


Expected results:


Additional info:

Comment 1 Mike Foley 2014-09-19 19:13:50 UTC
QE Work is complete.

Dependent BZs are done.

This feature is "test complete"

Comment 2 Mike Foley 2014-09-19 19:14:27 UTC
back to assigned ... comment #1 was intended for another BZ.  my mistake .

Comment 3 Libor Zoubek 2014-09-22 10:45:19 UTC
EAP 6.x - works
JBossFuse - fixed: see Bug 1140637 
JBoss Fuse Service Works (SOA-P) 6.x - works
JDG (Enterprise Data Grid) 6.x - works for standalone setup
EDS (Data Virtualization) 6.x - Bug 1144497
BRMS / BPMS 6.x - Bug 1144489


EWS - will be fixed, but there's no way to detect version (EWS = Tomcat 5/6/7) - any of tomact resources do not advertise it's EWS version. In case of EWS only product name will be provided.

JPP - will be fixed

Comment 4 Libor Zoubek 2014-09-22 10:54:06 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/4c44f5995
time:    2014-09-22 12:52:29 +0200
commit:  4c44f599522c3cbf14775e3659245f5642fd89e9
author:  Libor Zoubek - lzoubek@redhat.com
message: Bug 1144452 - "Open Support Case" must support all layered products

         Enable Opening support cases for Tomcat Server resources. We
         cannot detect EWS version from Tomcat resources, when opening a
         case on Tomcat resource only product can be selected properly.

         Properly forward Product Name and Product version to RHA for
         BRMS and Portal.

branch:  release/jon3.3.x
link:    https://github.com/rhq-project/rhq/commit/75f976625
time:    2014-09-22 12:53:16 +0200
commit:  75f976625c3085a372d6a1db1f08fce3e3fe9bd5
author:  Libor Zoubek - lzoubek@redhat.com
message: Bug 1144452 - "Open Support Case" must support all layered products
         Enable Opening support cases for Tomcat Server resources. We
         cannot detect EWS version from Tomcat resources, when opening a
         case on Tomcat resource only product can be selected properly.
         Properly forward Product Name and Product version to RHA for
         BRMS and Portal.
         (cherry picked from commit
         4c44f599522c3cbf14775e3659245f5642fd89e9) Signed-off-by: Libor
         Zoubek <lzoubek@redhat.com>

Comment 5 Simeon Pinder 2014-10-01 21:33:00 UTC
Moving to ON_QA as available for test with build:
https://brewweb.devel.redhat.com/buildinfo?buildID=388959


Note You need to log in before you can comment on or make changes to this bug.