Bug 1147931 - printing pdf results in blank pages from my Samsung ML-2160
Summary: printing pdf results in blank pages from my Samsung ML-2160
Keywords:
Status: CLOSED DUPLICATE of bug 1160132
Alias: None
Product: Fedora
Classification: Fedora
Component: urw-fonts
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-30 10:40 UTC by Marcin Juszkiewicz
Modified: 2014-11-28 14:19 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-28 14:19:13 UTC


Attachments (Terms of Use)
log of 'echo test|lpr' (17.01 KB, text/plain)
2014-09-30 10:40 UTC, Marcin Juszkiewicz
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1142817 None None None Never

Internal Links: 1142817

Description Marcin Juszkiewicz 2014-09-30 10:40:38 UTC
Created attachment 942661 [details]
log of 'echo test|lpr'

Description of problem:

As long as I try to print something other than 'cups test page' I have blank page coming from printer.

Version-Release number of selected component (if applicable):

bluez-cups.x86_64         5.23-1.fc22   
cups.x86_64               1:1.7.5-7.fc22
cups-client.x86_64        1:1.7.5-7.fc22
cups-devel.x86_64         1:1.7.5-7.fc22
cups-filesystem.noarch    1:1.7.5-7.fc22
cups-filters.x86_64       1.0.59-1.fc22 
cups-filters-libs.x86_64  1.0.59-1.fc22 
cups-libs.i686            1:1.7.5-7.fc22
cups-libs.x86_64          1:1.7.5-7.fc22
cups-pk-helper.x86_64     0.2.5-5.fc22  
gutenprint-cups.x86_64    5.2.10-8.fc22 
python-cups.x86_64        1.9.67-2.fc22 
python3-cups.x86_64       1.9.67-2.fc22 


How reproducible:

always

Steps to Reproduce:
1. echo test | lpr

or
1. open pdf in okular
2. print it

Actual results:

blank page

Expected results:

proper printout

Additional info:

cups debugging suxx. I did "cupsctl LogLevel=debug2" and one job gave me some debug and next did not.

Comment 1 Tim Waugh 2014-10-02 10:47:15 UTC
wrz 30 12:25:31 puchatek cupsd[952]: [Job 233] Error: /invalidfont in /findfont
wrz 30 12:25:31 puchatek cupsd[952]: [Job 233] Operand stack:
wrz 30 12:25:31 puchatek cupsd[952]: [Job 233] Helvetica

Looks like bug #921706.

What do these commands say?:

rpm -q urw-fonts
rpm -V urw-fonts
grep -l Nimbus /var/cache/fontconfig/*

Comment 2 Marcin Juszkiewicz 2014-10-02 11:03:20 UTC
13:02 hrw@puchatek:~$ rpm -q urw-fonts
urw-fonts-1.10-1.fc22.noarch
13:02 hrw@puchatek:~$ rpm -V urw-fonts
13:02 hrw@puchatek:~$ grep -l Nimbus /var/cache/fontconfig/*
/var/cache/fontconfig/b79f3aaa7d385a141ab53ec885cc22a8-le64.cache-4

Comment 3 Marcin Juszkiewicz 2014-10-02 11:22:21 UTC
13:20 root@puchatek:del# rpm -q ghostscript urw-fonts fontconfig
ghostscript-9.15-1.fc22.x86_64
urw-fonts-1.10-1.fc22.noarch
fontconfig-2.11.1-5.fc22.x86_64
fontconfig-2.11.1-5.fc22.i686
13:22 root@puchatek:del# gs -sDEVICE=nullpage -dBATCH -c '(Helvetica) findfont'
GPL Ghostscript 9.15 (2014-09-22)
Copyright (C) 2014 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Can't find (or can't open) font file /usr/share/ghostscript/9.15/Resource/Font/NimbusSanL-Regu.
Can't find (or can't open) font file NimbusSanL-Regu.
Can't find (or can't open) font file /usr/share/ghostscript/9.15/Resource/Font/NimbusSanL-Regu.
Can't find (or can't open) font file NimbusSanL-Regu.
Querying operating system for font files...
Can't find (or can't open) font file /usr/share/ghostscript/9.15/Resource/Font/NimbusSanL-Regu.
Can't find (or can't open) font file NimbusSanL-Regu.
Didn't find this font on the system!
Substituting font Courier for NimbusSanL-Regu.
Can't find (or can't open) font file /usr/share/ghostscript/9.15/Resource/Font/NimbusMonL-Regu.
Can't find (or can't open) font file NimbusMonL-Regu.
Can't find (or can't open) font file /usr/share/ghostscript/9.15/Resource/Font/NimbusMonL-Regu.
Can't find (or can't open) font file NimbusMonL-Regu.
Didn't find this font on the system!
Unable to substitute for font.
Error: /invalidfont in /findfont
Operand stack:
   Helvetica
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   1887   1   3   %oparray_pop
Dictionary stack:
   --dict:1179/1684(ro)(G)--   --dict:0/20(G)--   --dict:77/200(L)--
Current allocation mode is local
Last OS error: Not a directory
GPL Ghostscript 9.15: Unrecoverable error, exit code 1

Comment 4 Tim Waugh 2014-10-02 11:23:25 UTC
Thanks. And this?:

strings /var/cache/fontconfig/* | grep default/Type1

Comment 5 Marcin Juszkiewicz 2014-10-02 11:25:18 UTC
13:24 hrw@puchatek:fonts$ strings /var/cache/fontconfig/* | grep default/Type1
/usr/share/fonts/default/Type1
/usr/share/fonts/default/Type1
/usr/share/fonts/default/Type1/a010013l.pfb
/usr/share/fonts/default/Type1/a010015l.pfb
/usr/share/fonts/default/Type1/a010033l.pfb
/usr/share/fonts/default/Type1/a010035l.pfb
/usr/share/fonts/default/Type1/b018012l.pfb
/usr/share/fonts/default/Type1/b018015l.pfb
/usr/share/fonts/default/Type1/b018032l.pfb
/usr/share/fonts/default/Type1/b018035l.pfb
/usr/share/fonts/default/Type1/c059013l.pfb
/usr/share/fonts/default/Type1/c059016l.pfb
/usr/share/fonts/default/Type1/c059033l.pfb
/usr/share/fonts/default/Type1/c059036l.pfb
/usr/share/fonts/default/Type1/d050000l.pfb
/usr/share/fonts/default/Type1/n019003l.pfb
/usr/share/fonts/default/Type1/n019004l.pfb
/usr/share/fonts/default/Type1/n019023l.pfb
/usr/share/fonts/default/Type1/n019024l.pfb
/usr/share/fonts/default/Type1/n019043l.pfb
/usr/share/fonts/default/Type1/n019044l.pfb
/usr/share/fonts/default/Type1/n019063l.pfb
/usr/share/fonts/default/Type1/n019064l.pfb
/usr/share/fonts/default/Type1/n021003l.pfb
/usr/share/fonts/default/Type1/n021004l.pfb
/usr/share/fonts/default/Type1/n021023l.pfb
/usr/share/fonts/default/Type1/n021024l.pfb
/usr/share/fonts/default/Type1/n022003l.pfb
/usr/share/fonts/default/Type1/n022004l.pfb
/usr/share/fonts/default/Type1/n022023l.pfb
/usr/share/fonts/default/Type1/n022024l.pfb
/usr/share/fonts/default/Type1/p052003l.pfb
/usr/share/fonts/default/Type1/p052004l.pfb
/usr/share/fonts/default/Type1/p052023l.pfb
/usr/share/fonts/default/Type1/p052024l.pfb
/usr/share/fonts/default/Type1/s050000l.pfb
/usr/share/fonts/default/Type1/z003034l.pfb

13:25 hrw@puchatek:fonts$ fc-list "Nimbus Sans"
/usr/share/fonts/default/Type1/n019023l.pfb: Nimbus Sans:style=Italic
/usr/share/fonts/default/Type1/n019003l.pfb: Nimbus Sans:style=Regular
/usr/share/fonts/default/Type1/n019004l.pfb: Nimbus Sans:style=Bold
/usr/share/fonts/default/Type1/n019024l.pfb: Nimbus Sans:style=Bold Italic
13:25 hrw@puchatek:fonts$ fc-list "Nimbus Mono"
/usr/share/fonts/default/Type1/n022004l.pfb: Nimbus Mono:style=Bold
/usr/share/fonts/default/Type1/n022024l.pfb: Nimbus Mono:style=Bold Oblique
/usr/share/fonts/default/Type1/n022003l.pfb: Nimbus Mono:style=Regular
/usr/share/fonts/default/Type1/n022023l.pfb: Nimbus Mono:style=Oblique

Comment 6 Tim Waugh 2014-10-02 11:31:33 UTC
Ah... has the font family changed named? On Fedora 21 it's 'Nimbus Sans L':

$ fc-list "Nimbus Sans"
$ fc-list "Nimbus Sans L"
/usr/share/fonts/default/Type1/n019003l.pfb: Nimbus Sans L:style=Regular
/usr/share/fonts/default/Type1/n019023l.pfb: Nimbus Sans L:style=Regular Italic
/usr/share/fonts/default/Type1/n019024l.pfb: Nimbus Sans L:style=Bold Italic
/usr/share/fonts/default/Type1/n019004l.pfb: Nimbus Sans L:style=Bold
/usr/share/fonts/default/Type1/n019044l.pfb: Nimbus Sans L:style=Bold Condensed
/usr/share/fonts/default/Type1/n019063l.pfb: Nimbus Sans L:style=Regular Condensed Italic
/usr/share/fonts/default/Type1/n019064l.pfb: Nimbus Sans L:style=Bold Condensed Italic
/usr/share/fonts/default/Type1/n019043l.pfb: Nimbus Sans L:style=Regular Condensed
$ rpm -q urw-fonts
urw-fonts-2.4-19.fc21.noarch

If it's changed name, the references to 'Nimbus Sans L' etc in /etc/fonts/conf.d/* will also need to be updated.

Changing component to urw-fonts for further investigation by its maintainer.

Comment 7 Marcin Juszkiewicz 2014-10-02 11:33:27 UTC
13:33 hrw@puchatek:fonts$ fc-list "Nimbus Sans L"                                 
13:33 hrw@puchatek:fonts$ fc-list "Nimbus Mono L"                                 
13:33 hrw@puchatek:fonts$

Comment 8 Marcin Juszkiewicz 2014-10-02 11:47:01 UTC
13:46 hrw@puchatek:~$ rpm -q okular
okular-4.14.1-1.fc22.x86_64

Comment 9 Tom Yan 2014-10-22 08:51:21 UTC
(In reply to Tim Waugh from comment #6)
> Ah... has the font family changed named? On Fedora 21 it's 'Nimbus Sans L':
https://bugzilla.redhat.com/show_bug.cgi?id=1140865#c3
http://pkgs.fedoraproject.org/cgit/ghostscript.git/tree/ghostscript.spec#n242
> If it's changed name, the references to 'Nimbus Sans L' etc in
> /etc/fonts/conf.d/* will also need to be updated.
https://bugs.freedesktop.org/show_bug.cgi?id=85225

Comment 10 Ngo Than 2014-11-28 14:19:13 UTC

*** This bug has been marked as a duplicate of bug 1160132 ***


Note You need to log in before you can comment on or make changes to this bug.