Bug 115684 - selinux: interesting popup: "unknown user"
Summary: selinux: interesting popup: "unknown user"
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: usermode   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact:
URL:
Whiteboard:
Keywords:
: 119413 119493 120543 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-14 21:04 UTC by Kaj J. Niemi
Modified: 2013-07-02 22:58 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-21 15:47:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kaj J. Niemi 2004-02-14 21:04:50 UTC
Description of problem:
When attempting to shutdown or reboot (click the red hat, Logout,
select shutdown or reboot from popup window) it won't work. Instead a
smaller screen pops up telling me "Unknown user" and waits for the
user to click "OK" to continue. I guess this is selinux related
because it didn't happen before.

If I choose "logout" I get back to the gdm screen without any
additional popup.

Version-Release number of selected component (if applicable):
gnome-session-2.5.3-1

How reproducible:
Always

Steps to Reproduce:
1. Attempt to shutdown or reboot from menu 
2.
3.
  
Actual results:
Will shutdown the session and return to the gdm login screen. From
there I am able to shutdown/reboot as usual.

Expected results:
Should shutdown or reboot

Comment 1 Kaj J. Niemi 2004-03-03 12:49:25 UTC
I think this is actually a problem within userhelper which attempts to
change the context but fails for some reason. The component should
probably be changed.

Comment 2 Bill Nottingham 2004-03-30 20:31:18 UTC
*** Bug 119413 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2004-03-30 22:37:07 UTC
*** Bug 119493 has been marked as a duplicate of this bug. ***

Comment 4 Gabriel Friedmann 2004-03-31 21:38:33 UTC
I can verify this and add my own circumstances.

Just isntalled core2 test2. Workstation install. SELinux set to warning. 
three partitions: / /usr /home

Added user during install.
After first install reboot and post-install process I logged in as
user i created during install.  

I mucked around a bit with epiphany.  I tried to load up the RHN
taskbar icon... it don't think it popped up.

I selected 'shutdown' and waited a minute or two while nothing seemed
to be happenning.

I walked away and returned to a bare desktop (no icons, no taskbar,
yes background image) with a tiny error dialog stating "Unknown User".

Clicked 'OK' and returned to graphical logon.

Comment 5 Gerry Tool 2004-04-05 12:33:16 UTC
Same thing happens to me.  Everytime I choose reboot from the gnome
exit menu this "unknown user" box appears.  Reboot fails and I am put
back to the gdm login screen.  Reboot from there works.

Comment 6 Abe Drier 2004-04-13 01:50:28 UTC
1- I have experienced this problem when executed as a non-root user 
in GNOME.  (KDE only presents a logout option to the user)
2- Hitting the close button returns to the login screen. 
3- When logged in as root, the system shutsdown / reboots as expected.
4- This happens in enforcing mode and in permissive mode.
5- Tried to execute "init 6" from a terminal window and the response 
was "must be superuser" which seems appropriate. 
5- All updates are in place as of April 12 

Comment 7 Mark McLoughlin 2004-04-14 15:18:44 UTC
*** Bug 120543 has been marked as a duplicate of this bug. ***

Comment 8 Ling Li 2004-04-28 04:21:35 UTC
Same here as of April 27, Rawhide (the same as test3?)

Comment 9 Pontus Enhager 2004-05-29 17:33:51 UTC
I see this in FC2 after upgrade from FC1

Comment 10 Greg Douglas 2004-08-11 13:12:01 UTC
I was still getting this problem with the latest upgrades as of this 
week.

While cleaning-up various errors found in my boot log, I came across 
the following fix for a separate problem.  It has resolved the 
problem of getting an "Unknown User" message when logging off as a 
non root user.  As well, the system now shuts down correclty, instead 
of sending me to the loggin window.  this is what I added:

Created the missing file: /etc/sysconfig/selinux and added the value 
of 'SELINUX=disabled' (without the quotes).

Hope this helps.



Comment 13 Jindrich Novy 2005-02-21 15:47:54 UTC
Fixed a least since usermode-1.74 (present in FC3) and later.



Note You need to log in before you can comment on or make changes to this bug.