Bug 115917 - Tool non functionnal with kernel upgrade
Tool non functionnal with kernel upgrade
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 116356 TB63cbe611 118579 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-16 21:20 EST by Luc Lalonde
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 04:54:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system-config-network error log (974 bytes, text/plain)
2004-02-16 21:22 EST, Luc Lalonde
no flags Details

  None (edit)
Description Luc Lalonde 2004-02-16 21:20:33 EST
An upgrade to kernel 2.6.2 breaks system-config-network
(see error log)
Comment 1 Luc Lalonde 2004-02-16 21:22:52 EST
Created attachment 97720 [details]
system-config-network error log
Comment 2 Bill Nottingham 2004-02-20 10:33:06 EST
*** Bug 116356 has been marked as a duplicate of this bug. ***
Comment 3 W. Michael Petullo 2004-02-21 09:49:18 EST
Please note that bug #116356 does have a simple patch attached to it
that fixes this problem.
Comment 4 Bill Nottingham 2004-03-04 00:21:38 EST
*** Bug 117409 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 2004-03-18 01:00:00 EST
*** Bug 118579 has been marked as a duplicate of this bug. ***
Comment 6 Harald Hoyer 2004-03-18 06:08:17 EST
Should be fixed with version 1.3.16
Comment 7 Jef Spaleta 2004-05-05 22:26:48 EDT
I dont seem to be having a problem on my test3 with current devel
update packages.

kernel 2.6.5-1.350
system-config-network 1.3.16-1

the s-c-network gui comes up and lets me screw up my network settings
to my heart's content.

Comment 8 Moritz Barsnick 2004-06-07 06:57:55 EDT
Now (in 1.3.16-1), the kernel version parser chokes on versions with 
_more than_ one dash.  :-/  I'm rebuilding my system (kernel and 
special modules) just to eliminate that right now...

The first dash should be the only separation point, I guess.
Comment 9 david.hagood 2004-11-11 07:49:15 EST
Why is this closed out - I seem to be having the very same problem
with the lastest up2date (as of 2004/11/11) - my kernel has an
additional patch to support my HDTV tuner, and as such has more than
one dash.

"Fixing" the problem by requiring the user to rebuild their kernel is
NOT FIXING the problem.
Comment 10 Harald Hoyer 2004-11-11 08:46:34 EST
wowbagger@sktc.net:
Please attach or paste the traceback from system-config-network.
Comment 11 david.hagood 2004-11-13 09:36:35 EST
 up2date upgrade

...


Testing package set / solving RPM inter-dependencies...

Downloading headers to solve dependencies...
Traceback (most recent call last):#####
  File "/usr/sbin/up2date", line 1245, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 800, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1119, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 74, in run
    self.__dryRun()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 159, in
__dryRun
    self.percentCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 386, in dryRun
    ret = depsolve.solvedep()
  File "/usr/share/rhn/up2date_client/depSolver.py", line 554, in solvedep
    ret = self.process_deps(deps)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 521, in
process_deps
    changed = self.__dependencies(dependencies)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 307, in
__dependencies    msgCallback = self.msgCallback
ValueError: unpack list of wrong size
Comment 12 Harald Hoyer 2004-11-15 07:37:51 EST
wowbagger@sktc.net: please file that bug for component up2date.

Note You need to log in before you can comment on or make changes to this bug.