Bug 116016 - (XFSPROGS) no xfsdump rpm included in distribution
(XFSPROGS) no xfsdump rpm included in distribution
Status: CLOSED DUPLICATE of bug 201779
Product: Fedora
Classification: Fedora
Component: xfsprogs (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
: 133695 189478 (view as bug list)
Depends On: 66513
  Show dependency treegraph
Reported: 2004-02-17 12:30 EST by Nate Pearlstein
Modified: 2013-07-02 22:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-06 12:29:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
condtionilze the need for dmapi in xfsdump (6.38 KB, patch)
2006-08-04 12:51 EDT, Russell Cattelan
no flags Details | Diff

  None (edit)
Description Nate Pearlstein 2004-02-17 12:30:24 EST
Description of problem:

No xfsdump rpm included with the release.  xfsprogs does not contain

Version-Release number of selected component (if applicable): test1

How reproducible: N/A

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Eric Sandeen 2004-02-17 12:36:07 EST
xfsprogs can be found at ftp://oss.sgi.com/projects/xfs/
under cmd_tars & cmd_rpms
Comment 2 Nate Pearlstein 2004-06-14 13:37:13 EDT
xfsrestore should be added as well
Comment 3 Bernhard Erdmann 2004-09-26 13:55:04 EDT
xfsrestore is included by the xfsdump RPM
Comment 4 Colin Charles 2005-04-07 01:50:07 EDT
*** Bug 133695 has been marked as a duplicate of this bug. ***
Comment 5 Marcin Garski 2006-06-01 18:03:28 EDT
*** Bug 189478 has been marked as a duplicate of this bug. ***
Comment 6 Eric Sandeen 2006-08-03 14:34:39 EDT
xfsdump currently relies on dmapi, which is somewhat pointless in a FC distro,
since there is no kernel support.  Russell is looking into making an xfsdump
which does not have a hard dependency on dmapi...
Comment 7 Russell Cattelan 2006-08-04 12:51:29 EDT
Created attachment 133648 [details]
condtionilze the need for dmapi in xfsdump
Comment 8 Russell Cattelan 2006-08-04 12:59:45 EDT
I have submitted the above patch upstream.

I have also got the start of the spec file and Make file for the cvs
Comment 9 Marcin Garski 2006-08-23 09:38:55 EDT
xfsdump-2.2.42 has been released which probably incorporate your patches.
From changelog:
- Rework code to remove the DMAPI build and run-time dependency.

Should I provide spec file, or maybe you have already made it?
Comment 10 Russell Cattelan 2006-08-23 12:57:55 EDT
Ahh cool I've been waiting for Nathan to push that tarball.

Spec file and src rpm updated
Comment 11 Russell Cattelan 2006-08-24 12:53:04 EDT

I'll maintain xfsdump.src.rpm as a link to the latest.
Comment 12 Marcin Garski 2006-08-31 19:59:27 EDT
Is there any plans including xfsdump in FC, if not it's a good candidate for FE?
Comment 13 Russell Cattelan 2006-09-06 12:29:54 EDT

*** This bug has been marked as a duplicate of 201779 ***

Note You need to log in before you can comment on or make changes to this bug.