Bug 116092 - PS2 mouse /dev/psaux open fails in kernel 2.6.2-1.85smp
PS2 mouse /dev/psaux open fails in kernel 2.6.2-1.85smp
Status: CLOSED DUPLICATE of bug 116118
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-18 00:37 EST by Bob Arendt
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Arendt 2004-02-18 00:37:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040115 Epiphany/1.0.7

Description of problem:
My first symptom after reboot was that XFree86 wouldn't start
(normally start at run-level 5).  The XFree log indicated a
mouse problem (see Additional Info below).

I rebooted, starting at run-level 1, and manually tried to start gpm.
It failed, stating it couldn't open the mouse (see Add. Info below).

Booting to a previous kernel-smp-2.6.2-1.81, and gpm succeeds,
and XFree86 works (normally I have gpm disabled).

The Xserver/desktop is unusable without the mouse.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.2-1.85

How reproducible:
Always

Steps to Reproduce:
Mouse fails on every boot

Actual Results:  critical programs (gpm, XFree86) fail

Expected Results:  critical programs (gpm, XFree86) work

Additional info:

My first symptom after reboot was that XFree86 wouldn't start
(normally start at run-level 5)

/var/log/XFree86.0.log indicated:
(**) Option "Protocol" "IMPS/2"
(**) Mouse0: Protocol: "IMPS/2"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/psaux"
(EE) xf86OpenSerial: Cannot open device /dev/psaux
        No such device.
(EE) Mouse0: cannot open input device
(EE) PreInit failed for input device "Mouse0"

OK - looks more basic than XFree86, let's reboot, starting in
run-level 1, and try to start gpm ....... here's what happened:

------------------------------------------------
Script started on Tue Feb 17 22:09:22 2004
sh-2.05b# gpm -m /dev/psaux -t imps2
(.. also tried "-t ms3" , same result)
sh-2.05b# O0o.oops(): [gpm.c(937)]: Could not open /dev/psaux.

sh-2.05b# ls -l /dev/psaux
crw-------  1 root root 10, 1 Jan 21 09:12 /dev/psaux
sh-2.05b# cat /proc/devices 
Character devices:
  1 mem
  2 pty
  3 ttyp
  4 /dev/vc/0
  4 tty
  4 ttyS
  5 /dev/tty
  5 /dev/console
  5 /dev/ptmx
  7 vcs
 10 misc
 13 input
 29 fb
 36 netlink
128 ptm
136 pts
180 usb

Block devices:
  1 ramdisk
  3 ide0
  9 md
 22 ide1
sh-2.05b# exit
------------------------------------------------

I was root, root had R/W, the device (10) shows in /proc/devices,
yet has problems ...

This works without problem in FC1 test kernels:
kernel-smp-2.6.1-1.61
kernel-smp-2.6.1-1.65
kernel-smp-2.6.2-1.79
kernel-smp-2.6.2-1.81

This is on a Asus P4P800 M/B (865PE + ICH5), 3.0G P4

The mouse is a IMPS2 compatible made by Mitsuko.

I'd be happy to supply any other info.
Comment 1 Thomas M Steenholdt 2004-02-18 01:48:05 EST
See bug 116033 for information!

What I did su successfully configure me out of this problem was:
in /etc/X11/XF86Config - Section ServerLayout (Default Layout)
I changed the InputDevice "Mouse0" "CorePointer" line to read
InputDevice "DevInputMice" "CorePointer"

That did it for X

for GPM, edit /etc/sysconfig/mouse and change device line to
/dev/input/mice
Comment 2 Thomas M Steenholdt 2004-02-18 01:50:48 EST
I'm unsure if we should file bugs against the X and gpm components or
perhaps kudzu in order to make sure these configurations get set
correctly. This is something that has changed from from test1 released
kernel to 2.6.2-1.85 so tools should be updated to reflect this change!

Please advise!
Comment 3 Arjan van de Ven 2004-02-18 03:04:28 EST
The tools updates are in progress.
Rawhide isn't always 100% coherent, sometimes it breaks for a day or so.
Comment 4 Bob Arendt 2004-02-18 11:48:04 EST
Using /dev/input/mice doesn't work on earlier FC1 2.4.22-1.2166.nptl,
and /dev/psaux does.  No usb devices on this system, just a ps2
keyboard and ps2 mouse.  At what FC1/2 kernel version should the
/dev/input/mice scheme work for PS2 mice?  (I still have to try this
on my home system, updated to "Flaming Death").  As an aside .. what
should I have read to know of the change?  I didn't see anything on
the fedora-devel list, and /usr/src/linux-2.6.2-1.87/Documentation
documents *both* input devices, and it doesn't seem to indicate that
use of /dev/psaux has been deprecated.
Comment 5 Bob Arendt 2004-02-18 12:00:38 EST
Oh - I see it now - in the middle of fedora devel message:
"rawhide report: 20040217 changes"
     - disable psaux emulation.
A little oblique ...  but it's RawHide!  I'll test the home system
tonight, and most likely mark it closed if /dev/input/mice works.
Comment 6 Bob Arendt 2004-02-18 22:33:01 EST
Yes - verified using /dev/input/mice works
Thanks!
Comment 7 Dave Jones 2004-02-19 19:49:14 EST
*** Bug 116306 has been marked as a duplicate of this bug. ***
Comment 8 David Juran 2004-02-22 11:40:33 EST
I realize this bug has been closed, but wouldn't it help to bump the
version of kudzu the kernel conflicts to something that is aware of
the new location of the mice devices?
Comment 9 Dave Jones 2004-02-23 07:42:12 EST
*** Bug 116550 has been marked as a duplicate of this bug. ***
Comment 10 Miloslav Trmac 2004-03-04 09:09:42 EST
*** Bug 117479 has been marked as a duplicate of this bug. ***
Comment 11 Mike A. Harris 2004-03-29 16:35:40 EST
Reclosing as duplicate of master dupe, bug alias "mouse-psaux"

*** This bug has been marked as a duplicate of 116118 ***
Comment 12 Red Hat Bugzilla 2006-02-21 14:01:23 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.