Bug 1181283 - error when changing fqdn and updating certs [NEEDINFO]
Summary: error when changing fqdn and updating certs
Status: CLOSED DUPLICATE of bug 1152797
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
(Show other bugs)
Version: 6.0.6
Hardware: All Linux
unspecified
high vote
Target Milestone: GA
Assignee: Chris Roberts
QA Contact: Katello QA List
URL:
Whiteboard:
Keywords: ReleaseNotes, Triaged
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-01-12 19:31 UTC by Chris Roberts
Modified: 2018-08-31 15:20 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-29 14:12:35 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
bkearney: needinfo? (mmccune)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 924383 None None None Never
Red Hat Bugzilla 1152797 None None None Never
Red Hat Knowledge Base (Solution) 1232133 None None None Never
Red Hat Knowledge Base (Solution) 2263671 None None None 2016-06-24 08:06 UTC

Description Chris Roberts 2015-01-12 19:31:50 UTC
Description of problem:
When changing the fqdn of a satellite 6 system and following the docs listed here, we get the following error:

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.0/html/User_Guide/sect-Troubleshooting.html#idp27144192

http://fpaste.org/168765/14210892/

Version-Release number of selected component (if applicable):


Installed Packages

    candlepin-0.9.23.1-1.el7.noarch
    candlepin-common-1.0.1-1.el7.noarch
    candlepin-guice-3.0-2_redhat_1.el7.noarch
    candlepin-scl-1-5.el7.noarch
    candlepin-scl-quartz-2.1.5-6.el7.noarch
    candlepin-scl-rhino-1.7R3-3.el7.noarch
    candlepin-scl-runtime-1-5.el7.noarch
    candlepin-selinux-0.9.23.1-1.el7.noarch
    candlepin-tomcat-0.9.23.1-1.el7.noarch
    elasticsearch-0.90.10-6.el7sat.noarch
    katello-1.5.0-30.el7sat.noarch
    katello-certs-tools-1.5.6-1.el7sat.noarch
    katello-default-ca-1.0-1.noarch
    katello-installer-0.0.64-1.el7sat.noarch
    katello-server-ca-1.0-1.noarch
    pulp-admin-client-2.4.3-1.el7sat.noarch
    pulp-katello-0.3-4.el7sat.noarch
    pulp-nodes-common-2.4.3-0.1.beta.el7sat.noarch
    pulp-nodes-parent-2.4.3-0.1.beta.el7sat.noarch
    pulp-puppet-plugins-2.4.3-1.el7sat.noarch
    pulp-puppet-tools-2.4.3-1.el7sat.noarch
    pulp-rpm-admin-extensions-2.4.3-1.el7sat.noarch
    pulp-rpm-plugins-2.4.3-1.el7sat.noarch
    pulp-selinux-2.4.3-1.el7sat.noarch
    pulp-server-2.4.3-1.el7sat.noarch
    python-gofer-qpid-1.3.0-1.el7sat.noarch
    python-isodate-0.5.0-1.pulp.el7sat.noarch
    python-kombu-3.0.15-12.pulp.el7sat.noarch
    python-pulp-bindings-2.4.3-1.el7sat.noarch
    python-pulp-client-lib-2.4.3-1.el7sat.noarch
    python-pulp-common-2.4.3-1.el7sat.noarch
    python-pulp-puppet-common-2.4.3-1.el7sat.noarch
    python-pulp-rpm-common-2.4.3-1.el7sat.noarch
    python-qpid-0.22-15.el7.noarch
    python-qpid-qmf-0.22-37.el7.x86_64
    qpid-cpp-client-0.22-42.el7.x86_64
    qpid-cpp-server-0.22-42.el7.x86_64
    qpid-cpp-server-linearstore-0.22-42.el7.x86_64
    qpid-java-client-0.22-7.el7.noarch
    qpid-java-common-0.22-7.el7.noarch
    qpid-proton-c-0.7-2.el7.x86_64
    qpid-qmf-0.22-37.el7.x86_64
    qpid-tools-0.22-13.el7.noarch
    ruby193-rubygem-katello-1.5.0-93.el7sat.noarch
    rubygem-hammer_cli_katello-0.0.4-14.el7sat.noarch
    rubygem-smart_proxy_pulp-1.0.1-1.1.el7sat.noarch
    satellite1.released-el7.satellite.lab.eng.rdu2.redhat.com-qpid-broker-1.0-1.noarch
    satellite1.released-el7.satellite.lab.eng.rdu2.redhat.com-qpid-client-cert-1.0-1.noarch

How reproducible:


Steps to Reproduce:
1. change hostname in /etc/sysconfig/network and /etc/hosts
2. follow docs listed here https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.0/html/User_Guide/sect-Troubleshooting.html#idp27144192
3. error

Actual results:
http://fpaste.org/168765/14210892/

Expected results:
it to update certs

Additional info:

Comment 1 RHEL Product and Program Management 2015-01-12 19:54:19 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Xixi 2015-03-19 21:02:44 UTC
Related: 

Bug 1152797 [RFE] Provide Documentation to update Satellite FQDN and associated certificates (rename a Satellite)

Bug 924383 "[RFE] Need a server side tool to assist with the process of changing  the hostname of the Katello server" for a tool, use kbase in meantime  and add to docs 

https://access.redhat.com/solutions/1232133 "How to change hostname of a Red Hat Satellite 6 Server and update associated SSL certificates?"

Comment 11 Mike McCune 2015-11-04 23:56:20 UTC
Changing hostnames is currently not supported.

See:

https://bugzilla.redhat.com/show_bug.cgi?id=1152797#c21

and

https://access.redhat.com/solutions/1315853

Comment 12 Mike McCune 2015-11-05 00:53:56 UTC
The more relevant/correct KCS is:

https://access.redhat.com/solutions/1232133

Comment 15 David O'Brien 2016-04-18 00:48:32 UTC
Reset docs contact <> daobrien

Comment 18 Bryan Kearney 2016-07-08 20:18:37 UTC
Per 6.3 planning, moving out non acked bugs to the backlog

Comment 20 Stephen Benjamin 2016-07-29 14:12:35 UTC

*** This bug has been marked as a duplicate of bug 1152797 ***


Note You need to log in before you can comment on or make changes to this bug.