Bug 120494 - wrong fonts are used on GUI
wrong fonts are used on GUI
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
: i18n
: 122216 123297 128134 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-09 08:34 EDT by Akira TAGOH
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-21 21:25:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a screenshot when OOo is ran normally (92.43 KB, image/png)
2004-04-09 08:36 EDT, Akira TAGOH
no flags Details
a screenshot, which should be shown(the applications font has been changed to Kochi Gothic) (71.99 KB, image/png)
2004-04-09 08:39 EDT, Akira TAGOH
no flags Details
Screenshot of oowriter in the zh_TW locale (82.75 KB, image/png)
2004-05-19 21:05 EDT, Lawrence Lim
no flags Details

  None (edit)
Description Akira TAGOH 2004-04-09 08:34:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.4.1)
Gecko/20031114

Description of problem:
OOo 1.1.1 has shown Japanese characters with Anti-Aliased font. it's
really great. but some glyphs on GUI such as the menu and the dialog
etc etc are missing so that OOo selects the wrong fonts to show the
characters. it looks to me OOo is using Korean fonts to show Japanese.
in fact when I removed ttfonts-ko package, OOo doesn't show Japanese
anymore even if ttfonts-ja has been installed, and other xft-enabled
applications show Japanese correctly.
However when I change the applications font on gnome-font-properties
from Sans to Kochi Gothic say, OOo can show Japanese properly without
missing glyphs.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.1-2

How reproducible:
Always

Steps to Reproduce:
1.run oocalc on LANG=ja_JP.UTF-8
2.
3.
    

Actual Results:  it looks like some glyphs are missing on the menu.

Expected Results:  the menu should be shown correctly

Additional info:

this problem happened on even rawhide tree. and I have tried this on
20040407 and 20040408.
Comment 1 Akira TAGOH 2004-04-09 08:36:24 EDT
Created attachment 99263 [details]
a screenshot when OOo is ran normally
Comment 2 Akira TAGOH 2004-04-09 08:39:47 EDT
Created attachment 99264 [details]
a screenshot, which should be shown(the applications font has been changed to Kochi Gothic)
Comment 3 Akira TAGOH 2004-05-16 22:19:48 EDT
*** Bug 123297 has been marked as a duplicate of this bug. ***
Comment 4 Akira TAGOH 2004-05-17 06:13:28 EDT
*** Bug 122216 has been marked as a duplicate of this bug. ***
Comment 5 Lawrence Lim 2004-05-19 20:57:30 EDT
Same problem for the zh_* locale as well. 
Comment 6 Lawrence Lim 2004-05-19 21:05:48 EDT
Created attachment 100362 [details]
Screenshot of oowriter in the zh_TW locale
Comment 7 Dan Williams 2004-05-25 09:49:34 EDT
Can you test with 1.1.1-5?  It has fixes specifically for UI font in
non-English languages.
Comment 8 Leon Ho 2004-05-26 04:03:09 EDT
All CJK have got the correct UI fonts in 1.1.1-5 now! Thanks! However
Japanese font is revented to use bitmap again.
Comment 9 Akira TAGOH 2004-06-01 01:53:18 EDT
Dan, 1.1.1-5 looks better for CJK people, even if OOo uses the bitmap
font again for Japanese. so could you push 1.1.1-5 for FC2 updates?
Comment 10 Akira TAGOH 2004-08-06 03:33:40 EDT
*** Bug 128134 has been marked as a duplicate of this bug. ***
Comment 11 Dan Williams 2004-09-25 16:39:47 EDT
I plan on building 1.1.2-5 for FC2, yes.
Comment 12 Leon Ho 2004-10-21 21:25:51 EDT
Saw 1.1.2-10 in fc2 updates. Thanks Dan. Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.