Bug 1208780 - [RFE]Provide a way through the Hosted-engine TUI to run necessary hosted-engine shell commands.
Summary: [RFE]Provide a way through the Hosted-engine TUI to run necessary hosted-engi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-hosted-engine
Version: 3.5.1
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Ryan Barry
QA Contact: Huijuan Zhao
URL:
Whiteboard:
: 1151342 1151393 (view as bug list)
Depends On: 1260470 1276352
Blocks: 1059435 rhevh-7.0 1250199
TreeView+ depends on / blocked
 
Reported: 2015-04-03 07:40 UTC by Ying Cui
Modified: 2016-03-09 14:21 UTC (History)
13 users (show)

Fixed In Version: ovirt-node-plugin-hosted-engine-0.3.0-1.el7ev
Doc Type: Enhancement
Doc Text:
Users can now perform maintenance tasks on a RHEV-H self-hosted engine through the text user interface (TUI) without entering the rescue shell.
Clone Of:
Environment:
Last Closed: 2016-03-09 14:21:25 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
deploy HE (22.31 KB, image/png)
2015-10-09 03:29 UTC, Huijuan Zhao
no flags Details
new layout (113.81 KB, image/png)
2015-10-09 04:51 UTC, Ryan Barry
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 40897 master MERGED Add a way to run commands from the HE page Never

Description Ying Cui 2015-04-03 07:40:05 UTC
Description:
Currently rhevh do not support to let end-user drop to shell to run commands, but if running hosted-engine, some commands must to execute or execute frequently.
These cmd we have to F2 drop to shell to run.

We'd better to provide a TUI way to run them rather than let end-user F2 drop to shell directly to run them. 

Such as:
1. # screen -r -d
2. # hosted-engine --set-maintenance --mode=global
3. # hosted-engine --set-maintenance --mode=none
4. # hosted-engine --vm-start
5. # hosted-engine --vm-status

Comment 1 Doron Fediuck 2015-04-13 13:46:07 UTC
What we're going to support is the following functionalities:

1. Show HE status
This will have a button in the TUI similar to CPU info button.
Pressing it will show the output of the command.

2. Maintenance commands
a. Checkbox for global (VM) maintenance. Pressing it will show the output of the command.
b. Checkbox for local (host) maintenance. Pressing it will show the output of the command.

c. A button for resuming from maintenance.

Comment 2 Yaniv Lavi 2015-04-13 13:54:46 UTC
*** Bug 1151342 has been marked as a duplicate of this bug. ***

Comment 3 Yaniv Lavi 2015-04-13 13:57:46 UTC
*** Bug 1151393 has been marked as a duplicate of this bug. ***

Comment 4 Huijuan Zhao 2015-10-09 03:28:03 UTC
As Bug 1267437 block this issue verify, I have to verify this issue after Bug 1267437 fix.

Ryan Barry, Doron Fediuck, for this new feature, is there some buttons on Hosted Engine TUI like the screenshot in attachment(deploy HE)? And the buttons appear all the time or just appear after deploy Hosted Engine? Thanks.

Comment 5 Huijuan Zhao 2015-10-09 03:29:00 UTC
Created attachment 1081176 [details]
deploy HE

Comment 6 Ryan Barry 2015-10-09 04:51:15 UTC
Created attachment 1081179 [details]
new layout

If the engine is configured, the buttons (and engine status) will appear.

Example (from an unconfigured engine with the variables set) is attached.

Comment 8 Huijuan Zhao 2015-10-29 12:45:15 UTC
The issue verify is blocked by HE bug:
TUI Hosted Engine display is "Not configured" but HE already deployed on RHEV-H.

I will update bug ID tomorrow.

Comment 9 Huijuan Zhao 2015-11-11 05:34:19 UTC
The issue is fixed according Comment 1 on rhev-hypervisor-7-7.2-20151104.0.

Test version:
ovirt-node-plugin-hosted-engine-0.3.0-2.el7ev.noarch
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20151104.0.el7ev)


Test Steps:
1. RHEV-H installed successful.
2. Login RHEV-H, change to Hosted Engine page, Deploy Hosted Engine.
3. Check Hosted Engine page.

Test Results:
After step3, there is < Hosted Engine VM status > and < Set Hosted Engine maintenance > on Hosted Engine page.

So I will change the status to VERIFIED.

Comment 11 errata-xmlrpc 2016-03-09 14:21:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.