Bug 1276352 - TUI Hosted Engine always display "Not configured" but HE already deployed on RHEV-H
Summary: TUI Hosted Engine always display "Not configured" but HE already deployed on...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-hosted-engine
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-3.6.0-rc3
: 3.6.0
Assignee: Ryan Barry
QA Contact: Ying Cui
URL:
Whiteboard:
Depends On:
Blocks: 1208780
TreeView+ depends on / blocked
 
Reported: 2015-10-29 14:12 UTC by Ying Cui
Modified: 2016-03-09 14:42 UTC (History)
6 users (show)

Fixed In Version: ovirt-node-plugin-hosted-engine-0.3.0-2.el7ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 14:42:11 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 47675 None None None Never
oVirt gerrit 48021 ovirt-3.6 MERGED vm.conf doesn't exist on 3.6, read from hosted-engine.conf Never

Description Ying Cui 2015-10-29 14:12:48 UTC
Description of problem:
Deploy HE successful on rhevm-appliance ova, rhevh is UP on engine yet. But navigate to RHEV-H TUI Hosted Engine, here still display "Not configured".


Version-Release number of selected component (if applicable):
# rpm -qa ovirt-node ovirt-node-plugin-hosted-engine ovirt-hosted-engine-setup ovirt-hosted-engine-ha vdsm
ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch
ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev.noarch
ovirt-hosted-engine-ha-1.3.1-1.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-1.el7ev.noarch
vdsm-4.17.10-5.el7ev.noarch

# cat /etc/redhat-release
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20151025.0.el7ev)

rhevm-appliance-20151014.1-1.x86_64.rhevm.ova


How reproducible:
100%


Steps to Reproduce:
1. Clean installed RHEV-H 7.2 20151025.0 successful.
2. RHEV-H TUI Setup network via dhcp.
3. Set root password for rhevh.
4. Navigate to "Hosted Engine" TUI.
5. Deploy Hosted Engine
6. Set URL on "Engine ISO/OVA URL for download"
7. Click on "Deploy"
8. hosted-engine deployment process start and deployed on RHEV-H one by one steps( Not engine setup automatically because of bug 1274143).
9. RHEV-H is UP on HE-VM
10. Check Hosted Engine TUI on RHEV-H

Actual results:
After step10, in rescue shell show engine is up, but TUI Hosted Engine display is "Not configured". Detailed information refer to attachment, "rescue shell" and "TUI".

Expected results:
After step10, TUI Hosted Engine should display HE has been configured.

Comment 1 Ying Cui 2015-10-29 14:26:18 UTC
# hosted-engine --check-liveliness
Hosted Engine is up!
# hosted-engine --vm-status


--== Host 1 status ==--

Status up-to-date                  : True
Hostname                           : dhcp-8-107.nay.redhat.com
Host ID                            : 1
Engine status                      : {"health": "good", "vm": "up", "detail": "up"}
Score                              : 3400
stopped                            : False
Local maintenance                  : False
crc32                              : c8acbb8e
Host timestamp                     : 11258

Comment 4 Red Hat Bugzilla Rules Engine 2015-10-29 23:18:35 UTC
Fixed bug tickets must have target milestone set prior to fixing them. Please set the correct milestone and move the bugs back to the previous status after this is corrected.

Comment 5 Ying Cui 2015-11-03 08:20:28 UTC
This bug block one node RFE Bug 1208780.

Comment 8 Ying Cui 2015-11-11 03:58:27 UTC
Verified this bug on the following version, but need to report a new medium bug(To see the Hosted Engine TUI as configured after HE deployment, we need to logoff firstly to restart the TUI, otherwise the TUI still display as "not configured")

Version:
# rpm -qa ovirt-node ovirt-hosted-engine-setup ovirt-hosted-engine-ha ovirt-node-plugin-hosted-engine vdsm
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch
ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch
ovirt-hosted-engine-ha-1.3.2.1-1.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-2.el7ev.noarch
vdsm-4.17.10.1-0.el7ev.noarch
# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20151104.0.el7ev)

Test Steps:
1. Clean installed RHEV-H 7.2 successful.
2. RHEV-H TUI Setup network via dhcp.
3. Navigate to "Hosted Engine" TUI.
5. Deploy Hosted Engine
6. Set URL on "Engine ISO/OVA URL for download"
7. Click on "Deploy"
8. RHEV-H is UP on HE-VM
10. logoff RHEV-H TUI firstly
11. Recheck Hosted Engine TUI. here display Hosted Engine: Configured

# hosted-engine --check-liveliness
Hosted Engine is up!

# hosted-engine --vm-status

--== Host 1 status ==--

Status up-to-date                  : True
Hostname                           : dhcp-8-107.nay.redhat.com
Host ID                            : 1
Engine status                      : {"health": "good", "vm": "up", "detail": "up"}
Score                              : 3400
stopped                            : False
Local maintenance                  : False
crc32                              : 9cd506c4
Host timestamp                     : 159749

Comment 9 Ying Cui 2015-11-12 03:37:17 UTC
(In reply to Ying Cui from comment #8)
> Verified this bug on the following version, but need to report a new medium
> bug(To see the Hosted Engine TUI as configured after HE deployment, we need
> to logoff firstly to restart the TUI, otherwise the TUI still display as
> "not configured")

Bug 1280185 - It should not restart the TUI to check Hosted Engine status after HE deployed yet

Comment 11 errata-xmlrpc 2016-03-09 14:42:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.