Bug 1220050 - Data Tiering:UI:when a user looks for detach-tier help, instead command seems to be getting executed
Summary: Data Tiering:UI:when a user looks for detach-tier help, instead command seems...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.0
Hardware: Unspecified
OS: Linux
urgent
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact: bugs@gluster.org
URL:
Whiteboard: TIERING
Depends On: 1211570
Blocks: qe_tracker_everglades glusterfs-tiering-supportability 1229269 1260923 1273726 1274411
TreeView+ depends on / blocked
 
Reported: 2015-05-09 12:56 UTC by Mohammed Rafi KC
Modified: 2015-10-30 17:32 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1211570
Environment:
Last Closed: 2015-05-15 17:16:18 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohammed Rafi KC 2015-05-09 12:56:44 UTC
+++ This bug was initially created as a clone of Bug #1211570 +++

Description of problem:
======================
When a user wants to see detach-tier command help, instead of showing the usage or how to execute, the command seems to be executing

Eg:
[root@yarrow ~]# gluster v detach-tier
Volume detach-tier failed


It should rather behave like how it is for a attach-tier

[root@yarrow ~]# gluster v attach-tier
Usage: volume attach-tier <VOLNAME> [<replica COUNT>] <NEW-BRICK>...



Version-Release number of selected component (if applicable):
============================================================
[root@yarrow ~]# gluster --version
glusterfs 3.7dev built on Apr  8 2015 17:57:45
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.
[root@yarrow ~]# rpm -qa|grep gluster
glusterfs-cli-3.7dev-0.994.gitf522001.el6.x86_64
glusterfs-server-3.7dev-0.994.gitf522001.el6.x86_64
glusterfs-libs-3.7dev-0.994.gitf522001.el6.x86_64
glusterfs-fuse-3.7dev-0.994.gitf522001.el6.x86_64
glusterfs-3.7dev-0.994.gitf522001.el6.x86_64
glusterfs-api-3.7dev-0.994.gitf522001.el6.x86_64



How reproducible:
=================
always and easily


Steps to Reproduce:
==================
1.just issue a "Gluster v detach-tier" command and it will say detach-tier failed rather than showing the usage.

Expected results:
================
Show the usage as below :
[root@yarrow ~]#gluster v detach-tier
Usage:volume detach-tier <VOLNAME> - detach tier from volume <VOLNAME>

--- Additional comment from Mohammed Rafi KC on 2015-04-23 07:18:53 EDT ---

upstream patch : http://review.gluster.org/#/c/10303/

--- Additional comment from Anand Avati on 2015-04-27 03:11:25 EDT ---

REVIEW: http://review.gluster.org/10303 (cli/tiering : Parse detach-tier command properly) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Anand Avati on 2015-04-30 09:54:46 EDT ---

COMMIT: http://review.gluster.org/10303 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 508eb854f3f94f52d4ebd050f3e45deb9cfa90c8
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Mon Apr 27 12:33:06 2015 +0530

    cli/tiering : Parse detach-tier command properly
    
    gluster detach-tier help should show the usage of
    detach-tier command properly.
    
    Also, instead of force option, if any other was given,
    then the command should fail with a usage message
    
    Change-Id: Ie801529176db067c98fd1bfada056cbc647973fb
    BUG: 1211570
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/10303
    Tested-by: NetBSD Build System
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>

Comment 1 Anand Avati 2015-05-09 17:13:11 UTC
COMMIT: http://review.gluster.org/10709 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit 63e472fe49a4d13335c59bd6258010f594c7146a
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Mon Apr 27 12:33:06 2015 +0530

    cli/tiering : Parse detach-tier command properly
    
            Back port of http://review.gluster.org/10303
    
    gluster detach-tier help should show the usage of
    detach-tier command properly.
    
    Also, instead of force option, if any other was given,
    then the command should fail with a usage message
    
    >Change-Id: Ie801529176db067c98fd1bfada056cbc647973fb
    >BUG: 1211570
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/10303
    >Tested-by: NetBSD Build System
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    >Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    
    Change-Id: I51ef7c3450c219b2b24724592270461570436010
    BUG: 1220050
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/10709
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 2 Niels de Vos 2015-05-15 17:16:18 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.