Bug 1221957 (glusterfs-tiering-supportability) - Fully support data-tiering in 3.7.x, remove out of 'experimental' status
Summary: Fully support data-tiering in 3.7.x, remove out of 'experimental' status
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: glusterfs-tiering-supportability
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: hari gowtham
QA Contact: bugs@gluster.org
URL:
Whiteboard:
: 905747 (view as bug list)
Depends On: 1219513 1219842 1219848 1219850 1220047 1220050 1220051 1221476 1221534 1221967 1221969 1224144 1227188
Blocks: 1229269 1273726 1274411 glusterfs-3.7.6
TreeView+ depends on / blocked
 
Reported: 2015-05-15 10:40 UTC by Niels de Vos
Modified: 2015-11-17 05:57 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.7.6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1229269 1273726 (view as bug list)
Environment:
Last Closed: 2015-11-17 05:57:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2015-05-15 10:40:01 UTC
GlusterFS 3.7.0 has marked data-tiering as an 'experimental' feature. Basic functionality for data-tiering is available, but with many restrictions and known issues.

This bug tracks the improvements made to tiering. Bug reports to improve tiering in the 3.7 release should have 'glusterfs-tiering-supportability' in the 'blocks' field.

Comment 1 Niels de Vos 2015-05-15 12:52:09 UTC
*** Bug 905747 has been marked as a duplicate of this bug. ***

Comment 2 Niels de Vos 2015-06-02 08:20:19 UTC
The required changes to fix this bug have not made it into glusterfs-3.7.1. This bug is now getting tracked for glusterfs-3.7.2.

Comment 3 Niels de Vos 2015-06-20 10:08:21 UTC
Unfortunately glusterfs-3.7.2 did not contain a code change that was associated with this bug report. This bug is now proposed to be a blocker for glusterfs-3.7.3.

Comment 4 Kaushal 2015-07-30 13:17:47 UTC
This bug could not be fixed in time for glusterfs-3.7.3. This is now being tracked for being fixed in glusterfs-3.7.4.

Comment 5 Vivek Agarwal 2015-10-21 16:31:22 UTC
http://review.gluster.org/12407

Comment 6 Vijay Bellur 2015-10-22 06:07:22 UTC
REVIEW: http://review.gluster.org/12412 (Tier/cli: removing warning message for tiering) posted (#1) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)

Comment 7 Vijay Bellur 2015-10-22 13:49:51 UTC
COMMIT: http://review.gluster.org/12412 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 89a68feb5261de2238e7a23fece74e2f19220334
Author: hari gowtham <hgowtham@redhat.com>
Date:   Wed Oct 21 12:12:09 2015 +0530

    Tier/cli: removing warning message for tiering
    
            back-port of :http://review.gluster.org/#/c/12407/
    
    The warning message for tiering being under experimental staus is removed.
    
    >Change-Id: I7d1d535d380b672c70f03ecc0d24a113600ea43f
    >BUG: 1273726
    >Signed-off-by: hari gowtham <hgowtham@redhat.com>
    >Reviewed-on: http://review.gluster.org/12407
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    >Tested-by: Dan Lambright <dlambrig@redhat.com>
    
    Change-Id: I957c4fd557908586183fefadd448b76391b4911a
    BUG: 1221957
    Signed-off-by: Hari Gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/12412
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>

Comment 8 Kaushal 2015-10-28 12:28:35 UTC
This bug could not be fixed in time for glusterfs-3.7.4 or glusterfs-3.7.5. This is now being tracked for being fixed in glusterfs-3.7.6.

Comment 9 Raghavendra Talur 2015-11-17 05:57:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.6, please open a new bug report.

glusterfs-3.7.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-November/024359.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.