Bug 1273726 - Fully support data-tiering in 3.7.x, remove out of 'experimental' status
Fully support data-tiering in 3.7.x, remove out of 'experimental' status
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
: Tracking
Depends On: 1227188 1219513 1219842 1219848 1219850 1220047 1220050 1220051 1221476 1221534 glusterfs-tiering-supportability 1221967 1221969 1224144
Blocks: 1229269 1274411
  Show dependency treegraph
 
Reported: 2015-10-21 02:39 EDT by hari gowtham
Modified: 2016-06-16 12:18 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.8.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: glusterfs-tiering-supportability
: 1274411 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:18:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hari gowtham 2015-10-21 02:39:19 EDT
+++ This bug was initially created as a clone of Bug #1221957 +++

GlusterFS 3.7.0 has marked data-tiering as an 'experimental' feature. Basic functionality for data-tiering is available, but with many restrictions and known issues.

This bug tracks the improvements made to tiering. Bug reports to improve tiering in the 3.7 release should have 'glusterfs-tiering-supportability' in the 'blocks' field.

--- Additional comment from Niels de Vos on 2015-05-15 08:52:09 EDT ---



--- Additional comment from Niels de Vos on 2015-06-02 04:20:19 EDT ---

The required changes to fix this bug have not made it into glusterfs-3.7.1. This bug is now getting tracked for glusterfs-3.7.2.

--- Additional comment from Niels de Vos on 2015-06-20 06:08:21 EDT ---

Unfortunately glusterfs-3.7.2 did not contain a code change that was associated with this bug report. This bug is now proposed to be a blocker for glusterfs-3.7.3.

--- Additional comment from Kaushal on 2015-07-30 09:17:47 EDT ---

This bug could not be fixed in time for glusterfs-3.7.3. This is now being tracked for being fixed in glusterfs-3.7.4.
Comment 1 Vijay Bellur 2015-10-21 02:46:08 EDT
REVIEW: http://review.gluster.org/12407 (Tier/cli: removing warning message for tiering) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Vijay Bellur 2015-10-21 16:39:08 EDT
COMMIT: http://review.gluster.org/12407 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 802b24d4d9da09dfb1479eb54bd4a74f678bc97e
Author: hari gowtham <hgowtham@redhat.com>
Date:   Wed Oct 21 12:12:09 2015 +0530

    Tier/cli: removing warning message for tiering
    
    The warning message for tiering being under experimental staus is removed.
    
    Change-Id: I7d1d535d380b672c70f03ecc0d24a113600ea43f
    BUG: 1273726
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/12407
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2015-10-28 08:28:29 EDT
This bug could not be fixed in time for glusterfs-3.7.4 or glusterfs-3.7.5. This is now being tracked for being fixed in glusterfs-3.7.6.
Comment 4 Niels de Vos 2016-06-16 12:18:09 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.