Bug 1221969 - tiering: use sperate log/socket/pid file for tiering
Summary: tiering: use sperate log/socket/pid file for tiering
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact: bugs@gluster.org
URL:
Whiteboard: TIERING
Depends On: 1221970 1226167
Blocks: glusterfs-tiering-supportability 1229269 1260923 1273726 1274411
TreeView+ depends on / blocked
 
Reported: 2015-05-15 11:14 UTC by Mohammed Rafi KC
Modified: 2015-10-30 17:32 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1221970 (view as bug list)
Environment:
Last Closed: 2015-06-02 08:02:56 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohammed Rafi KC 2015-05-15 11:14:32 UTC
Description of problem:



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-05-28 19:15:35 UTC
REVIEW: http://review.gluster.org/10980 (tiering/rebalance: Use separate pid/socket file for tiering) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-06-01 04:38:29 UTC
COMMIT: http://review.gluster.org/10980 committed in release-3.7 by Kaushal M (kaushal@redhat.com) 
------
commit 3ea46dca41d0a006576214b2d71a462ee6866c4d
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Fri May 15 16:03:00 2015 +0530

    tiering/rebalance: Use separate pid/socket file for tiering
    
            Back port of http://review.gluster.org/10792
    
    When promotion/demotion daemon starts, it uses the same pidfile
    as rebalance. This patch will introduce a different pid file
    for the same.
    
     >Change-Id: Ic484c53f51e00ae6b2d697748a9600b14829e23b
     >BUG: 1221970
     >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
     >Reviewed-on: http://review.gluster.org/10792
     >Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
     >Tested-by: Gluster Build System <jenkins@build.gluster.com>
     >Tested-by: NetBSD Build System
    
    Change-Id: Idda13e983ffd443672aee0873ee51e8cc7089c49
    BUG: 1221969
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/10980
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Joseph Fernandes
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 3 Niels de Vos 2015-06-02 08:02:56 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.1, please reopen this bug report.

glusterfs-3.7.1 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.packaging/1
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.